Bug 57329 - addition of library: zipios
Summary: addition of library: zipios
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: abiword (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Aaron Brown
URL: zipios.sourceforge.net
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-12-10 15:35 UTC by Rui Miguel Seabra
Modified: 2007-04-18 16:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-08 05:59:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Rui Miguel Seabra 2001-12-10 15:35:00 UTC
zipios is c++ library for handling zip files which seems interesting, and
is a requirement for abiword openwriter plugin

From the website:
 Zipios++ is a java.util.zip-like C++ library for reading and writing Zip
files. Access to individual entries is provided through standard C++
iostreams. A simple read-only virtual file system that mounts regular
directories and zip files is also provided.

I put this as a bug on zlib because I didn't know better.

Comment 1 Trond Eivind Glomsrxd 2001-12-10 20:07:15 UTC
refiling against abiword... is it useful for AbiWord?

Comment 2 Rui Miguel Seabra 2001-12-10 23:35:45 UTC
Yes, it is. I forgot that abiword is shipped with redhat :)
The OpenWriter abiword plugin requires zipios.
Since abiword, with the openwriter plugin, is able to get the gist of open
writer docs, it is an indirect dependency of abiword.

thanks, rms

Comment 3 Jeremy Katz 2002-07-18 04:26:30 UTC
We don't ship the plugin and don't generally add libraries unless there are
things actually depending on them which we ship.


Note You need to log in before you can comment on or make changes to this bug.