Bug 573317 - [abrt] crash in gpodder-2.1-3.fc12: welcome.py:54:on_btnCancel_clicked:AttributeError: 'gPodderWelcome' object has no attribute 'gPodderWelcome'
Summary: [abrt] crash in gpodder-2.1-3.fc12: welcome.py:54:on_btnCancel_clicked:Attrib...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gpodder
Version: 12
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jef Spaleta
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:26a939b3
: 578606 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-03-14 03:05 UTC by Dale Wilcox
Modified: 2010-06-16 01:31 UTC (History)
6 users (show)

Fixed In Version: python-mygpoclient-1.4-1.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-20 18:46:55 UTC


Attachments (Terms of Use)
File: backtrace (542 bytes, text/plain)
2010-03-14 03:05 UTC, Dale Wilcox
no flags Details

Description Dale Wilcox 2010-03-14 03:05:29 UTC
abrt 1.0.8 detected a crash.

architecture: i686
cmdline: /usr/bin/python /usr/bin/gpodder itms://itunes.apple.com/us/podcast/insight-for-living-daily-broadcast/id89603501?ign-msr=http%3A%2F%2Fdaily.insight.org%2Fsite%2FSurvey%3FSURVEY_ID%3D1180%26ACTION_REQUIRED%3DURI_ACTION_USER_REQUESTS
comment: attempting to download a podcast
component: gpodder
executable: /usr/bin/gpodder
kernel: 2.6.32.9-70.fc12.i686.PAE
package: gpodder-2.1-3.fc12
reason: welcome.py:54:on_btnCancel_clicked:AttributeError: 'gPodderWelcome' object has no attribute 'gPodderWelcome'
release: Fedora release 12 (Constantine)

backtrace
-----
welcome.py:54:on_btnCancel_clicked:AttributeError: 'gPodderWelcome' object has no attribute 'gPodderWelcome'

Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/gpodder/gtkui/interface/welcome.py", line 54, in on_btnCancel_clicked
    self.gPodderWelcome.destroy()
AttributeError: 'gPodderWelcome' object has no attribute 'gPodderWelcome'

Local variables in innermost frame:
button: <gtk.Button object at 0xa2a2fcc (GtkButton at 0xa22a498)>
self: <gpodder.gtkui.interface.welcome.gPodderWelcome object at 0xa2a132c>

How to reproduce
-----
1. Attempting to dowload podcast
2.
3.

Comment 1 Dale Wilcox 2010-03-14 03:05:31 UTC
Created attachment 399936 [details]
File: backtrace

Comment 2 Ville-Pekka Vainio 2010-03-14 10:19:09 UTC
Reported upstream: https://bugs.gpodder.org/show_bug.cgi?id=941

It seems like this could be a race condition of some sort, as I can sometimes reproduce it and sometimes I can't. In case upstream (or Jeff) doesn't have any good suggestions, I may have to close this as cantfix.

Comment 3 Ville-Pekka Vainio 2010-03-31 19:19:38 UTC
*** Bug 578606 has been marked as a duplicate of this bug. ***

Comment 4 ericbotton 2010-04-29 21:16:07 UTC
Package: gpodder-2.1-3.fc12
Architecture: x86_64
OS Release: Fedora release 12 (Constantine)


How to reproduce
-----
1. after installing fedora rpm, run setup
2. ask to get podcasts from my.gpodder.com|org or whatever
3.crash

Comment 5 Fedora Update System 2010-05-03 10:26:34 UTC
python-mygpoclient-1.4-1.fc12,gpodder-2.3-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/python-mygpoclient-1.4-1.fc12,gpodder-2.3-1.fc12

Comment 6 Fedora Update System 2010-05-04 06:03:06 UTC
python-mygpoclient-1.4-1.fc12, gpodder-2.3-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update python-mygpoclient gpodder'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/python-mygpoclient-1.4-1.fc12,gpodder-2.3-1.fc12

Comment 7 Daniel Scott 2010-05-12 14:24:13 UTC
Package: gpodder-2.1-3.fc12
Architecture: x86_64
OS Release: Fedora release 12 (Constantine)


How to reproduce
-----
1. Cancel the initial dialog box 'gPodder startup assistant
2.
3.

Comment 8 Fedora Update System 2010-05-20 18:46:45 UTC
python-mygpoclient-1.4-1.fc12, gpodder-2.3-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 jason.prokopowich 2010-06-16 01:30:01 UTC
Issue persists,

welcome.py:50:on_setup_my_gpodder:AttributeError: 'gPodderWelcome' object has no attribute 'gPodderWelcome'

Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/gpodder/gtkui/interface/welcome.py", line 50, in on_setup_my_gpodder
    self.gPodderWelcome.destroy()
AttributeError: 'gPodderWelcome' object has no attribute 'gPodderWelcome'

Local variables in innermost frame:
gpodder: <gtk.Button object at 0x1927190 (GtkButton at 0x1a7f4c0)>
self: <gpodder.gtkui.interface.welcome.gPodderWelcome object at 0x192bb10>


1. created gpodder account
2. Clicked Down my subscriptions from my.podder.org
3.

Comment 10 jason.prokopowich 2010-06-16 01:31:24 UTC
  Installing     : python-mygpoclient-1.4-1.fc12.noarch                                                                                                     1/5 
  Installing     : python-eyed3-0.6.17-3.fc12.noarch                                                                                                        2/5 
  Installing     : python-mutagen-1.16-2.fc12.noarch                                                                                                        3/5 
  Installing     : python-gpod-0.7.2-8.fc12.x86_64                                                                                                          4/5 
  Installing     : gpodder-2.3-4.fc12.noarch


Note You need to log in before you can comment on or make changes to this bug.