Bug 57354 - kernel-2.4.16-0.6 fails to boot
kernel-2.4.16-0.6 fails to boot
Status: CLOSED WONTFIX
Product: Red Hat Raw Hide
Classification: Retired
Component: kernel (Show other bugs)
1.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-10 14:18 EST by Need Real Name
Modified: 2015-01-04 17:01 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-26 00:36:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-12-10 14:18:16 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.5) Gecko/20011113

Description of problem:
When booting the newly compiled kernel it hangs at:
(scsi0) Downloading sequencer code...

Version-Release number of selected component (if applicable):
see above

How reproducible:
Always

Steps to Reproduce:
1. Boot the new kernel
2.
3.
	

Actual Results:  (scsi0) Downloading sequencer code...

Expected Results:  (scsi0) Downloading sequencer code... 436 instructions
downloaded (or whatever the number of instructions to download for
kernel-2.4.16-0.6, 436 is from kernel-2.4.9-13)

Additional info:

#>rpm -q modutils binutils gcc sh-utils bash patch gnupg
modutils-2.4.12-2
binutils-2.11.92.0.7-2 (fails to build with 2.11.92.0.12-2)
gcc-3.1-0.10
sh-utils-2.0.11-7
bash-2.05a-1
patch-2.5.4-10
gnupg-1.0.6-3

lspci -v
00:0a.0 SCSI storage controller: Adaptec AIC-7881U (rev 01)
        Subsystem: Adaptec AHA-2940UW SCSI Host Adapter
        Flags: bus master, medium devsel, latency 64, IRQ 9
        I/O ports at e800 [size=256]
        Memory at ec001000 (32-bit, non-prefetchable) [size=4K]
        Expansion ROM at ea000000 [disabled] [size=64K]

/etc/modutils.conf:
alias scsi_hostadapter aic7xxx
(all previous kernels have booted without problems. Does this kernel enable
the new driver from adaptec as default? Previous kernels, up to 2.4.9??
used the old driver. Had speed problems on another box with this driver,
compared to the old driver, but no boot problems)
Comment 1 Arjan van de Ven 2001-12-13 04:04:56 EST
Still the same driver.
Do you have any idea what the last kernel was that did boot ?
(makes searching for the breaking change simpler ;)
Comment 2 Need Real Name 2001-12-17 17:06:24 EST
Had no success with kernels-2.4.16 at all. Kernels built from source are
2.4.16-0.6, 0.11, 0.13, see below. The unresolved symbols should not affect the
boot, is only for information. The first two kernels were built with 
binutils-2.11.92.0.7-2, the last one with binutils-2.11.92.0.12-4. All are built
with gcc-3.1-0.10, glibc-2.2.4-20, modutils-2.4.12-3 installed.
Kernels between 2.4.9 and 2.4.16 have not been built from source due to either
space problems or failures when compiling.

kernel-2.4.16-0.6.src.rpm:
depmod:*** Unresolved symbols in
/lib/modules/2.4.16-0.6/kernel/drivers/char/ip2main.o
depmod:         iiEllisCleanup

kernel-2.4.16-0.11.src.rpm:
depmod: *** Unresolved symbols in
/lib/modules/2.4.16-0.11/kernel/drivers/char/drm/sis.o
depmod:         sis_malloc_Ra3329ed5
depmod:         sis_free_Rced25333

kernel-2.4.16-0.13.src.rpm:
depmod: *** Unresolved symbols in
/lib/modules/2.4.16-0.13/kernel/drivers/char/drm/sis.o
depmod:         sis_malloc_Ra3329ed5
depmod:         sis_free_Rced25333
Comment 3 Need Real Name 2001-12-18 13:49:58 EST
Now also kernel-2.4.9-18 is in the unbootable kernel collection. Hangs at the
same place as kernels-2.4.16-0.x. The latest kernel booting is 2.4.9-13.
However, it is downloaded, not natively compiled. The latest natively compiled
kernel is 2.4.9-0.5. The following modules are loaded in the current running
kernel (2.4.9-13):
aic7xxx               114624   7
sd_mod                 11676   7
scsi_mod               98424   2 [aic7xxx sd_mod]
Comment 4 Arjan van de Ven 2001-12-18 15:14:04 EST
gcc-3.1 is unfortionatly not yet suitable for compiling kernels.....
Comment 5 Need Real Name 2001-12-18 17:51:18 EST
Are you sure it's the compiler, the kernel is pure c-code? Maybe the kernel is
at fault... Also, when compiling with gcc-3.1 _numerous_ warnings are issued,
one for example is inline assembly for calculating checksums, which fails, etc...

Note You need to log in before you can comment on or make changes to this bug.