Bug 573639 - [rhn.webqa] missing 78 packages in rhel-i386-server-5
[rhn.webqa] missing 78 packages in rhel-i386-server-5
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: releng (Show other bugs)
5.5
All Linux
low Severity medium
: rc
: ---
Assigned To: Daniel Mach
Release Test Team
:
Depends On:
Blocks: 581474
  Show dependency treegraph
 
Reported: 2010-03-15 09:04 EDT by Garik Khachikyan
Modified: 2015-01-04 16:57 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-08 08:17:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
missing rhnlib (7.20 KB, image/jpeg)
2010-03-18 11:13 EDT, Petr Sklenar
no flags Details
missing rhn-setup-gnome-0.4.20-33.el5.noarch when installin i386 XEN PV guest with @Everything (32.68 KB, image/png)
2010-03-22 10:47 EDT, Jan Hutař
no flags Details

  None (edit)
Description Garik Khachikyan 2010-03-15 09:04:23 EDT
Description of problem:
During Satellite sync of the rhel-i386-server-5 channel webqa gives "Extinct package <package_name>"

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. try satellite-sync -c rhel-i386-server-5
2.
3.
  
Actual results:
78 packages not get synced

Expected results:
All current packages of rhel-i386-server-5 should be fetched.

Additional info:
---
04:41:58    Fetching any missing RPMs: rhel-i386-server-5 (78)
04:42:06       1/78 Extinct package:  openssh-4.3p2-36.el5_4.3.i386.rpm
04:42:06       2/78 Extinct package:
openssh-clients-4.3p2-36.el5_4.3.i386.rpm
04:42:06       3/78 Extinct package:
openssh-askpass-4.3p2-36.el5_4.3.i386.rpm
04:42:07       4/78 Extinct package:
openssh-server-4.3p2-36.el5_4.3.i386.rpm
04:42:07       5/78 Extinct package:
kernel-headers-2.6.18-164.9.1.el5.i386.rpm
04:42:07       6/78 Extinct package:  kernel-PAE-2.6.18-164.9.1.el5.i686.rpm
04:42:07       7/78 Extinct package:
kernel-debug-2.6.18-164.9.1.el5.i686.rpm
04:42:08       8/78 Extinct package:
kernel-PAE-devel-2.6.18-164.9.1.el5.i686.rpm
04:42:08       9/78 Extinct package:
kernel-debug-devel-2.6.18-164.9.1.el5.i686.rpm
04:42:08      10/78 Extinct package:
kernel-doc-2.6.18-164.9.1.el5.noarch.rpm
04:42:08      11/78 Extinct package:
kernel-devel-2.6.18-164.9.1.el5.i686.rpm
04:42:09      12/78 Extinct package:  dbus-1.1.2-12.el5_4.1.i386.rpm
04:42:09      13/78 Extinct package:  dbus-x11-1.1.2-12.el5_4.1.i386.rpm
04:42:09      14/78 Extinct package:  dbus-devel-1.1.2-12.el5_4.1.i386.rpm
04:42:09      15/78 Extinct package:  dbus-libs-1.1.2-12.el5_4.1.i386.rpm
04:42:10      16/78 Extinct package:
kernel-PAE-2.6.18-164.10.1.el5.i686.rpm
04:42:10      17/78 Extinct package:
kernel-devel-2.6.18-164.10.1.el5.i686.rpm
04:42:10      18/78 Extinct package:
kernel-doc-2.6.18-164.10.1.el5.noarch.rpm
04:42:10      19/78 Extinct package:
kernel-PAE-devel-2.6.18-164.10.1.el5.i686.rpm
04:42:11      20/78 Extinct package:
kernel-debug-devel-2.6.18-164.10.1.el5.i686.rpm
04:42:11      21/78 Extinct package:
kernel-headers-2.6.18-164.10.1.el5.i386.rpm
04:42:11      22/78 Extinct package:
kernel-debug-2.6.18-164.10.1.el5.i686.rpm
04:42:11      23/78 Extinct package:  gcc-objc++-4.1.2-46.el5_4.2.i386.rpm
04:42:12      24/78 Extinct package:  gcc-gnat-4.1.2-46.el5_4.2.i386.rpm
04:42:12      25/78 Extinct package:  gcc-java-4.1.2-46.el5_4.2.i386.rpm
04:42:12      26/78 Extinct package:  libgfortran-4.1.2-46.el5_4.2.i386.rpm
04:42:12      27/78 Extinct package:  gcc-4.1.2-46.el5_4.2.i386.rpm
04:42:13      28/78 Extinct package:  libmudflap-4.1.2-46.el5_4.2.i386.rpm
04:42:13      29/78 Extinct package:  libstdc++-4.1.2-46.el5_4.2.i386.rpm
04:42:13      30/78 Extinct package:  gcc-gfortran-4.1.2-46.el5_4.2.i386.rpm
04:42:13      31/78 Extinct package:
libmudflap-devel-4.1.2-46.el5_4.2.i386.rpm
04:42:13      32/78 Extinct package:  gcc-objc-4.1.2-46.el5_4.2.i386.rpm
04:42:14      33/78 Extinct package:  gcc-c++-4.1.2-46.el5_4.2.i386.rpm
04:42:14      34/78 Extinct package:
libstdc++-devel-4.1.2-46.el5_4.2.i386.rpm
04:42:16      35/78 Extinct package:  libgnat-4.1.2-46.el5_4.2.i386.rpm
04:42:16      36/78 Extinct package:  libobjc-4.1.2-46.el5_4.2.i386.rpm
04:42:16      37/78 Extinct package:  cpp-4.1.2-46.el5_4.2.i386.rpm
04:42:16      38/78 Extinct package:  php-dba-5.1.6-24.el5_4.5.i386.rpm
04:42:17      39/78 Extinct package:  php-devel-5.1.6-24.el5_4.5.i386.rpm
04:42:17      40/78 Extinct package:  php-mbstring-5.1.6-24.el5_4.5.i386.rpm
04:42:17      41/78 Extinct package:  php-mysql-5.1.6-24.el5_4.5.i386.rpm
04:42:17      42/78 Extinct package:  php-snmp-5.1.6-24.el5_4.5.i386.rpm
04:42:18      43/78 Extinct package:  php-cli-5.1.6-24.el5_4.5.i386.rpm
04:42:18      44/78 Extinct package:  php-5.1.6-24.el5_4.5.i386.rpm
04:42:18      45/78 Extinct package:  php-common-5.1.6-24.el5_4.5.i386.rpm
04:42:18      46/78 Extinct package:  php-bcmath-5.1.6-24.el5_4.5.i386.rpm
04:42:18      47/78 Extinct package:  php-odbc-5.1.6-24.el5_4.5.i386.rpm
04:42:19      48/78 Extinct package:  php-ldap-5.1.6-24.el5_4.5.i386.rpm
04:42:19      49/78 Extinct package:  php-pdo-5.1.6-24.el5_4.5.i386.rpm
04:42:19      50/78 Extinct package:  php-xml-5.1.6-24.el5_4.5.i386.rpm
04:42:19      51/78 Extinct package:  php-xmlrpc-5.1.6-24.el5_4.5.i386.rpm
04:42:19      52/78 Extinct package:  php-gd-5.1.6-24.el5_4.5.i386.rpm
04:42:20      53/78 Extinct package:  php-soap-5.1.6-24.el5_4.5.i386.rpm
04:42:20      54/78 Extinct package:  php-imap-5.1.6-24.el5_4.5.i386.rpm
04:42:20      55/78 Extinct package:  php-pgsql-5.1.6-24.el5_4.5.i386.rpm
04:42:20      56/78 Extinct package:  php-ncurses-5.1.6-24.el5_4.5.i386.rpm
04:42:21      57/78 Extinct package:  dhcp-3.0.5-21.el5_4.1.i386.rpm
04:42:21      58/78 Extinct package:  dhcp-devel-3.0.5-21.el5_4.1.i386.rpm
04:42:21      59/78 Extinct package:  dhclient-3.0.5-21.el5_4.1.i386.rpm
04:42:21      60/78 Extinct package:  cups-1.3.7-11.el5_4.5.i386.rpm
04:42:21      61/78 Extinct package:  cups-lpd-1.3.7-11.el5_4.5.i386.rpm
04:42:22      62/78 Extinct package:  cups-devel-1.3.7-11.el5_4.5.i386.rpm
04:42:22      63/78 Extinct package:  cups-libs-1.3.7-11.el5_4.5.i386.rpm
04:42:22      64/78 Extinct package:  glibc-devel-2.5-42.el5_4.3.i386.rpm
04:42:22      65/78 Extinct package:  nscd-2.5-42.el5_4.3.i386.rpm
04:42:23      66/78 Extinct package:  glibc-utils-2.5-42.el5_4.3.i386.rpm
04:42:23      67/78 Extinct package:  glibc-headers-2.5-42.el5_4.3.i386.rpm
04:42:23      68/78 Extinct package:  glibc-2.5-42.el5_4.3.i386.rpm
04:42:23      69/78 Extinct package:  glibc-common-2.5-42.el5_4.3.i386.rpm
04:42:24      70/78 Extinct package:  glibc-2.5-42.el5_4.3.i686.rpm
04:42:24      71/78 Extinct package:
kernel-headers-2.6.18-164.11.1.el5.i386.rpm
04:42:24      72/78 Extinct package:
kernel-debug-devel-2.6.18-164.11.1.el5.i686.rpm
04:42:24      73/78 Extinct package:
kernel-PAE-2.6.18-164.11.1.el5.i686.rpm
04:42:24      74/78 Extinct package:
kernel-PAE-devel-2.6.18-164.11.1.el5.i686.rpm
04:42:25      75/78 Extinct package:
kernel-debug-2.6.18-164.11.1.el5.i686.rpm
04:42:26      76/78 Extinct package:
kernel-devel-2.6.18-164.11.1.el5.i686.rpm
04:42:26      77/78 Extinct package:
kernel-doc-2.6.18-164.11.1.el5.noarch.rpm
04:42:26      78/78 Extinct package:
iscsi-initiator-utils-6.2.0.871-0.12.el5_4.1.i386.rpm
04:42:26    Fetching any missing RPMs: rhn-tools-rhel-i386-server-5 (2)
04:42:26 Error: expected 52612 bytes, got 52452 bytes
04:42:27 Error: expected 52612 bytes, got 52452 bytes
04:42:27 Error: expected 52612 bytes, got 52452 bytes
04:42:27       1/2 Fetch unsuccessful:
rhn-virtualization-host-5.3.0-15.el5sat.noarch.rpm
04:42:27 Error: expected 21188 bytes, got 21028 bytes
04:42:28 Error: expected 21188 bytes, got 21028 bytes
04:42:28 Error: expected 21188 bytes, got 21028 bytes
04:42:28       2/2 Fetch unsuccessful:
rhn-virtualization-common-5.3.0-15.el5sat.noarch.rpm 
---
Comment 1 Garik Khachikyan 2010-03-15 09:06:43 EDT
adding Jan H. & Jay T. to the cc list.
Comment 2 Daniel Mach 2010-03-15 10:10:20 EDT
Garik, could you provide more information, please?
I know nothing about how the satellite-sync works.

Are the "Extinct package" messages all right?
Or is the problem only in "Error: expected X bytes, got Y bytes" messages?
Comment 3 Garik Khachikyan 2010-03-15 10:30:42 EDT
Hi Daniel,

Actually - "Extinct package" error is the main problem of the bug (would be glad if the package length issues for those 2 packages you would get fixed)

Let me rephrase the issue: for that list of packages in webqa UI when requesting them to download - you'ld expect HTTP 404 error page like the package could not be found for download.

---
https://content-web.rhn.webqa.redhat.com/rhn/public/NULL/iscsi-initiator-utils/6.2.0.871-0.12.el5_4.1/i386/iscsi-initiator-utils-6.2.0.871-0.12.el5_4.1.i386.rpm?__gda__=1268663962_aef029253bdc9c89f82c8a48a0d6abc4
---
Comment 5 Daniel Mach 2010-03-16 11:49:15 EDT
KS trees updated to match latest RC trees.
You should be able to sync everything you need.
Comment 6 Petr Sklenar 2010-03-18 11:13:11 EDT
Created attachment 401040 [details]
missing rhnlib

Synced again from webqa today and we are not able kickstart anything, there are missing packages. There are screenshot in attachment.

yumdownloader of this rhnlib-2.5.22-2.el5.noarch.rpm from synced satellite works - so its some issue in kickstart.
Comment 7 Garik Khachikyan 2010-03-22 09:57:35 EDT
by the way: KS against 5.4 tree went okey.
Comment 8 Garik Khachikyan 2010-03-22 09:57:58 EDT
we tried at least for: x86_64 & i386
Comment 9 Jan Hutař 2010-03-22 10:47:16 EDT
Created attachment 401787 [details]
missing rhn-setup-gnome-0.4.20-33.el5.noarch when installin i386 XEN PV guest with @Everything
Comment 11 Garik Khachikyan 2010-03-24 09:54:58 EDT
# COMMENT

For me just did re-sync of 32bit and 64bit RHEL5 channels - all extincts just gone !!!

Will be doing the provisioning as well to see that all is fine with KS trees there.

@Jan: feel free to put your experience here.
thanks.
Comment 12 Garik Khachikyan 2010-06-08 08:17:23 EDT
# VERIFIED/CLOSED

the issue is gone. closing.

Note You need to log in before you can comment on or make changes to this bug.