Bug 573642 - [abrt] crash in wallpapoz-0.4.1-18.svn92_trunk.fc12: daemon_wallpapoz:161:<module>:IndexError: list index out of range
Summary: [abrt] crash in wallpapoz-0.4.1-18.svn92_trunk.fc12: daemon_wallpapoz:161:<mo...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: wallpapoz
Version: 12
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Mamoru TASAKA
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:9bd11927
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-03-15 13:23 UTC by Gerry Tool
Modified: 2010-06-15 15:52 UTC (History)
3 users (show)

Fixed In Version: wallpapoz-0.4.1-20.svn92_trunk.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-03-30 02:12:35 UTC


Attachments (Terms of Use)
File: backtrace (1.96 KB, text/plain)
2010-03-15 13:23 UTC, Gerry Tool
no flags Details

Description Gerry Tool 2010-03-15 13:23:39 UTC
abrt 1.0.8 detected a crash.

architecture: x86_64
cmdline: python /usr/bin/daemon_wallpapoz
component: wallpapoz
executable: /usr/bin/daemon_wallpapoz
kernel: 2.6.32.9-70.fc12.x86_64
package: wallpapoz-0.4.1-18.svn92_trunk.fc12
reason: daemon_wallpapoz:161:<module>:IndexError: list index out of range
release: Fedora release 12 (Constantine)

backtrace
-----
daemon_wallpapoz:161:<module>:IndexError: list index out of range

Traceback (most recent call last):
  File "/usr/bin/daemon_wallpapoz", line 161, in <module>
    wallpapoz_system.change_wallpaper(worklist[cur_desk][number[cur_desk]])
IndexError: list index out of range

Local variables in innermost frame:
total_workspaces: 4
conf_type: u'workspace'
random: <module 'random' from '/usr/lib64/python2.6/random.pyc'>
number: array('i', [0, 0, 0, 0])
previous_index: 0
GInitiallyUnowned: <class 'gtk.__main__.GInitiallyUnowned'>
array: <module 'array' from '/usr/lib64/python2.6/lib-dynload/arraymodule.so'>
style: 'scaled'
previous_desktop: 0
gtk: <module 'gtk' from '/usr/lib64/python2.6/site-packages/gtk-2.0/gtk/__init__.pyc'>
__package__: None
delay: 300.0
WallpapozSystem: <class wallpapoz_system.WallpapozSystem at 0xd03170>
available_style: {'1': 'stretched', '0': 'centered', '3': 'zoom', '2': 'scaled', '4': 'wallpaper'}
__doc__: None
string: <module 'string' from '/usr/lib64/python2.6/string.pyc'>
__builtins__: <module '__builtin__' (built-in)>
__file__: '/usr/bin/daemon_wallpapoz'
wallpapoz_system: <wallpapoz_system.WallpapozSystem instance at 0xd4eb48>
randomvar: 0
wallpaper_list: [<AsyncIndex(Thread-1, started 140003900634896)>, <AsyncIndex(Thread-2, stopped 140003890145040)>, <AsyncIndex(Thread-3, stopped 140003879655184)>, <AsyncIndex(Thread-4, stopped 140003869165328)>]
sys: <module 'sys' (built-in)>
__name__: '__main__'
wallpapozxml: <xml_processing.XMLProcessing instance at 0xbdb830>
cur_desk: 1
i: 3
AsyncIndex: <class '__main__.AsyncIndex'>
iter: [u'/usr/share/backgrounds/constantine/default/constantine.xml']
threading: <module 'threading' from '/usr/lib64/python2.6/threading.pyc'>
XMLProcessing: <class xml_processing.XMLProcessing at 0xd27530>
pathname: '/usr/bin'
time: <module 'time' from '/usr/lib64/python2.6/lib-dynload/timemodule.so'>
worklist: [[u'/usr/share/backgrounds/constantine/default/constantine.xml']]
os: <module 'os' from '/usr/lib64/python2.6/os.pyc'>

Comment 1 Gerry Tool 2010-03-15 13:23:41 UTC
Created attachment 400210 [details]
File: backtrace

Comment 2 Joel Uckelman 2010-03-15 20:35:13 UTC

How to reproduce
-----
No idea how this crash was triggered, sorry.

Comment 3 Mamoru TASAKA 2010-03-17 16:29:59 UTC
Well, I hope that next -20 will fix this issue, hopefully.

Comment 4 Fedora Update System 2010-03-17 17:00:07 UTC
wallpapoz-0.4.1-20.svn92_trunk.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/wallpapoz-0.4.1-20.svn92_trunk.fc12

Comment 5 Fedora Update System 2010-03-17 17:00:58 UTC
wallpapoz-0.4.1-20.svn92_trunk.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/wallpapoz-0.4.1-20.svn92_trunk.fc11

Comment 6 Joel Uckelman 2010-03-19 20:48:47 UTC

How to reproduce
-----
No idea what causes this.

Comment 7 Fedora Update System 2010-03-20 03:49:12 UTC
wallpapoz-0.4.1-20.svn92_trunk.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update wallpapoz'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/wallpapoz-0.4.1-20.svn92_trunk.fc12

Comment 8 Fedora Update System 2010-03-30 02:12:30 UTC
wallpapoz-0.4.1-20.svn92_trunk.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2010-03-30 02:26:24 UTC
wallpapoz-0.4.1-20.svn92_trunk.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Joel Uckelman 2010-04-06 17:32:00 UTC
I'm still getting this same crash with 0.4.1-20.svn92_trunk.fc12.

Comment 11 Mamoru TASAKA 2010-04-06 17:51:14 UTC
(In reply to comment #10)
> I'm still getting this same crash with 0.4.1-20.svn92_trunk.fc12.    

Then please provide how to reproduce this issue.

Comment 12 Joel Uckelman 2010-04-06 18:00:17 UTC
(In reply to comment #11)
> (In reply to comment #10)
> > I'm still getting this same crash with 0.4.1-20.svn92_trunk.fc12.    
> 
> Then please provide how to reproduce this issue.    

I can't reproduce it at will, but it keeps happening for me. The bug reporting tool seems to think the stack trace matches the one reported here.


Note You need to log in before you can comment on or make changes to this bug.