Bug 57365 - Fails to build with pam-0.75-20
Summary: Fails to build with pam-0.75-20
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: XFree86 (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-12-10 21:15 UTC by Enrico Scholz
Modified: 2007-04-18 16:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-29 18:11:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Enrico Scholz 2001-12-10 21:15:46 UTC
Description of Problem:

When trying to rebuild XFree86-4.1.0-8 with installed pam-devel-0.75-20 I get:

| $ LANG=C rpm --rebuild XFree86-4.1.0-8.src.rpm 
| Installing XFree86-4.1.0-8.src.rpm
| error: failed build dependencies:
|         /lib/libpam.so   is needed by XFree86-4.1.0-8


pam-devel provides /usr/lib/libpam.so but not /lib/libpam.so.

Comment 1 Mike A. Harris 2001-12-29 18:11:50 UTC
pam package *used* to provide /lib/libpam.so symlinks because 7.x
had it stored there.  It is not possible for me to make one single
XFree86 src.rpm package that compiles everywhere with any pam package.
The 4.1.0 packages will remain as they are, for 7.x compatibility.

When 4.2.0 is ready, I may change this, but IMHO it is a pam package
backward compatibility issue.

Comment 2 Mike A. Harris 2002-01-23 16:52:59 UTC
Works for me in 4.1.0-15 ok using a build system with all updates
applied.


Note You need to log in before you can comment on or make changes to this bug.