Bug 57399 - long lines should wrap
Summary: long lines should wrap
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: xmlto   
(Show other bugs)
Version: 1.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Tim Waugh
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-12-11 17:18 UTC by Tammy Fox
Modified: 2007-04-18 16:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-11 17:48:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Tammy Fox 2001-12-11 17:18:32 UTC
I showed johnsonm the output of xmlto man foo.xml, and he
suggested that you line wrap long lines inside <para>s so all
viewers can display them properly.

Comment 1 Tim Waugh 2001-12-11 17:48:20 UTC
The reason it doesn't do this at the moment (except for it being 'out of the 
way') is that it would require the stylesheet to be quite smart about it.  I 
don't know groff well enough to know what things at the beginning of the line 
are 'special'.

As it is, we don't escape things like '\' in a para, which we ought to.  I'd 
rather not have to go hunting for '.' and whatever else as well if I can help 
it. :-)

Which viewers in particular don't display these long lines properly?


Comment 2 Tim Waugh 2002-01-07 16:57:53 UTC
Closing, no input.



Note You need to log in before you can comment on or make changes to this bug.