Bug 57405 - Jumbled input after switching to single user mode.
Jumbled input after switching to single user mode.
Status: CLOSED DUPLICATE of bug 54741
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
7.3
ia64 Linux
high Severity high
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-11 13:39 EST by Matthew Tolentino
Modified: 2014-03-16 22:24 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-11 13:39:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Tolentino 2001-12-11 13:39:24 EST
Description of Problem:
After switching from run-level 5 (init5) to single user (init1), the 
keyboard inputs get jumbled when the user presses enter.  For example, 
when you attempt to change to run-level 5 by entering init 5, you may get 
something like ti5ni echoed back to the screen.  It is the character 
sequence that is echoed that the system attempts to exec, consequently you 
can do next to nothing until you figure out the sequence.  

Another example we worked through was reboot.
user types: reboot
system echoes something weird.
Eventually, we figured out if we typed oroetb the system would reboot.

The sequence appears to be 1,3,5,7,...   2,4,6,8,...  but changes based on 
what is still resident in the input buffer...


Version-Release number of selected component (if applicable):
RC-3.  qa1129, qa1207.  

How Reproducible:
Always

Steps to Reproduce:
1. boot to init 5
2. change to init 1
3. type something intelligible and hit return
4. observe what is spit out...

Actual Results:
Weird output

Expected Results:
expect what the user typed to be echoed and exec'd.

Additional Information:
Comment 1 Bill Nottingham 2001-12-13 12:30:44 EST
This should be fixed with the util-linux errata. It's a login problem.

*** This bug has been marked as a duplicate of 54741 ***

Note You need to log in before you can comment on or make changes to this bug.