Bug 5741 - ftp download of RH 6.1 stops with "Exception occured"
ftp download of RH 6.1 stops with "Exception occured"
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Cristian Gafton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-08 17:20 EDT by tracy
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-01-27 02:46:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description tracy 1999-10-08 17:20:45 EDT
Purchased RH6.0 box set.

Custom installation on host.

Wanted to ftp install RH6.1 from your site.

bootnet.img on box set CDROM did not function properly.

Retrieved copy of bootnet.img from your website.

Booted host with inserted floppy containing bootnet.img

Connection to your ftp site established.

Provided data for custom installation, partitioning, etc.

Some time passed without user input.  Things seemed to be
going well.

Then the following message was displayed:

"Exception occured

Traceback (innermost last):
File "/usr/bin/anaconda.real", line 225, in ?
intf.run(todo,test=test)
File
"/tmp/lib/python1.5/site-packages/text.py", line 1000, in
run rc = apply(step[1](),step[2])
File
"/mnt/redhat/comps/install/6.1/i386/misc/src/trees/hdimage/usr/lib/python1.5/site-packages/textw/packages.py',
line 10,
in __call__  "

Then two icon options are displayed.    OKAY     DEBUG

Selecting DEBUG leads to:

[READING]

Reading package info
./var/tmp/pythonxroo/usr/lib/python1.5/ftplib.py(201)getresp()

Then the following command line prompt is displayed:

(Pdb)

Entering help at the above command line prompt lists several
keywords.  continue is among them.  I entered it as follows:

(Pdb)continue

The following was displayed:

*   install exited abnormally

Then it displayed shutdown processes and ended with,...

you may safely reboot your system.

The above has been repeated yesterday and today.  Same
results.  If OK is selected above where I mentioned chosing
DEBUG, the exit sequence I refer to at the asterisk * above
is presented.

Suggestions?
Comment 1 rcp 1999-10-24 00:26:59 EDT
Error occurs when starting to read package information. End of
traceback shows error coming from File
"/var/tmp/python-root/usr/lib/python1.5/ftplib.py", line 201, in
getresp IOError: [Errno ftp error] 550 pub: No such file or directory.

This was using "ftp.redhat.com" and "/pub/redhat/redhat-6.1/i386/".
Got a CWD error (rather than the "No such file") using the infomagic
mirror.
Comment 2 rcp 1999-10-24 00:30:59 EDT
See also Bug #5483 which appears to be the same problem.
Comment 3 richard.meer 1999-11-02 15:18:59 EST
Hi,
I've had this bug in the instalation of LINUX and some people advised
me to check the RPMS directory for anny files not ending with .RPM
I dis that and foun an log file from my FTP prog. deleted the file
and tryed the install agean, it still did'nt work ( for some other
people this did work !!) Then I compared the files in that dir with
the files on the FTP site and found out that a file called HOWTO-
corean..... something was'nt completly downloaded. I redownloaded
this file and the install worked well !! so check your RPMS dir, it
should be 555.198.893 bytes large, if it is'nt check your RPM files !!
Comment 4 Cristian Gafton 2000-01-27 02:46:59 EST
This is caused by a bad download

Note You need to log in before you can comment on or make changes to this bug.