Bug 574116 - missing dependency: globus-usage-devel
Summary: missing dependency: globus-usage-devel
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: myproxy
Version: el5
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Steve Traylen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-03-16 16:55 UTC by Lev Shamardin
Modified: 2010-04-07 22:16 UTC (History)
2 users (show)

Fixed In Version: myproxy-5.1-2.el4
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-03-24 18:00:48 UTC
Type: ---


Attachments (Terms of Use)

Description Lev Shamardin 2010-03-16 16:55:20 UTC
Description of problem:
myproxy-devel should depend on globus-usage-devel.

Version-Release number of selected component (if applicable):
myproxy-devel-5.1-1.el5 (from koji build)

How reproducible:
always

Steps to Reproduce:
1. install myproxy-devel
2. remove globus-usage-devel
3. pkg-config myproxy --cflags
  
Actual results:
[shamardin@devbox proxytool]$ pkg-config myproxy --cflags
Package globus-usage was not found in the pkg-config search path.
Perhaps you should add the directory containing `globus-usage.pc'
to the PKG_CONFIG_PATH environment variable
Package 'globus-usage', required by 'myproxy', not found

Expected results:
[shamardin@devbox proxytool]$ pkg-config myproxy --cflags
-D_LARGEFILE_SOURCE=1 -D_FILE_OFFSET_BITS=64 -I/usr/include/globus -I/usr/lib/globus/include -I/usr/kerberos/include

Comment 1 Steve Traylen 2010-03-16 17:05:47 UTC
 
Sorry these are not picked up automatically in EPEL. Thanks again.
Since not released yet I'll produce new packages.

Steve

Comment 2 Fedora Update System 2010-03-16 18:35:54 UTC
myproxy-5.1-2.el4 has been submitted as an update for Fedora EPEL 4.
http://admin.fedoraproject.org/updates/myproxy-5.1-2.el4

Comment 3 Fedora Update System 2010-03-16 18:36:36 UTC
myproxy-5.1-2.el5 has been submitted as an update for Fedora EPEL 5.
http://admin.fedoraproject.org/updates/myproxy-5.1-2.el5

Comment 4 Fedora Update System 2010-03-17 19:12:16 UTC
myproxy-5.1-2.el5 has been pushed to the Fedora EPEL 5 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update myproxy'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/myproxy-5.1-2.el5

Comment 5 Fedora Update System 2010-03-17 19:13:23 UTC
myproxy-5.1-2.el4 has been pushed to the Fedora EPEL 4 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update myproxy'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/myproxy-5.1-2.el4

Comment 6 Fedora Update System 2010-03-24 18:00:38 UTC
myproxy-5.1-2.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2010-04-07 22:16:26 UTC
myproxy-5.1-2.el4 has been pushed to the Fedora EPEL 4 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.