Bug 574126 - First run of tasque does not give me any backends to use
Summary: First run of tasque does not give me any backends to use
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: tasque
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: David Kaylor
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 574623 577730 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-03-16 17:18 UTC by Eric Hopper
Modified: 2010-04-09 04:11 UTC (History)
4 users (show)

Fixed In Version: tasque-0.1.9-3.fc13
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-03-30 02:17:08 UTC
Type: ---


Attachments (Terms of Use)
Screenshot of first preferences screen (17.39 KB, image/png)
2010-03-16 17:18 UTC, Eric Hopper
no flags Details

Description Eric Hopper 2010-03-16 17:18:54 UTC
Created attachment 400514 [details]
Screenshot of first preferences screen

Description of problem:
When I start up tasque for the first time I get a preferences screen that asks me to choose a task management system but doesn't give me any choices.

Version-Release number of selected component (if applicable):
tasque-0.1.9-2.fc12.x86_64

How reproducible:
Every time

Steps to Reproduce:
1.Install task on a fresh desktop that's never run it before
2.Start it up
  
Actual results:
I get a screen that asks me to choose a task management system but doesn't give me any choices.

Expected results:
Some choices for a task management system.

Additional info:
If I run tasque from the command line I get this output:

$ tasque 
[Debug]: Tasque remote control active.

** (Tasque:22400): WARNING **: The following assembly referenced from /usr/lib64/tasque/Tasque.exe could not be loaded:
     Assembly:   evolution-sharp    (assemblyref_index=14)
     Version:    5.0.0.0
     Public Key: c46a23b774189844
The assembly was not found in the Global Assembly Cache, a path listed in the MONO_PATH environment variable, or in the location of the executing assembly (/usr/lib64/tasque/).


** (Tasque:22400): WARNING **: Could not load file or assembly 'evolution-sharp, Version=5.0.0.0, Culture=neutral, PublicKeyToken=c46a23b774189844' or one of its dependencies.

** (Tasque:22400): WARNING **: Could not load file or assembly 'evolution-sharp, Version=5.0.0.0, Culture=neutral, PublicKeyToken=c46a23b774189844' or one of its dependencies.
[Warn]: Exception reading types from assembly 'Tasque, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null': The classes in the module cannot be loaded.
[Debug]: Tasque.exe location:  /usr/lib64/tasque/Tasque.exe
[Info]: Searching for Backend DLLs in: /usr/lib64/tasque
[Info]: 	Reading /usr/lib64/tasque/RtmNet.dll
[Debug]: CurrentBackend specified in Preferences: 
[Info]: OnPreferences called
[Debug]: Loading preferences
[Debug]: Called Preferences Init

Comment 1 Eric Hopper 2010-03-16 17:20:31 UTC
After I installed the 'evolution-sharp' package, it worked fine.  Perhaps tasque needs a dependency added or needs to be fixed to work when the dependency isn't available.

Comment 2 Fedora Update System 2010-03-18 02:40:28 UTC
tasque-0.1.9-3.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/tasque-0.1.9-3.fc12

Comment 3 Fedora Update System 2010-03-18 02:44:43 UTC
tasque-0.1.9-3.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/tasque-0.1.9-3.fc13

Comment 4 David Kaylor 2010-03-18 02:50:39 UTC
I reproduced the problem by removing evolution-sharp from my system. Updated
packages with the dependency added have been submitted.

Comment 5 David Kaylor 2010-03-18 02:51:06 UTC
*** Bug 574623 has been marked as a duplicate of this bug. ***

Comment 6 Fedora Update System 2010-03-20 03:40:47 UTC
tasque-0.1.9-3.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update tasque'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/tasque-0.1.9-3.fc12

Comment 7 Fedora Update System 2010-03-20 03:50:28 UTC
tasque-0.1.9-3.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update tasque'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/tasque-0.1.9-3.fc13

Comment 8 Santeri Paavolainen 2010-03-29 06:12:49 UTC
*** Bug 577730 has been marked as a duplicate of this bug. ***

Comment 9 Fedora Update System 2010-03-30 02:17:04 UTC
tasque-0.1.9-3.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2010-04-09 04:11:34 UTC
tasque-0.1.9-3.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.