Bug 57429 - Athlon kernel crashes during boot on Abit KT7A v1.3
Athlon kernel crashes during boot on Abit KT7A v1.3
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2001-12-12 05:01 EST by Toralf
Modified: 2007-04-18 12:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2003-06-07 19:28:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Toralf 2001-12-12 05:01:50 EST
Description of Problem:
On a system with AMD Athlon processor and Abit KT7A v1.3 mainboard, Red Hat
Linux 7.2 will crash during the init phase, but only if athlon kernel is
used, the i686 one works just fine. I am unable to reproduce this problem
on older revisions of the KT7A. 

Version-Release number of selected component (if applicable):
2.4.7-10 or 2.4.9-13; %{ARCH} = "athlon"

How Reproducible:
Every time

Steps to Reproduce:
1. Install Red Hat Linux 7.2
2. Boot the system

Actual Results:
The kernel appears to load correctly, but a crash dump occurs after a few
init steps; it does not happen at the same point every time. The useful
sections of the trace disappear off screen before I'm able to read them
properly, but I suspect that the problem is related to memory accesses.

Expected Results:
The system boot.

Boot in rescue mode, install i686 kernel 
- or -
Replace the mainboard with an older revision, e.g. v1.1, of the same model

Additional Information:
I have tried different versions of the mainboard BIOS, and always get this
problem. On the older (v1.1) board it is the other way around; I never get
this kind of failure no matter what BIOS revision I use.

I suspect that this is really a mainboard issue, but I'm reporting it here
for two reasons:
1. Just to let you (i.e. Red Hat) and everyone else know that there may be
a problem with this particular mainboard, and that a workaround exists. 
2. Maybe you should upgrade the installer to address this kind of problem,
e.g. by allowing the user to select processor type.
Comment 1 Arjan van de Ven 2001-12-13 04:39:45 EST
The cause for this has been found; it's an "experimental" (read "buggy") chipset
feature that some bioses enable; newer kernels will disable this feature again
Comment 2 Eirik Thorsnes 2001-12-15 07:04:53 EST
I have the same problem on Abit KT7A-RAID v1.3, but NOT on same board with
revision 1.0. The problem is worked around by using "noathlon" kernel
commandline. Using the newest kernel (2.4.16) does NOT solve the problem.

Eirik Thorsnes
Comment 3 Eirik Thorsnes 2001-12-15 07:13:04 EST
I'm sorry, the motherboard revision in my last comment should be 1.2 not 1.3.
I'm using the latest bios (rev. 64).

Eirik Thorsnes
Comment 4 Alan Cox 2003-06-07 19:28:05 EDT
Closing: this is the old via chpset flaw that current kernels work around

Note You need to log in before you can comment on or make changes to this bug.