Bug 57432 - Apache segfaults
Apache segfaults
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: apache (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-12 09:59 EST by Matthew Kirkwood
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-21 06:51:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Apache config file (3.92 KB, text/plain)
2001-12-13 07:13 EST, Matthew Kirkwood
no flags Details
Conf file for apache that causes segfaults (43.23 KB, text/plain)
2002-04-01 12:07 EST, Darrell Duane
no flags Details

  None (edit)
Description Matthew Kirkwood 2001-12-12 09:59:57 EST
Description of Problem:

My custom httpd.conf causes apache to segfault when it receives a connection.


Version-Release number of selected component (if applicable):

$ rpm -q apache
apache-1.3.20-16


How Reproducible:

Works every time for me (on a dual P3).


Steps to Reproduce:

Copy the (shortly to be attached) httpd.conf to /etc/httpd/conf and restart
apache.  Upon connect, we see:

[Wed Dec 12 13:20:52 2001] [notice] child pid 5345 exit signal Segmentation
fault (11)
Comment 1 Matthew Kirkwood 2001-12-13 07:13:01 EST
Created attachment 40475 [details]
Apache config file
Comment 2 Matthew Kirkwood 2001-12-13 07:39:51 EST
More info -- it's an SSL thing

I managed to run it under gdb (with "-X") and got:

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 1024 (LWP 10270)]
0x403ddc66 in ssl_hook_NewConnection () from /etc/httpd/modules/libssl.so
(gdb) bt
#0  0x403ddc66 in ssl_hook_NewConnection () from /etc/httpd/modules/libssl.so
#1  0x0805e3c6 in ap_start_restart () at eval.c:41
#2  0x0805f656 in ap_child_terminate () at eval.c:41
#3  0x0805f83a in ap_child_terminate () at eval.c:41
#4  0x0805f97d in ap_child_terminate () at eval.c:41
#5  0x0805ffcd in ap_child_terminate () at eval.c:41
#6  0x080608c3 in main () at eval.c:41
#7  0x4016f507 in __libc_start_main (main=0x8060440 <main>, argc=40, 
    ubp_av=0xbffff544, init=0x804f344 <_init>, fini=0x8074b20 <_fini>, 
    rtld_fini=0x4000dc14 <_dl_fini>, stack_end=0xbffff53c)
    at ../sysdeps/generic/libc-start.c:129


This still happens with the 1.3.22 update.  If I remove the SSL bits from the
config file, all seems fine.

Of course, it has no business trying SSL stuff when I connect on port 80 anyway,
so I guess there's something up with my config file.  Hardly excuses a segfault,
though :-)
Comment 3 Matthew Kirkwood 2001-12-13 10:00:59 EST
Oops, forgot to mention SSL details.  I've tried with and without the mod_ssl
update.  I'm now on:

$ rpm -q apache mod_ssl openssl
apache-1.3.22-2
mod_ssl-2.8.5-1
openssl-0.9.6b-8

and the same still happens.  The new backtrace is the same, modulo a couple of
symbols in mod_ssl moving by a few bytes.
Comment 4 Darrell Duane 2002-04-01 12:05:41 EST
I've started getting segfaults with apache, and I'm not using SSL, and don't
have any mention of ssl in my conf file.  I'll attach my conf file next.
Comment 5 Darrell Duane 2002-04-01 12:07:53 EST
Created attachment 51665 [details]
Conf file for apache that causes segfaults
Comment 6 Darrell Duane 2002-04-01 12:39:40 EST
Ok, I'm not certain what exactly I fixed, but I utiized the httpd.conf.rpmnew 
file and changed or added only what I knew to be important, and that fixed the
problem with the segfault.
Comment 7 Joe Orton 2004-09-21 06:51:31 EDT
Thanks for the report.  This is a mass bug update; since this release
of Red Hat Linux is no longer supported, please either:

a) try and reproduce the bug with a supported version of Red Hat
Enterprise Linux or Fedora Core, and re-open this bug as appropriate
after changing the Product field, or,

b) if relevant, try and reproduce this bug using the current version
of the upstream package, and report the bug upstream.

Note You need to log in before you can comment on or make changes to this bug.