Bug 574380 - A disabled wireless interface cannot be enabled after system wakeup from suspend (Intel PRO/Wireless 5100 AGN)
A disabled wireless interface cannot be enabled after system wakeup from susp...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Stanislaw Gruszka
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-17 08:26 EDT by Matej
Modified: 2010-11-08 12:53 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-08 12:53:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Detailed hardware information for the machine on which this bug was first discovered. (21.70 KB, text/plain)
2010-03-17 09:38 EDT, Matej
no flags Details
'dmesg' output before suspend (59.05 KB, text/plain)
2010-03-17 10:02 EDT, Matej
no flags Details
'dmesg' output after suspend (73.27 KB, text/plain)
2010-03-17 10:18 EDT, Matej
no flags Details
logs with debug50=0x02029f8f iwlagn module parameter (1.86 MB, text/plain)
2010-05-17 19:17 EDT, Travis Suel
no flags Details
Another log dump with debug50=0x02029f8f iwlagn module parameter (48.17 KB, text/plain)
2010-05-18 09:21 EDT, Matej
no flags Details

  None (edit)
Description Matej 2010-03-17 08:26:33 EDT
Description of problem:

If I disable wireless (via the wireless button on the laptop) and put the computer to sleep (via suspend), then after wakeup the wireless interface cannot be enabled again.


Version-Release number of selected component (if applicable):

iwl5000-firmware-8.24.2.12-2

Kernel: 2.6.32.9-70.fc12.i686.PAE


How reproducible: Always.


Steps to Reproduce:
1. Boot.
2. Disable wlan
3. Suspend system
4. Wakeup
5. try to enable wlan


Actual results:

The wireless interface cannot be enabled.


Expected results:

The wireless interface should become enabled.


Additional info: See attached file for detailed hardware information.
Comment 1 John W. Linville 2010-03-17 09:12:37 EDT
Don't forget the attachment!  And please include the output of dmesg after the failure...thanks!
Comment 2 Matej 2010-03-17 09:38:51 EDT
Created attachment 400752 [details]
Detailed hardware information for the machine on which this bug was first discovered.
Comment 3 Matej 2010-03-17 10:02:38 EDT
Created attachment 400769 [details]
'dmesg' output before suspend

I have switched the wireless interface on and off a couple of times during this stage. It worked normally: the wlan was turned off and then on again. The connection was also normally re-established after the wlan interface was switched on again.
Comment 4 Matej 2010-03-17 10:18:20 EDT
Created attachment 400777 [details]
'dmesg' output after suspend

I have disabled the wlan interface before suspending the system. After wakeup the wireless interface would be disabled (which is correct behaviour -- in my opinion), but the problem is that the wireless button didn't work anymore. I was not able to switch the wlan interface on again and had to restart the machine.

Note: I did not try to 'unlaod and load' the related kernel modules.
Comment 5 Travis Suel 2010-04-10 22:50:42 EDT
I've been having the same problem with all 2.6.32 kernels on an x86_64 machine with the same version of iwl5000-firmware (problem still exists in 2.6.32.11-99).  I have the same Intel PRO/Wireless 5100 wireless NIC.

One additional thing I've noticed: if the card is off when the kernel boots, it cannot be turned on.
Comment 6 Stanislaw Gruszka 2010-04-14 10:37:24 EDT
Please provide logs with debug50=0x02029f8f iwlagn module parameter, after finishing reproduce scenario: disable radio, suspend, resume, enable radio. Thanks.
Comment 7 Travis Suel 2010-05-06 22:05:43 EDT
That's a bit beyond my understanding.  Could you point me to some documentation?  Specifically, I'm not sure which particular logs you want and I'm not sure how to pass parameters to the iwlagn module (is it just a kernel argument at boot time?).
Comment 8 Stanislaw Gruszka 2010-05-14 09:23:52 EDT
Hi Travis,

I'm not sure where is documentation, here are brief instructions. Please assure you are using current uptodate kernel. 

First change to log kernel messages to /var/log/messages. To do this add "kern.*" to proper line in /etc/rsyslog.conf file: 

*.info;kern.*;mail.none;authpriv.none;cron.none                /var/log/messages

Then restart system logger:

[root@dhcp-lab-161 ~]# /etc/init.d/rsyslog restart

Remove iwlagn modules:

[root@dhcp-lab-161 ~]# rmmod iwlagn iwlcore

Clear logs (you may want to save old logs somewhere, before clear them)

[root@dhcp-lab-161 ~]# echo > /var/log/messages

Load module with debug option:

[root@dhcp-lab-161 ~]# modprobe iwlagn debug50=0x02029f8f

Do suspend/resume to reproduce problem, and attach /var/log/messages file here.

Thanks.
Comment 9 Travis Suel 2010-05-17 19:17:31 EDT
Created attachment 414694 [details]
logs with debug50=0x02029f8f iwlagn module parameter
Comment 10 Travis Suel 2010-05-17 19:18:51 EDT
Stanislaw,

Thanks for the help.
Comment 11 Matej 2010-05-18 09:21:47 EDT
Created attachment 414847 [details]
Another log dump with debug50=0x02029f8f iwlagn module parameter

Kernel version:

Linux 2.6.32.11-99.fc12.i686.PAE #1 SMP Mon Apr 5 16:15:03 EDT 2010 i686 i686 i386 GNU/Linux

Notes:

I followed the steps (with WiFi turned off during the process). After I loaded the 'iwlagn' kernel module, I turned the WiFi on (successfully) and then turned it off again (so that the computer was in the state that leads to the buggy behaviour).

After that I suspended/resumed the computer and the erroneous behaviour was reproduced (wireless would not turn on).

That's it.
Comment 12 Stanislaw Gruszka 2010-08-05 08:15:29 EDT
Hi,

Sorry for long silence, I was quite busy last months. 

Unfortunately I can not tell where the problem is from logs you provide. Looks like switch is permanently in "radio kill" state after resume. 

Could you check  if problem is solved on F-13 with 2.6.34 kernel ?

Also could you tell me what kind of laptops do you have, maybe I will be able to borrow the same and reproduce problem locally. 

And one more question, if after resume you toggle button on/off a few times, does it help?
Comment 13 Stanislaw Gruszka 2010-08-05 08:32:47 EDT
(In reply to comment #12)
> Also could you tell me what kind of laptops do you have, maybe I will be able
> to borrow the same and reproduce problem locally. 

Matej, You have HP laptop, do hp-wpi module is loaded, if not assure it is and check if that helps, if yes blacklist it and checkout.
Comment 14 Matej 2010-08-18 05:18:17 EDT
Sorry for the very late reply. I was a bit indisposed lately.

So, my laptop: HP EliteBook 2730p Notebook PC (FU442EA) (see http://h10010.www1.hp.com/wwpc/uk/en/sm/WF06b/321957-321957-64295-3955549-3955549-3784558-3818575.html)

Also, I could not find the hp-wpi module with lsmod, and a call to 'modprobe hp_wpi' or 'modprobe hp-wpi' resulted in 'FATAL: Module hp_wpi not found' in both cases.

However, there were 'hp_accel' and 'hp_wmi' modules. I blacklisted 'hp_wmi' and it worked (I tried it on kernels 2.6.32.16-150 and 2.6.32.9-70)! The wireless successfully turned back after suspend.

Thus, simply blacklisting 'hp_wmi' fixes the problem. But what functionality is lost by doing this?
Comment 15 Stanislaw Gruszka 2010-08-18 13:03:35 EDT
(In reply to comment #14)
> However, there were 'hp_accel' and 'hp_wmi' modules. I blacklisted 'hp_wmi' and

Eh, yes, of course hp_wmi, I made a typo,  

> Thus, simply blacklisting 'hp_wmi' fixes the problem. But what functionality is
> lost by doing this?

Magic laptop keys like setting sound volume or screen brightness will not work without wmi. 

So, we know now were the problem is. Are you able to test some new kernels (F-13, F-14 or upstream) to see if the problem is fixed in new code?
Comment 16 Matej 2010-08-24 10:53:37 EDT
I am sorry, but I cannot. I have very little space left on my hard drive. Well, I might probably upgrade to F13 at some point, but I do not want to overwrite my current installation because I really need the computer badly. :)

Any recommendations?
Comment 17 Stanislaw Gruszka 2010-08-24 11:23:21 EDT
You can try live CD/DVD ?
Comment 18 Stanislaw Gruszka 2010-08-24 11:24:41 EDT
And you can install upstream kernel on your current F-12 installation, but this can be hard :-)
Comment 19 Matej 2010-08-24 11:43:08 EDT
Of course. :) Okay, I'll try it with a live USB stick.
Comment 20 Matej 2010-08-25 06:35:02 EDT
I have just tried out Fedora 13 (kernel 2.6.33.3-85.fc13.i686) and I can confirm that the bug is not present here.

The wifi interface successfully turned on (after booting the computer from the Live USB stick, switching off wifi, suspending and waking the system up).

NOTE: I have specifically checked that the 'hp_wmi' module is loaded (before and after suspend).

So I guess the bug is fixed here. Should I still try F14?
Comment 21 Stanislaw Gruszka 2010-08-25 07:26:20 EDT
(In reply to comment #20)
> So I guess the bug is fixed here. Should I still try F14?
No. If hp_wmi not work in F-14 this will be most likely different bug.
Comment 22 Bug Zapper 2010-11-03 15:25:34 EDT
This message is a reminder that Fedora 12 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 12.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '12'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 12's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 12 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 23 Stanislaw Gruszka 2010-11-08 12:53:37 EST
According to comment 20 issue is fixed in F-13, I do not have time to investigate further and fix in F-12, I'm closing with NEXTREALESE.

Note You need to log in before you can comment on or make changes to this bug.