Bug 57455 - confusing info in book rhl-ig-x86(EN)-7.2-Print-RHI (2001-08-30T12:12-0400)
confusing info in book rhl-ig-x86(EN)-7.2-Print-RHI (2001-08-30T12:12-0400)
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: rhl-ig-x86 (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Sandra Moore
Sandra Moore
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-12 17:48 EST by Agent 5M1TH
Modified: 2014-08-04 18:23 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-17 13:30:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Agent 5M1TH 2001-12-12 17:48:41 EST
Description of Problem:

I am about to install RH7.2 onto my system as a second OS and wish to have it co-exist with Win98SE. Before installing I have read 
through the online forum, the manuals, etc to see WHAT STEPS MUST I TAKE to safely install it. My request is pretty simple and I hate it I 
have to bring it up to your attention for assitance. However, I believe newbies like me will face this same problem and just quit. I don't want 
to quit, all I need is help to achieve the following:

My system has 2 IDE HDDs, one is 11Gb (hda) and second is 6Gb (hdb). No partitions on either one. hda is running win98SE.
  hdb is the soon-to-be-redhat7.2. Both disks are connected on same IDE channel. In addition to this, i have one CD-RW (master)
  and one CD-ROM (slave) on the second IDE channel. 

  I need your advice on the following: 

  1. How should i wire my PC for best performance? Should I keep the hdb wired as primary slave, or move it as secondary
  master? Would you recommend any different hardware configuration as far as HDDs and CDs are concerned? I need this tuned to
  install RedHat 7.2 as second OS. 

  2. How do i achive an installation (or post-install setup), so that after it is finished, the PC gets a boot-menu, showing both OS to
  select from AND, if no aciton is taken (for say 10sec), boots by default to Win98SE? I need this, since my girlfriend and I share
  the computer and she needs Windows to do her job (some Win specific applicaitons). I would hate to cause any inconvenience
  for her, so regardless of how unimportant it may sound, it is important for me. =) 

NOW HERE COMES THE CONFUSION: 

In part G1.1 of the captioned manual, it says that "If you choose to install a new hard drive for Linux, all you need to do is start the Red Hat 
Linux installation program. After starting the Red Hat Linux installation program, just make sure you tell it to install Linux on the newly  
installed hard drive (such as hdb or sdb) rather than the hard drive used by Windows." 

HOWEVER, in part E.1.9. it says that  "On First Two IDE Drives>>> If you have 2 IDE (or EIDE) drives, /boot must be located on one of them. 
Note that this two-drive limit also includes any IDE CD-ROM drives on your primary IDE controller. So, if you have one IDE hard drive, and 
one IDE CD-ROM on your primary controller, /boot must be located on the first hard drive only, even if you have other hard drives on your 
secondary IDE controller."

Awaiting your kind assistance on both my problem and eliminating the confusing points in the manual,
Thanks.
Comment 1 Sandra Moore 2001-12-17 13:30:32 EST
Thanks for reporting this -- I will work on these sections for the next release
of the manual, to help clarify these.

In the mean time, you should contact Red Hat's technical support team by
registering your product at www.redhat.com/apps/activate and then use the online
help system to clarify this.
 
As a side note, in order to get Win98 to be the default OS loaded, you'll need
to be sure to check Win98 as the default boot image when you set up the boot
loader (either GRUB or LILO). 

I also recommend following the instructions in Appendix G, which is written
specifically for your situation. Appendix E is a more generic look at
partitioning and does not reflect dual boot scenarios with multiple hard drives
as you have seen. The information you have quoted from App. E is for a system
that will ideally only have Red Hat Linux on it, not mulitple operating systems.

Hope this helps,
Sandra

Note You need to log in before you can comment on or make changes to this bug.