Bug 574629 - dhclient sets MTU to 576 for bridge device
dhclient sets MTU to 576 for bridge device
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dhcp (Show other bugs)
12
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Jiri Popelka
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-17 21:31 EDT by Joe Conway
Modified: 2010-04-22 18:34 EDT (History)
2 users (show)

See Also:
Fixed In Version: dhcp-4.1.1-13.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-22 18:34:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Joe Conway 2010-03-17 21:31:17 EDT
Description of problem:

Update of dhclient from dhclient-4.1.0p1-12.fc12.x86_64 to dhclient-4.1.1-9.fc12.x86_64 causes the default MTU of a bridge device to be set to 576 rather than 1500 as it was previously. This in turn prevents virtual machines that are connected to the bridge device from functioning properly (e.g. web pages will not load, although simple ping will work fine -- workaround is to force MTU in virtual machines to 576 also).

Version-Release number of selected component (if applicable):

dhclient-4.1.1-9.fc12.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Set up bridged networking with the following scripts:

ifcfg.br0
--------------
DEVICE=br0
TYPE=Bridge
BOOTPROTO=dhcp
ONBOOT=yes
DELAY=0

ifcfg-eth0
--------------
DEVICE=eth0
TYPE=Ethernet
HWADDR=xx:xx:xx:xx:xx:xx
ONBOOT=yes
BRIDGE=br0

2. verify you have dhclient-4.1.1-9.fc12.x86_64
3. ensure NetworkManager is stopped
4. /etc/init.d/network restart
5. check with ifconfig, see br0 MTU=576
6. yum downgrade dhclient dhclient-4.1.0p1-12.fc12.x86_64
7. /etc/init.d/network restart
8. check with ifconfig, see br0 MTU=1500
  
Actual results:

br0 MTU is 576 upon start up or network restart

Expected results:

br0 MTU is 1500 upon start up or network restart

Additional info:
Comment 1 Jiri Popelka 2010-03-18 09:02:17 EDT
Hi Joe,
thanks for the report.

this is caused by fixing Bug #566873.
dhclient-4.1.1-9.fc12 now requests interface-mtu (specifies the MTU to use on this interface) option from server by default.
Server sends only options which it has configured to send and which the client requests.

It means that your dhcp server is configured to send interface-mtu option (with value 576). You discovered it with dhclient-4.1.1-9.fc12, because from this version the client is prepared to accept it.

If you don't want your client to request interface-mtu, you have to over-ride the list of default requested options.
It means put the following line into /etc/dhcp/dhclient.conf:

request subnet-mask, broadcast-address, time-offset, routers, domain-name, domain-name-servers, host-name, nis-domain, nis-servers, ntp-servers;

I'm not sure how to proceed this bug.
I was looking into Debian (testing) and found that the default dhclient is also requesting interface-mtu. The only difference is that in Fedora we do it in dhclient code (we don't have default dhclient.conf) and in Debian it is done via 'request' statement in default dhclient.conf
Comment 2 Derek Atkins 2010-03-18 09:13:37 EDT
Perhaps Fedora should consider a default dhclient.conf and move the interface-mtu request there so it's easier for people to turn off?
Comment 3 Joe Conway 2010-03-18 12:40:08 EDT
Thanks -- I can confirm the 'request' statement in dhclient.conf fixes the issue for me. I agree with Derek -- I think a default dhclient.conf with a request statement would be a good idea. For example, if that had been the case I would have figured this out much more quickly when I grepped for mtu in /etc.
Comment 4 Jiri Popelka 2010-03-19 10:42:53 EDT
I did a little searching and found this:
http://mathema.tician.de/node/409
and
especially this
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=513616
The patch
http://bugs.debian.org/cgi-bin/bugreport.cgi?msg=5;filename=ignore-below-576.diff;att=1;bug=513616
and explanation seems reasonable to me.
Comment 5 Fedora Update System 2010-03-19 13:37:12 EDT
dhcp-4.1.1-11.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/dhcp-4.1.1-11.fc12
Comment 6 Joe Conway 2010-03-19 13:53:54 EDT
4.1.1-11.fc12 works for me -- thanks!
Comment 7 Fedora Update System 2010-03-22 22:08:42 EDT
dhcp-4.1.1-11.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update dhcp'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/dhcp-4.1.1-11.fc12
Comment 8 Fedora Update System 2010-03-24 19:29:22 EDT
dhcp-4.1.1-12.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update dhcp'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/dhcp-4.1.1-12.fc12
Comment 9 Fedora Update System 2010-03-26 21:01:31 EDT
dhcp-4.1.1-13.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update dhcp'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/dhcp-4.1.1-13.fc12
Comment 10 Fedora Update System 2010-04-22 18:33:53 EDT
dhcp-4.1.1-13.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.