Bug 574653 - SELinux is preventing /usr/bin/iceauth "read" access on /root/.DCOPserver_GenomicsPC__0 (deleted).
Summary: SELinux is preventing /usr/bin/iceauth "read" access on /root/.DCOPserve...
Keywords:
Status: CLOSED DUPLICATE of bug 543970
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 12
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:5cf654a531e...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-03-18 04:36 UTC by kingbiotech
Modified: 2010-03-18 14:03 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-03-18 14:03:32 UTC


Attachments (Terms of Use)

Description kingbiotech 2010-03-18 04:36:39 UTC
Summary:

SELinux is preventing /usr/bin/iceauth "read" access on
/root/.DCOPserver_(removed)__0 (deleted).

Detailed Description:

[iceauth has a permissive type (iceauth_t). This access was not denied.]

SELinux denied access requested by iceauth. It is not expected that this access
is required by iceauth and this access may signal an intrusion attempt. It is
also possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                unconfined_u:unconfined_r:iceauth_t:s0-s0:c0.c1023
Target Context                unconfined_u:object_r:admin_home_t:s0
Target Objects                /root/.DCOPserver_(removed)__0 (deleted) [ file ]
Source                        iceauth
Source Path                   /usr/bin/iceauth
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           xorg-x11-server-utils-7.4-13.fc12
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.32-99.fc12
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.32.9-70.fc12.i686 #1 SMP Wed
                              Mar 3 05:14:32 UTC 2010 i686 i686
Alert Count                   4
First Seen                    Thu 18 Mar 2010 10:04:06 AM IST
Last Seen                     Thu 18 Mar 2010 10:06:09 AM IST
Local ID                      0b428f46-ca15-4bf1-931b-ed7e96eb7c71
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1268886969.482:22): avc:  denied  { read } for  pid=2195 comm="iceauth" path=2F726F6F742F2E44434F507365727665725F47656E6F6D69637350435F5F30202864656C6574656429 dev=dm-0 ino=10188 scontext=unconfined_u:unconfined_r:iceauth_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:admin_home_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1268886969.482:22): arch=40000003 syscall=11 success=yes exit=0 a0=8c33c80 a1=8c33f50 a2=8c32890 a3=8c33f50 items=0 ppid=2194 pid=2195 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=1 comm="iceauth" exe="/usr/bin/iceauth" subj=unconfined_u:unconfined_r:iceauth_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  catchall,iceauth,iceauth_t,admin_home_t,file,read
audit2allow suggests:

#============= iceauth_t ==============
allow iceauth_t admin_home_t:file read;

Comment 1 Daniel Walsh 2010-03-18 14:03:32 UTC
Are you logging in as root via X?  This is not allowed by SELinux.

Reopen if my assumption is wrong

*** This bug has been marked as a duplicate of bug 543970 ***


Note You need to log in before you can comment on or make changes to this bug.