Bug 57467 - gcc 3.1-0.10 miscompiles qmake
gcc 3.1-0.10 miscompiles qmake
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: gcc (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-13 07:55 EST by Bernhard Rosenkraenzer
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-21 10:48:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bernhard Rosenkraenzer 2001-12-13 07:55:37 EST
Description of Problem:
Using qmake (Qt's makefile generator) after compiling it with gcc 
3.1-0.10 produces broken Makefiles. The same version of qt/qmake works 
perfectly with 2.96-101.

Version-Release number of selected component (if applicable):
3.1-0.10


How Reproducible:
100%

Steps to Reproduce:
1. Install qt 3.0.1 sources
2. Attempt to build
3. 

Actual Results:
Build fails because tools/designer/designer/Makefile gets weird rules:
dbconnections\.ui: dbconnections.ui
        $(UIC) dbconnections.ui -o dbconnections\.ui



Expected Results:
The Makefile has the correct rule, such as the one I'm getting when
building qmake with gcc 2.96 or 3.0.2:

dbconnections.h: dbconnections.ui
        $(UIC) dbconnections.ui -o dbconnections.h


Additional Information:
qmake compiles without any warnings even with gcc 3.1 -Wall, so it's 
probably not some newly enforced standards compliance.
Comment 1 Bernhard Rosenkraenzer 2001-12-13 09:19:44 EST
Happens even at -O0
Comment 2 Bernhard Rosenkraenzer 2001-12-13 10:24:58 EST
It's even weirder:
qmake is usually compiled with out any -O flags because it has to support 
pretty much all compilers out there.

Adding -O2 to the CFLAGS actually fixes the problem.

So qmake is miscompiled at -O0 only (guess that's the first time I've had to 
_increase_ the optimization level to work around compiler bugs ;) ).

Comment 3 Bernhard Rosenkraenzer 2001-12-13 11:54:36 EST
Reducing priority after finding a workaround.
Comment 4 Jakub Jelinek 2001-12-20 18:16:05 EST
Reduced to makefile.o (if it is compiled with -O0, it doesn't work, if -O1
and above, it works). Will need to debug where things change...
Comment 5 Jakub Jelinek 2001-12-21 10:48:14 EST
As it does go away if makefile.cc is compiled with -fno-inline, I guess this
is just the result of bogus change from 2001-11-15 which caused tree inlining
to happen without optimizations too.
This was fixed on 2001-12-13 in CVS.

Note You need to log in before you can comment on or make changes to this bug.