Bug 574741 - Segmentation Fault in Firefox 3.5.8 and Thunderbird 3.0.3 after yum update
Segmentation Fault in Firefox 3.5.8 and Thunderbird 3.0.3 after yum update
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: mozilla (Show other bugs)
12
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Christopher Aillon
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-18 08:08 EDT by Barbara Monticini
Modified: 2010-12-03 12:08 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-03 12:08:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Barbara Monticini 2010-03-18 08:08:22 EDT
Description of problem:

Firefox and Thunderbird both crashed at startup this morning.

Tried to start them from the konsole I got a Segmentation fault "$prog" ${1+"$@"}

Tried to start them in -safe-mode with any success.

Tried to create new profiles with any success.

Tried to re-install software with any success.

To solve the problem I made a "yum history undo 6" were 6 is the number of the last "yum update" transaction

[monticini@leased-2-148 ~]$ yum history list 6
Loaded plugins: dellsysidplugin2, presto, refresh-packagekit
ID     | Login user             | Date and time    | Action(s)      | Altered
-------------------------------------------------------------------------------
     6 | Barbara <monticini>    | 2010-03-17 14:24 | Update         |   39
history list

see "yum history info 6" below for details on packages that have been update during this transaction

Finally after the undo transaction both Firefox and thunderbird started correctly.



Version-Release number of selected component (if applicable):

Linux leased-2-148.fi.infn.it 2.6.32.9-70.fc12.i686 #1 SMP Wed Mar 3 05:14:32 UTC 2010 i686 i686 i386 GNU/Linux

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.8) Gecko/20100216 Fedora/3.5.8-1.fc12 Firefox/3.5.8

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.8) Gecko/20100301 Fedora/3.0.3-1.fc12 Thunderbird/3.0.3



How reproducible:

Here are the details of packages installed on Wed Mar 17 14:24:09 2010 with yum update.

[root@leased-2-148 monticini]# yum history info 6
Loaded plugins: dellsysidplugin2, presto, refresh-packagekit
Transaction ID : 6
Begin time     : Wed Mar 17 14:24:09 2010
Begin rpmdb    : 1708:918d524d7d552b1b8ff2be61d51554e41d429b6d
End time       :            14:28:58 2010 (289 seconds)
End rpmdb      : 1708:8b78b6b89cee97c2b00f097c4d5e49c609da015b
User           : Barbara <monticini>
Return-Code    : Success
Transaction performed with:
    Installed    rpm-4.7.2-1.fc12.i686
    Installed    yum-3.2.25-1.fc12.noarch
    Installed    yum-presto-0.6.2-1.fc12.noarch
Packages Altered:
    Updated      cyrus-sasl-2.1.23-7.fc12.i686
    Update                  2.1.23-8.fc12.i686
    Updated      cyrus-sasl-lib-2.1.23-7.fc12.i686
    Update                      2.1.23-8.fc12.i686
    Updated      cyrus-sasl-md5-2.1.23-7.fc12.i686
    Update                      2.1.23-8.fc12.i686
    Updated      cyrus-sasl-plain-2.1.23-7.fc12.i686
    Update                        2.1.23-8.fc12.i686
    Updated      dhclient-12:4.1.1-9.fc12.i686
    Update                12:4.1.1-10.fc12.i686
    Updated      gnome-vfs2-2.24.2-2.fc12.i686
    Update                  2.24.2-4.fc12.i686
    Updated      gstreamer-0.10.28-1.fc12.i686
    Update                 0.10.28-2.fc12.i686
    Updated      gstreamer-tools-0.10.28-1.fc12.i686
    Update                       0.10.28-2.fc12.i686
    Updated      gtk2-2.18.7-1.fc12.i686
    Update            2.18.8-1.fc12.i686
    Updated      gtk2-devel-2.18.7-1.fc12.i686
    Update                  2.18.8-1.fc12.i686
    Updated      java-1.6.0-openjdk-1:1.6.0.0-34.b17.fc12.i686
    Update                          1:1.6.0.0-36.b17.fc12.i686
    Updated      krb5-devel-1.7.1-2.fc12.i686
    Update                  1.7.1-4.fc12.i686
    Updated      krb5-libs-1.7.1-2.fc12.i686
    Update                 1.7.1-4.fc12.i686
    Updated      krb5-workstation-1.7.1-2.fc12.i686
    Update                        1.7.1-4.fc12.i686
    Updated      ksshaskpass-0.5.1-4.fc12.i686
    Update                   0.5.3-1.fc12.i686
    Updated      libgadu-1.9.0-0.1.rc1.fc12.i686
    Update               1.9.0-0.2.rc3.fc12.i686
    Updated      libpng-2:1.2.42-1.fc12.i686
    Update              2:1.2.43-1.fc12.i686
    Updated      libpng-devel-2:1.2.42-1.fc12.i686
    Update                    2:1.2.43-1.fc12.i686
    Updated      libssh2-1.2.2-5.fc12.i686
    Update               1.2.4-1.fc12.i686
    Updated      nspr-4.8.4-1.2.fc12.i686
    Update            4.8.4-2.fc12.i686
    Updated      postgresql-libs-8.4.2-1.fc12.i686
    Update                       8.4.3-1.fc12.i686
    Updated      ppp-2.4.5-5.fc12.i686
    Update           2.4.5-7.fc12.i686
    Updated      qt-1:4.6.2-3.fc12.i686
    Update          1:4.6.2-7.fc12.i686
    Updated      qt-devel-1:4.6.2-3.fc12.i686
    Update                1:4.6.2-7.fc12.i686
    Updated      qt-mysql-1:4.6.2-3.fc12.i686
    Update                1:4.6.2-7.fc12.i686
    Updated      qt-sqlite-1:4.6.2-3.fc12.i686
    Update                 1:4.6.2-7.fc12.i686
    Updated      qt-x11-1:4.6.2-3.fc12.i686
    Update              1:4.6.2-7.fc12.i686
    Updated      rb_libtorrent-0.14.8-1.fc12.i686
    Update                     0.14.9-1.fc12.i686
    Updated      rb_libtorrent-python-0.14.8-1.fc12.i686
    Update                            0.14.9-1.fc12.i686
    Updated      selinux-policy-3.6.32-99.fc12.noarch
    Update                      3.6.32-103.fc12.noarch
    Updated      selinux-policy-targeted-3.6.32-99.fc12.noarch
    Update                               3.6.32-103.fc12.noarch
    Updated      xorg-x11-apps-7.4-9.fc12.i686
    Update                     7.4-10.fc12.i686
    Updated      xorg-x11-drv-ati-6.13.0-0.21.20100219gite68d3a389.fc12.i686
    Update                        6.13.0-0.22.20100316git819b4015.fc12.i686
    Updated      xorg-x11-drv-ati-firmware-6.13.0-0.21.20100219gite68d3a389.fc12.i686
    Update                                 6.13.0-0.22.20100316git819b4015.fc12.i686
    Updated      xorg-x11-drv-nouveau-1:0.0.15-20.20091105gite1c2efd.fc12.i686
    Update                            1:0.0.15-21.20091105gite1c2efd.fc12.i686
    Updated      xorg-x11-drv-wacom-0.10.4-3.fc12.i686
    Update                          0.10.4-4.fc12.i686
    Updated      xorg-x11-server-Xorg-1.7.5.901-4.fc12.i686
    Update                            1.7.5.902-1.fc12.i686
    Updated      xorg-x11-server-common-1.7.5.901-4.fc12.i686
    Update                              1.7.5.902-1.fc12.i686
    Updated      xorg-x11-xinit-1.0.9-14.fc12.i686
    Update                      1.0.9-15.fc12.i686
Scriptlet output:
   1 warning: user mockbuild does not exist - using root
   2 warning: user mockbuild does not exist - using root
   3 warning: user mockbuild does not exist - using root
   4 warning: user mockbuild does not exist - using root
   5 
history info


Then I made a downgrade of 29/39 packages

[monticini@leased-2-148 ~]$ yum history info 9
Loaded plugins: dellsysidplugin2, presto, refresh-packagekit
Transaction ID : 9
Begin time     : Thu Mar 18 11:12:19 2010
Begin rpmdb    : 1707:9467e0146a3943b48dc9e779636463696df65934
End time       :            11:16:23 2010 (244 seconds)
End rpmdb      : 1707:9ebbb44ad635f5a6f3a781c307863b2f0eb68992
User           : Barbara <monticini>
Return-Code    : Success
Transaction performed with:
    Installed    rpm-4.7.2-1.fc12.i686
    Installed    yum-3.2.25-1.fc12.noarch
    Installed    yum-presto-0.6.2-1.fc12.noarch
Packages Altered:
    Downgrade    dhclient-12:4.1.1-9.fc12.i686
    Downgraded            12:4.1.1-10.fc12.i686
    Downgrade    gnome-vfs2-2.24.2-2.fc12.i686
    Downgraded              2.24.2-4.fc12.i686
    Downgrade    gstreamer-0.10.28-1.fc12.i686
    Downgraded             0.10.28-2.fc12.i686
    Downgrade    gstreamer-tools-0.10.28-1.fc12.i686
    Downgraded                   0.10.28-2.fc12.i686
    Downgrade    gtk2-2.18.7-1.fc12.i686
    Downgraded        2.18.8-1.fc12.i686
    Downgrade    gtk2-devel-2.18.7-1.fc12.i686
    Downgraded              2.18.8-1.fc12.i686
    Downgrade    krb5-devel-1.7.1-2.fc12.i686
    Downgraded              1.7.1-4.fc12.i686
    Downgrade    krb5-libs-1.7.1-2.fc12.i686
    Downgraded             1.7.1-4.fc12.i686
    Downgrade    krb5-workstation-1.7.1-2.fc12.i686
    Downgraded                    1.7.1-4.fc12.i686
    Downgrade    ksshaskpass-0.5.1-4.fc12.i686
    Downgraded               0.5.3-1.fc12.i686
    Downgrade    libgadu-1.9.0-0.1.rc1.fc12.i686
    Downgraded           1.9.0-0.2.rc3.fc12.i686
    Downgrade    libpng-2:1.2.42-1.fc12.i686
    Downgraded          2:1.2.43-1.fc12.i686
    Downgrade    libpng-devel-2:1.2.42-1.fc12.i686
    Downgraded                2:1.2.43-1.fc12.i686
    Downgrade    libssh2-1.2.2-5.fc12.i686
    Downgraded           1.2.4-1.fc12.i686
    Downgrade    nspr-4.8.4-1.2.fc12.i686
    Downgraded        4.8.4-2.fc12.i686
    Downgrade    postgresql-libs-8.4.2-1.fc12.i686
    Downgraded                   8.4.3-1.fc12.i686
    Downgrade    ppp-2.4.5-5.fc12.i686
    Downgraded       2.4.5-7.fc12.i686
    Downgrade    qt-1:4.6.2-3.fc12.i686
    Downgraded      1:4.6.2-7.fc12.i686
    Downgrade    qt-devel-1:4.6.2-3.fc12.i686
    Downgraded            1:4.6.2-7.fc12.i686
    Downgrade    qt-mysql-1:4.6.2-3.fc12.i686
    Downgraded            1:4.6.2-7.fc12.i686
    Downgrade    qt-sqlite-1:4.6.2-3.fc12.i686
    Downgraded             1:4.6.2-7.fc12.i686
    Downgrade    qt-x11-1:4.6.2-3.fc12.i686
    Downgraded          1:4.6.2-7.fc12.i686
    Downgrade    selinux-policy-3.6.32-99.fc12.noarch
    Downgraded                  3.6.32-103.fc12.noarch
    Downgrade    selinux-policy-targeted-3.6.32-99.fc12.noarch
    Downgraded                           3.6.32-103.fc12.noarch
    Downgrade    xorg-x11-apps-7.4-9.fc12.i686
    Downgraded                 7.4-10.fc12.i686
    Downgrade    xorg-x11-drv-ati-6.13.0-0.21.20100219gite68d3a389.fc12.i686
    Downgraded                    6.13.0-0.22.20100316git819b4015.fc12.i686
    Downgrade    xorg-x11-drv-ati-firmware-6.13.0-0.21.20100219gite68d3a389.fc12.i686
    Downgraded                             6.13.0-0.22.20100316git819b4015.fc12.i686
    Downgrade    xorg-x11-drv-nouveau-1:0.0.15-20.20091105gite1c2efd.fc12.i686
    Downgraded                        1:0.0.15-21.20091105gite1c2efd.fc12.i686
    Downgrade    xorg-x11-xinit-1.0.9-14.fc12.i686
    Downgraded                  1.0.9-15.fc12.i686
history info


Tried to start Thunderbird again:

  thunderbird-bin: error while loading shared libraries: libpng12.so.0: cannot open shared object file

Installed libpng.i686

  yum install libpng.i686

Firefox and Thunderbird started succefully!


Steps to Reproduce: see above
1.
2.
3.
  
Actual results:

Firefox and Thunderbird are running correctly now but cannot update the system in order to avoid Firefox and Thunderbird crashing again.


Expected results:


Additional info:
Comment 1 Bug Zapper 2010-11-03 15:18:45 EDT
This message is a reminder that Fedora 12 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 12.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '12'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 12's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 12 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Bug Zapper 2010-12-03 12:08:21 EST
Fedora 12 changed to end-of-life (EOL) status on 2010-12-02. Fedora 12 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.