Bug 57478 - preun script causes error during upgrade
preun script causes error during upgrade
Status: CLOSED RAWHIDE
Product: Red Hat Powertools
Classification: Retired
Component: kwintv (Show other bugs)
7.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-13 12:59 EST by Michael Schwendt
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-13 12:59:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2001-12-13 12:59:09 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.6) Gecko/20011120

Description of problem:
Upgrading a Red Hat kwintv package to a newer package release without using
special RPM options removes the consolehelper link from /usr/bin/kv4lsetup.

preuninstall scriptlet (through /bin/sh):
rm /usr/bin/kv4lsetup


Version-Release number of selected component (if applicable):
0.8.5-5, 0.8.5-6 (than preview)

How reproducible:
Always

Steps to Reproduce:
1. rpm -ivh kwintv-some-old-package.rpm
2. rpm -Uvh kwintv-0.8.5-5.i386.rpm
3. file /usr/bin/kv4lsetup



Actual Results:  /usr/bin/kv4lsetup: No such file or directory

(Additionally, rpm -e kwintv would fail to erase because of the preun
returning an error on the non-existant file/link. And rpm -e --noscripts as
a work-around doesn't remove the kwintv fonts from font path.)

Expected Results:  /usr/bin/kv4lsetup: symbolic link to consolehelper

(Additionally, rpm -e kwintv without no problems.)

Additional info:

kwintv development continues at  http://www.kwintv.org  and fixes a series
of bugs in 0.8.5 and later.
Comment 1 Ngo Than 2001-12-14 12:33:10 EST
it's a bug in old version. it's fixed in kwintv-0.8.5-7. You find it in
ftp://people.redhat.com/than/7.1

Notice: this bug will appear if you update kwintv-0.8.5-7, because preun in old
rpm will run by updating!

But updating next version will work correct!

I will update 0.8.10 soon.

Note You need to log in before you can comment on or make changes to this bug.