Bug 574802 - System freeze during USB transfers - Intel Ibex Peak USB2
System freeze during USB transfers - Intel Ibex Peak USB2
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-18 11:20 EDT by David Ross
Modified: 2011-07-05 15:51 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-27 11:12:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description David Ross 2010-03-18 11:20:48 EDT
Description of problem:
System appears to freeze completely during usb usage.  Devices work as expected and then without warning the system is unresponsive locally or via the network.

This seems to occur on all usb ports - ie transferring to/from flash drives as well as viewing the inbuilt webcam.

Version-Release number of selected component (if applicable):
2.6.33-1.fc13.x86_64

How reproducible:
Every time considerable amounts of data are transmitted/received.

Steps to Reproduce:
1. Plug in flash drive
2. Mount partition
3. Begin copying data
  
Actual results:
System freezes

Expected results:
Copy to complete without system locking up.

Additional info:
I have tried adding noapic to the kernel options however the problem still seems to persist.

lspci:
00:1a.0 USB Controller: Intel Corporation Ibex Peak USB2 Enhanced Host Controller (rev 06)
00:1d.0 USB Controller: Intel Corporation Ibex Peak USB2 Enhanced Host Controller (rev 06)

lsusb:
Bus 002 Device 002: ID 8087:0020  
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 007: ID 413c:8160 Dell Computer Corp. 
Bus 001 Device 006: ID 413c:8162 Dell Computer Corp. 
Bus 001 Device 005: ID 413c:8161 Dell Computer Corp. 
Bus 001 Device 004: ID 0c45:6417 Microdia 
Bus 001 Device 003: ID 0a5c:4500 Broadcom Corp. 
Bus 001 Device 002: ID 8087:0020  
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Let me know if there is more information or testing required.
Comment 1 David Ross 2010-03-18 12:36:50 EDT
I've completed some more testing and it appears as if the noapic option has actually helped a bit - I've only had one freeze with the option added and none since disabling bluetoothd in addition to adding noapic (having bluetooth disabled without the noapic option still causes a freeze).

There are some bluetooth related errors in the dmesg output:
btusb_intr_complete: hci0 urb ffff88010c6497b8 failed to resubmit (1)
btusb_bulk_complete: hci0 urb ffff88010c649188 failed to resubmit (1)
btusb_bulk_complete: hci0 urb ffff88010c648c60 failed to resubmit (1)
btusb_intr_complete: hci0 urb ffff8800b1f599c8 failed to resubmit (1)
btusb_bulk_complete: hci0 urb ffff8800b1f58a50 failed to resubmit (1)
btusb_bulk_complete: hci0 urb ffff8800b1f59ef0 failed to resubmit (1)

Perhaps there is more than one related problem?
Comment 2 David Ross 2010-03-18 13:29:37 EDT
Perhaps my previous comment was a bit premature, even with bluetooth disabled I've just had a freeze.

One other interesting thing to note is that if you are listening to music at the point where the system freezes then the last 1 or 2 seconds of audio is repeated indefinitely.  I'm still not sure what is causing this loop but any suggestions would be welcome.
Comment 3 Josh Bressers 2010-05-16 13:12:19 EDT
I'm seeing this behavior as well on F12. The problem seems to involve any sort of heavy file IO. I get this if a try to copy a large file, regardless of source and destination (NFS, local disk, USB drive).

The speed of the drive and network connection doesn't seem to matter. I see this if I use a wired or wireless connection to NFS for example.

The copy starts fine, after a few seconds then it (once the cache is full?), things fall apart. This also happens if I do something like
    dd if=/dev/zero of=big-file bs=1M count=1024

The computer eventually comes back to life once the copy is done (it takes a long time usually).

If I run vmstat during the operation, the number of things it shows in uninterruptible sleep jumps to between 4 and 6 once the machine starts flaking out.


I don't see this if I have it do synchronized IO though:
    dd oflag=dsync if=/dev/zero of=big-file bs=1M count=1024

Is there something I can provide to help diagnose this?

Thanks.
Comment 4 tom.medhurst 2011-01-23 07:41:56 EST
I am also seeing this in Fedora 14 (and have also seen it in Ubuntu 10.10, but not Debian Squeeze).

It happens to me with almost any USB device including my external USB sound card (powerwave) and anything that uses the USB Serial driver (for USB to RS-232 adapters).

Happens almost every time and can even get stuck during boot if I have one of these plugged in at the time.
Comment 5 Bug Zapper 2011-06-02 12:05:53 EDT
This message is a reminder that Fedora 13 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 13.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '13'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 13's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 13 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Bug Zapper 2011-06-27 11:12:28 EDT
Fedora 13 changed to end-of-life (EOL) status on 2011-06-25. Fedora 13 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.
Comment 7 brett 2011-07-05 15:51:21 EDT
I am having a similar issue on RHEL-6, up to date with updates.

Note You need to log in before you can comment on or make changes to this bug.