Bug 574845 - Network manager does not automatically start up wireless connection with hidden ESSID
Network manager does not automatically start up wireless connection with hidd...
Status: CLOSED DUPLICATE of bug 516788
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-18 12:40 EDT by Quentin Armitage
Modified: 2010-06-28 16:31 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-28 16:31:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Quentin Armitage 2010-03-18 12:40:55 EDT
Description of problem:
I have a wireless network which is hidden. The wireless configuration in NetworkManager is set to connect automatically, and Available to all users.

There are two issues:

1. It does not automatically connect to the network, but needs to be manually made to connect. BZ #516788 may be the same as this, but that was reported against F-12.

2. When the manual connection is invoked via "Connect to hidden network", afte the connection is chosen, an Authenticate window pops up prompting for the root password. This is completely unnecessary, and it connects to the wireless network even if Cancel is chosen from the Authenticate window.

Version-Release number of selected component (if applicable):
NetworkManager-0.8.0-0.4.git20100211.fc13.i686

How reproducible:
Always

Steps to Reproduce:
1.Startup system and login
2.
3.
  
Actual results:
No network connection

Expected results:
Network connection automatically established, with no intervention by user, and no prompting for root password.

Additional info:
Comment 1 Dan Williams 2010-04-08 21:19:47 EDT
Does the access point provide two SSIDs, one hidden and one public, both using the same BSSID?  Try doing an 'iwlist wlan0 scan' and looking for your AP; next do 'iwlist wlan0 scan essid <your hidden SSID>' and then look again for your AP.  Can you post the output of those two here?
Comment 2 Quentin Armitage 2010-04-09 05:47:08 EDT

Output of iwlist wlan1 scan (when not associated with AP)
===========================================================
wlan1     Scan completed :
          Cell 01 - Address: 00:18:4D:5E:6B:D6
                    Channel:11
                    Frequency:2.462 GHz (Channel 11)
                    Quality=47/70  Signal level=-63 dBm
                    Encryption key:on
                    ESSID:""
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s
                    Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s
                              36 Mb/s; 48 Mb/s; 54 Mb/s
                    Mode:Master
                    Extra:tsf=000005ec5dd35239
                    Extra: Last beacon: 69ms ago
                    IE: Unknown: 00200000000000000000000000000000000000000000000000000000000000000000
                    IE: Unknown: 010482848B96
                    IE: Unknown: 03010B
                    IE: Unknown: 050C020300000000000000000000
                    IE: Unknown: 2A0107
                    IE: Unknown: 32080C1218243048606C
===============================================================

Output of iwlist wlan1 scan (when associated with AP)
=====================================================
wlan1     Scan completed :
          Cell 01 - Address: 00:18:4D:5E:6B:D6
                    Channel:11
                    Frequency:2.462 GHz (Channel 11)
                    Quality=49/70  Signal level=-61 dBm
                    Encryption key:on
                    ESSID:""
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s
                    Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s
                              36 Mb/s; 48 Mb/s; 54 Mb/s
                    Mode:Master
                    Extra:tsf=000005ec5ffc7238
                    Extra: Last beacon: 61ms ago
                    IE: Unknown: 00200000000000000000000000000000000000000000000000000000000000000000
                    IE: Unknown: 010482848B96
                    IE: Unknown: 03010B
                    IE: Unknown: 050C020300000000000000000000
                    IE: Unknown: 2A0107
                    IE: Unknown: 32080C1218243048606C
          Cell 02 - Address: 00:18:4D:5E:6B:D6
                    Channel:11
                    Frequency:2.462 GHz (Channel 11)
                    Quality=53/70  Signal level=-57 dBm
                    Encryption key:on
                    ESSID:"SSID-REMOVED"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s
                    Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s
                              36 Mb/s; 48 Mb/s; 54 Mb/s
                    Mode:Master
                    Extra:tsf=000005ec5f5ee55d
                    Extra: Last beacon: 10382ms ago
                    IE: Unknown: 0020463F596975436C7951587E44604E383A543F2F4F7A787E4A7278326B50722F62
                    IE: Unknown: 010482848B96
                    IE: Unknown: 03010B
                    IE: Unknown: 2A0107
                    IE: Unknown: 32080C1218243048606C
==========================================================

Output of iwlist wlan1 scan essid "SSID-REMOVED" is the same as the output for when associated with the AP.

In case it makes any difference, wlan0 (an Atheros based PCMCIA card) was not in the system, alhough if I use the PCMCIA card instead of the USB wlan device, I get the same results.

FYI the AP is a Netgear DG834G, firmware version 4.01.40.
Comment 3 Dan Williams 2010-06-28 16:31:25 EDT

*** This bug has been marked as a duplicate of bug 516788 ***

Note You need to log in before you can comment on or make changes to this bug.