Bug 57491 - install hangs, bug-is-probable popup window, while formatting swap area
install hangs, bug-is-probable popup window, while formatting swap area
Status: CLOSED DUPLICATE of bug 18032
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i586 Linux
medium Severity high
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-13 19:00 EST by david.blake
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-13 19:02:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
traceback (bug tracing script text) presented in a popup window (978 bytes, text/plain)
2001-12-13 19:02 EST, david.blake
no flags Details

  None (edit)
Description david.blake 2001-12-13 19:00:50 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en]C-CCK-MCD   (WinNT; U)

Description of problem:
In a custom install of 7.0, after / has formatted, after /home has formatted, <swap> cannot finish formatting
a window pops up that suggests that a bug is probable and shows code start ing with "Traceback(inner most last):"
Error message includes:
lsys.py, return_isys.devSpaceFree(fsystem) SystemError: (2,'No such File or directory')
Note: the 6GB hard drive is removable. I chose toformat it as hda1 (/), hda2 (<swap>) and hda3 (/home).
Version 5 Red Hat was on this drive, but I did not choose upgrade; I chose custom install.
There is a 4GB drive in the other bay. It has Win98 installed. I chose to mount it as /win (hdc).

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
0. Install using 'boot.img' on a floppy (drive-a) 
1.Work through standard, custom install, using disk utility to assign '/' to hda1, <swap> to hda2, '/home' to hda3 and '/win' to hdc, the 
second hard drive (also removable).
2. Select '/' and '/home' to format
3. Select INSTALL (finish)
4. watch as messages cycle through "formatting /", "formatting /home" and finally "formatting swap"
	

Actual Results:  installation is interrupted with a popup window, stating that there is probably a bub and showing script text (attached). 
Closing this box closes the system and reboots. If the boot.img disk is removed, LILO boots until these messages show: "unable to 
opoen initial console" and then "Kernal panic: no init found. Try passing init= to kernal. However, with the exception of cntl-alt-del, there 
does not appear to be any stdin from the keyboard.
ALSO:
early in the LIL:O boot, these messages appear: "Ram Disk compressed image found at block 0" and "EXT2-fs warning: checktime 
reached, running e2fsck recommended"

Expected Results:  Linux should hav been installed on hda (disk 1).

Additional info:

Pentium 586, 166-mHz, 48mB RAM, Netgear card, Diamond Speedstar 24 w/ 1mB (old).
Two removable and swapopable hard drives, one with Linux RHv5 (was working, I expect it is dead now) the other disk drive has Win98 
installed.
Here is the full text of the message that appeared in the popup window:
Traceback (innermost last):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py", line 20, in run
    rc = self.todo.doInstall ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1480, in doInstall
    if self.method.systemMounted (self.fstab, self.instPath, self.hdList.selected()):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/image.py", line 46, in systemMounted
    self.loopbackFile = mntPoint + fstab.filesystemSpace(mntPoint)[0][0] + \
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/fstab.py", line 258, in filesystemSpace
    space.append((mntpoint, isys.fsSpaceAvailable(topMount + '/' + mntpoint)))
  File "/usr/lib/anaconda/isys.py", line 16, in fsSpaceAvailable
    return _isys.devSpaceFree(fsystem)
SystemError: (2, 'No such file or directory')

Local variables in innermost frame:
fsystem: /mnt/sysimage//win

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>
Comment 1 david.blake 2001-12-13 19:02:31 EST
Created attachment 40547 [details]
traceback (bug tracing script text) presented in a popup window
Comment 2 Brent Fox 2001-12-17 16:16:22 EST

*** This bug has been marked as a duplicate of 18032 ***

Note You need to log in before you can comment on or make changes to this bug.