Bug 57492 - 7.2 install fails to load 3Ware 3w-xxxx .o driver
7.2 install fails to load 3Ware 3w-xxxx .o driver
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2001-12-13 20:20 EST by Chance Reschke
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-01-23 13:15:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Chance Reschke 2001-12-13 20:20:02 EST
From Bugzilla Helper:

User-Agent: Mozilla/4.0 (compatible; MSIE 5.12; Mac_PowerPC)

Description of problem:

Installing RH 7.2 to a system with all disks attached to a 3Ware 
Escalade 7810 controler fails becuse the 3Ware driver is not loaded. 

At the installer lilo prompt I enter "linux dd", and when prompted for a 
driver diskette I insert either the 3Ware-provided driver or a driver 
diskette created from the images dir on the RH CD.

With the 3Ware driver diskette loaded, the following messages 
appear in VC 3:

  * found suggestion of 3w-xxxx
  * found 3w-xxx device
  * found suggestion of usb-ohci
  * found devices justProbe is 0
  * extracting pattern 2.4.7-10*/3w-xxxx)
  * going to insmod 3w-xxxx.o (path is /tmp/modules/3w-xxx)

However, /proc/modules does not list the 3Ware driver among the 
loaded modules and /proc/scsi/scsi is empty.

The install proceeds until the disk partitioning step at which point it 
fails with the "no valid devices" error.

I have tried "linux updates dd" with according the instructions in 
RedHat advisory RHBA-2001:131-03, but the results are the same.

The system in question is running RedHat 7.1 with Linux software 
RAID.  The 3Ware controler is configured with no hardware RAID 
arrays.  Running the RedHat 7.1 installer works fine.

Version-Release number of selected component (if applicable):

How reproducible:


Steps to Reproduce:

1. Boot from RH 7.2 installation floppy or CD
2.Enter "linux dd" at the lilo prompt
3.insert the 3Ware driver diskette when prompted

Actual Results:  The installtion fails in the partitioning step with the 
"no valid devices" error

Expected Results:  The 3Ware driver should have loaded, allowing 
me to parition the disks and proceed with the RH 7.2 installation

Additional info:
Comment 1 Michael Fulbright 2001-12-17 15:48:30 EST
Have you tried the anaconda errata:

Comment 2 Chance Reschke 2001-12-17 16:02:27 EST
Yes.  From my original report:

+ I have tried "linux updates dd" with according the instructions in 
+ RedHat advisory RHBA-2001:131-03, but the results are the same.

The console messages say the installer is "going to insmod 3w-xxxx.o", 
but the modules is never loaded and the install fails at the disk 
partitioning step.

Comment 3 Jeremy Katz 2002-01-02 16:05:54 EST
You shouldn't need 'linux updates dd', just 'linux updates'.  Also, you are
booting with the boot disk from 7.2, correct?
Comment 4 Need Real Name 2002-01-02 16:16:13 EST
I'm experiencing the same problem with a 3ware Escalade 7850 and Red Hat Linux
7.2.  I suspect that it is because the PCI ID of my board is 0x13c1 0x1001,
rather than the 0x13c1 0x1000 that Enigma expects to see.  

I worked around the problem by placing the 3w-xxxx.o driver on a floppy disk,
and insmod'ing the driver by hand when the shell on tty2 starts up in anaconda.

- paul
Comment 5 Need Real Name 2002-01-02 16:19:12 EST
please ignore my above comment, it's a different issue, which was resolved by
bug 54291.
Comment 6 Chance Reschke 2002-01-02 21:54:06 EST
Using 'linux updates" rather than "linux updates dd" has no effect.  The driver
still fails to load.

I've succeeded by using the same approach as paul-misc@booyaka.com.  That is, I
copy the driver from another RH 7.2 system to a diskette and from the shell
prompt on the second vc I mount the floppy and insmod the driver.

It sounds like the fix described in the resolution to Bug#:54291 might not have
been accomplished?

Comment 7 Jeremy Katz 2002-01-15 16:35:30 EST
It's fixed, just post 7.2.  If you boot with 'linux updates noprobe', you should
be able to manually select the driver and then things should work.
Comment 8 Chance Reschke 2002-01-23 13:15:23 EST
Does the RawHide fix use the latest 3Ware driver ( Release 7.3.2 Version  To successfully install RedHat 7.2 on disks attached to an
Escalade 7810 you must use this driver version - the version included with the
RedHat 7.2 installation disks will crash.  Also, the 3Ware module installed in
by the RH 7.2 installer will fail when the system is rebooted after installation.
Comment 9 Jeremy Katz 2002-01-23 14:30:41 EST
The current rawhide kernel uses a later driver version than the one mentioned

Note You need to log in before you can comment on or make changes to this bug.