Bug 574969 - tg3 oops with netconsole
Summary: tg3 oops with netconsole
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Neil Horman
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-03-19 00:54 UTC by Nicholas Miell
Modified: 2010-04-10 10:29 UTC (History)
7 users (show)

Fixed In Version: kernel-2.6.32.11-99.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-03-30 02:24:54 UTC


Attachments (Terms of Use)
oops #1 (5.65 KB, text/plain)
2010-03-19 00:54 UTC, Nicholas Miell
no flags Details
another one for your elucidation (5.68 KB, text/plain)
2010-03-19 00:55 UTC, Nicholas Miell
no flags Details
patch to pass tg3_napi struct pointer to tg3_interrupt (499 bytes, patch)
2010-03-19 15:14 UTC, Neil Horman
no flags Details | Diff

Description Nicholas Miell 2010-03-19 00:54:58 UTC
Created attachment 401147 [details]
oops #1

Description of problem:
When you setup a netconsole with tg3 and generate enough traffic (by e.g. turning drm.debug on), tg3 oopses.

Version-Release number of selected component (if applicable):
kernel-2.6.32.9-70.fc12.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Turn on netconsole
2. echo 1 > /sys/module/drm/parameters/debug
3. Wait
  
Actual results:
tg3 oopses

Expected results:
Happy fun drm logs right up until the GPU locks up the system bus.

Comment 1 Nicholas Miell 2010-03-19 00:55:38 UTC
Created attachment 401148 [details]
another one for your elucidation

Comment 2 Neil Horman 2010-03-19 15:11:23 UTC
looks like the second argument is passing the wrong type of data to tg3_interrupt.  I'll post a patch for you shortly.  Thanks!

Comment 3 Neil Horman 2010-03-19 15:14:37 UTC
Created attachment 401263 [details]
patch to pass tg3_napi struct pointer to tg3_interrupt

here, could you please see if this prevent the oops your seeing?  Thanks!

Comment 4 Neil Horman 2010-03-19 15:17:04 UTC
Note: This appears already fixed upstream with this commit from Louis Rilling:
fe234f0e5cbb880792d2d1ac0743cf8c07e9dde3

Comment 5 Nicholas Miell 2010-03-20 01:26:08 UTC
This appears to fix the problem.

Comment 6 Neil Horman 2010-03-20 13:06:46 UTC
great, thanks, I'll commit this shortly.

Comment 7 Neil Horman 2010-03-22 12:46:09 UTC
fixed in F-12 cvs tree.  Thanks!

Comment 8 Fedora Update System 2010-03-23 15:04:11 UTC
kernel-2.6.32.10-90.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/kernel-2.6.32.10-90.fc12

Comment 9 Fedora Update System 2010-03-24 23:40:50 UTC
kernel-2.6.32.10-90.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kernel'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/kernel-2.6.32.10-90.fc12

Comment 10 Fedora Update System 2010-03-30 02:24:19 UTC
kernel-2.6.32.10-90.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2010-04-10 10:29:04 UTC
kernel-2.6.32.11-99.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.