Bug 574990 - bad DVD can't be ejected without hard reboot
bad DVD can't be ejected without hard reboot
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
13
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-18 22:54 EDT by Cia Watson
Modified: 2010-03-19 12:25 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-19 12:25:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
small sample of error message output (2.90 KB, text/plain)
2010-03-18 22:54 EDT, Cia Watson
no flags Details

  None (edit)
Description Cia Watson 2010-03-18 22:54:46 EDT
Created attachment 401162 [details]
small sample of error message output

Description of problem:
If I either (apparently unsuccessfully) burn a DVD or insert another DVD of unknown quality that has errors of some sort, it doesn't mount and keeps trying to access the disk and gives continuous error messages in /var/log/messages. The only way I've found to retrieve the DVD and stop the error messages is to hard reboot the pc. I had the same problem in F12, this is a F13 only install, using pre-alpha netinstall.

Version-Release number of selected component (if applicable):


How reproducible:
insert 'bad' DVD into LG DVD drive (even some where dvd burning software reported success, and it comes up in external DVD player but has errors during playback of 1st of 2 videos).

Steps to Reproduce:
1. insert dvd into 
2.
3.
  
Actual results:
It makes noises like the drive is trying to access it, but it doesn't mount to the desktop. Attempt to push the eject button on the drive or using eject command from terminal don't work. Check /var/log/messages and it keeps repeating same error message about 'Buffer I/O error'

Expected results:
If the disk is unreadable, the drive access times out with an error message and either ejects the disk or offers to eject the disk. 

Additional info:

I have tried to open a terminal and as the local user or root user type 'eject /dev/sr0' and it will eventually return to the command prompt, but the drive doesn't open and the error messages continue. Just manually pushing the drive button also doesn't work. I had a similar experience (in F12) using K3B, tried to kill the K3B process and it wouldn't die.
Comment 1 Harald Hoyer 2010-03-19 05:57:24 EDT
can you open the tray after:

# echo 0 > /proc/sys/dev/cdrom/autoclose
# echo 0 > /proc/sys/dev/cdrom/lock

?
Comment 2 Cia Watson 2010-03-19 11:49:07 EDT
(In reply to comment #1)
> can you open the tray after:
> 
> # echo 0 > /proc/sys/dev/cdrom/autoclose
> # echo 0 > /proc/sys/dev/cdrom/lock
> 
> ?    

I wasn't sure whether I was supposed to use those commands before or after I put in a 'bad' disk, so first I inserted one and had the usual issue, entered the commands, tray didn't open. Had to restart. 

Then I gave those commands before putting in the dvd, it started to do the same (repeating same errors in error log) but when I pushed the button the drive door opened! Tried it again, and gave terminal command 'eject /dev/sr0' and after a couple moments, that worked too. 

The short answer is yes, I can open the tray after those commands as long as they're done before I put in the dvd.
Comment 3 Harald Hoyer 2010-03-19 12:25:19 EDT
you might want to make it permanent for you faulty drive and put them in /etc/sysctl.conf:

dev.cdrom.autoclose=0
dev.cdrom.lock=0

Note You need to log in before you can comment on or make changes to this bug.