Bug 574993 - Fedora 13 Alpha Graphical Installer permits Leading Capital in Username
Summary: Fedora 13 Alpha Graphical Installer permits Leading Capital in Username
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: firstboot
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Martin Gracik
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-03-19 03:08 UTC by Robert Lightfoot
Modified: 2013-07-04 12:49 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-03-19 21:50:36 UTC
Type: ---


Attachments (Terms of Use)

Description Robert Lightfoot 2010-03-19 03:08:03 UTC
Description of problem:
Able to create users such as Bob, Larry and Tom with a capital first letter

Version-Release number of selected component (if applicable):
F13-Alpha

How reproducible:


Steps to Reproduce:
1. Install F13-Alpha
2. Upon First Boot choose a username with leading Capital
3. It will be accepted.
  
Actual results:


Expected results:
Leading capitals and I believe any capitals in usernames should be rejected per long standing linux standards

Additional info:

Comment 1 James Laska 2010-03-19 20:11:54 UTC
Thank you for the bug report.  Neither of the text-mode or graphical user/group management tools restrict user accounts to all lowercase.  

# useradd -p '' Guest
# getent passwd Guest
Guest:x:501:501::/home/Guest:/bin/bash

In additional, the documentation [1] places no restrictions on case sensitivity for user account names. 

[1] http://docs.fedoraproject.org/deployment-guide/f12/en-US/html/ch-users-groups.html#s2-redhat-config-users-user-new

Comment 2 Robert Lightfoot 2010-03-19 21:50:36 UTC
Thanks for the information James.  I'm marking this closed not a bug if that is the intended and allowable behavior.  Several in #fedora felt that Ucase First Letter should not be allowed.  Thus the reason I reported it.


Note You need to log in before you can comment on or make changes to this bug.