Bug 57508 - dos2unix erroneously strips \r
dos2unix erroneously strips \r
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dos2unix (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Aaron Brown
:
Depends On:
Blocks: FC3Target FC3BugWeekTracker 183629
  Show dependency treegraph
 
Reported: 2001-12-14 12:32 EST by Tom Tromey
Modified: 2014-08-11 01:46 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-19 20:35:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
a patch (3.06 KB, patch)
2004-09-26 05:16 EDT, Michael Schwendt
no flags Details | Diff
patch (with uneeded lines dropped) (2.50 KB, patch)
2004-09-26 05:47 EDT, Michael Schwendt
no flags Details | Diff
final patch (2.18 KB, patch)
2004-09-26 15:03 EDT, Michael Schwendt
no flags Details | Diff

  None (edit)
Description Tom Tromey 2001-12-14 12:32:10 EST
Description of Problem:

If you give dos2unix a mac file (one where lines are separate by \r alone)
and accidentally ask it to convert in DOS mode, you get a file with no
newlines.

To me this seems like confusing behavior.  I'd prefer it if DOS conversion
mode changed `\r\n' to `\n' -- and left lone `\r's unmodified.  That
would reduce the potential for error.

Version-Release number of selected component (if applicable):

dos2unix 3.1 (Thu Nov 19 1998)

How Reproducible:


Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:
Comment 1 Michael Schwendt 2004-09-26 05:16:44 EDT
Created attachment 104332 [details]
a patch
Comment 2 Michael Schwendt 2004-09-26 05:47:31 EDT
Created attachment 104333 [details]
patch (with uneeded lines dropped)

My post to fedora-patch-list bounced, and when I looked at the message, I've
noticed lines in the patch which I should have deleted earlier.
Comment 3 Rik van Riel 2004-09-26 10:05:53 EDT
The patch makes sense.  I haven't been able to test it because I have
no mac files here, but the code looks sane.

Mike, want to rebuild the package or should I rebuild it ?
Comment 4 Michael Schwendt 2004-09-26 14:37:29 EDT
cat unixfile | tr \\n \\r > macfile
Comment 5 Michael Schwendt 2004-09-26 15:03:08 EDT
Created attachment 104335 [details]
final patch

While the unneeded lines in the first patch did no harm (a cut'n'rename
mistake), the second patch lost the line delimiter of the last line when
running mac2unix on a Mac file. A minor detail, easily overlooked when running
tests.

$ cd /tmp
$ cat /etc/services | tr \\n \\r > macfile
$ ls -la macfile
-rw-------  1 misc2 misc2 19936 Sep 26 21:05 macfile
$ dos2unix -c Mac macfile
dos2unix: converting file macfile to UNIX format ...
$ ls -la macfile
-rw-------  1 misc2 misc2 19936 Sep 26 21:06 macfile
$ cat macfile | tr \\r \\n > unixfile
$ md5sum unixfile /etc/services
485eacadb2a1d18fcf66483f81829f02  unixfile
485eacadb2a1d18fcf66483f81829f02  /etc/services

[size and checksum stay the same]
Comment 6 Rik van Riel 2004-09-26 17:19:00 EDT
Patch applied in dos2unix-3.1-19
Comment 7 Tim Powers 2005-05-19 20:35:31 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-195.html

Note You need to log in before you can comment on or make changes to this bug.