Bug 575201 - euca-describe-images shows no output if none of o a x specified
Summary: euca-describe-images shows no output if none of o a x specified
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: euca2ools
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Garrett Holmstrom
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-03-19 17:49 UTC by Robert Banfield
Modified: 2010-09-23 12:32 UTC (History)
1 user (show)

Fixed In Version: euca2ools-1.3.1-1.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-09-21 01:32:34 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 544676 None None None Never

Description Robert Banfield 2010-03-19 17:49:23 UTC
Description of problem:
euca-describe-images rather unhelpfully shows no output if none of -o -a -x are specified

Version-Release number of selected component (if applicable):
euca2ools.noarch 0:1.2-1.fc12


How reproducible:
Always

Steps to Reproduce:
1. euca-describe-images -A 01CA26RV706EVPYQMX02 -S ahtrfBT+nPZtzTyTCnYRXziCm5pVya3ZL9XFYAtR -U https://ec2.amazonaws.com
2.
3.
  
Actual results:
(Nothing)

Expected results:
Amazon's EC2 tools show those images which the user owns (-o self).  I'm not saying this should be the default behavior, but something should sure be described, or an error message saying to the user "hey, pick something to describe, this won't output anything".  

Even specifying "euca-describe-images ami-????????" shows nothing since it doesn't know the owner designation.


Additional info:

Comment 1 Robert Banfield 2010-03-19 18:00:23 UTC
Oops... keys already deactivated :)

Comment 2 Garrett Holmstrom 2010-03-23 00:02:35 UTC
Agreed, a change in its behavior here would definitely make things clearer.  I submitted this upstream; we'll see what they have to say.  I can't patch such behavioral changes in, of course, so we'll see what, if anything, they do with the next release.

Upstream bug:  https://bugs.launchpad.net/euca2ools/+bug/544676

Comment 3 Fedora Update System 2010-08-25 23:04:53 UTC
euca2ools-1.3-1.fc14 has been submitted as an update for Fedora 14.
http://admin.fedoraproject.org/updates/euca2ools-1.3-1.fc14

Comment 4 Fedora Update System 2010-08-25 23:06:02 UTC
euca2ools-1.3-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/euca2ools-1.3-1.fc13

Comment 5 Fedora Update System 2010-08-25 23:06:42 UTC
euca2ools-1.3-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/euca2ools-1.3-1.fc12

Comment 6 Fedora Update System 2010-08-26 02:14:25 UTC
euca2ools-1.3-1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update euca2ools'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/euca2ools-1.3-1.fc14

Comment 7 Fedora Update System 2010-09-21 01:32:25 UTC
euca2ools-1.3.1-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2010-09-21 01:34:53 UTC
euca2ools-1.3.1-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2010-09-23 12:32:08 UTC
euca2ools-1.3.1-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.