Bug 575258 - Procedure to bundle and install image fails
Summary: Procedure to bundle and install image fails
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: euca2ools
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Garrett Holmstrom
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-03-19 20:52 UTC by Robert Banfield
Modified: 2010-09-23 12:32 UTC (History)
2 users (show)

Fixed In Version: euca2ools-1.3.1-1.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-09-21 01:32:38 UTC


Attachments (Terms of Use)

Description Robert Banfield 2010-03-19 20:52:43 UTC
Description of problem:
An ISO is created containing a file system for EC2.  This ISO is uploaded to EC2 and capable of running fine using the Amazon tools (provided /usr/bin/openssl is replaced with a 0.9.8 variant, otherwise Amazon's tools also fail  and in a similar fashion).  When the ISO is uploaded using the Euca2ools, it moves directly from the pending to the terminated state, with the console output entirely blank.  

I have seen this before when the manifest generated is corrupt.

Version-Release number of selected component (if applicable):
python-boto-1.9b-2.fc12.noarch
euca2ools-1.2-1.fc12.noarch

How reproducible:
Always

Steps to Reproduce:
1.  euca-bundle-image -i $IMAGE --cert=$EC2CERT --privatekey=$EC2PK --user=$EC2AWSUSER -r $BASEARCH --block-device-mapping='ami=sda1,root=/dev/sda1,ephemeral0=sda2,swap=sda3' --kernel $KERNEL --ramdisk $RAMDISK --ec2cert=/root/EC2/support/ec2-ami-tools-1.3-31780/etc/ec2/amitools/cert-ec2.pem -U 'http://ec2.amazonaws.com'
2.  euca-upload-bundle -b $BUCKET -m ${IMAGE}.manifest.xml -a $EC2AWSID -s $EC2AWSSECRET -U 'http://s3.amazonaws.com'
3.  $EC2APIHOME/ec2-register -K $AWSCREDENTIALS ${BUCKET}/${IMAGEFILE}.manifest.xml

  
Actual results:
Launch some instances, they all move immediately from the pending to the terminated state.

Expected results:
Launch some instances, they go from pending to having IP addresses.

Additional info:

Comment 1 Garrett Holmstrom 2010-03-23 04:26:54 UTC
If you could, please try this out again with euca2ools-1.2-2 when it hits updates-testing and let me know if it works.

Comment 2 Robert Banfield 2010-03-24 19:55:24 UTC
Same error.  I have also removed the -U parameter from step 1 without success.   Still I get no output via ec2-get-console-output.

Comment 3 Garrett Holmstrom 2010-04-03 18:29:44 UTC
Do things seem to work when you don't use block device mapping?  Judging by what I have heard, upstream's test suites don't seem to cover that feature at all, so it would help to see if that's the cause of the problem.  If that isn't the cause, can you give some more details about what you're doing so it's easier to reproduce the problem?

Comment 4 Garrett Holmstrom 2010-05-22 20:14:26 UTC
Upstream claims to have added block device mapping support to its development builds.  Would you be up for testing such a build on Fedora?  Otherwise we can wait for the next upstream release.

Comment 5 Fedora Update System 2010-08-25 23:04:57 UTC
euca2ools-1.3-1.fc14 has been submitted as an update for Fedora 14.
http://admin.fedoraproject.org/updates/euca2ools-1.3-1.fc14

Comment 6 Fedora Update System 2010-08-25 23:06:07 UTC
euca2ools-1.3-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/euca2ools-1.3-1.fc13

Comment 7 Fedora Update System 2010-08-25 23:06:46 UTC
euca2ools-1.3-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/euca2ools-1.3-1.fc12

Comment 8 Fedora Update System 2010-08-26 02:14:30 UTC
euca2ools-1.3-1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update euca2ools'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/euca2ools-1.3-1.fc14

Comment 9 Fedora Update System 2010-09-21 01:32:29 UTC
euca2ools-1.3.1-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2010-09-21 01:34:57 UTC
euca2ools-1.3.1-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2010-09-23 12:32:13 UTC
euca2ools-1.3.1-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.