Bug 57534 - anaconda fails after formating "rpm.error: match tag missing in new header"
anaconda fails after formating "rpm.error: match tag missing in new header"
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-14 18:54 EST by Christopher A. Nielsen
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-14 18:55:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda dump (53.67 KB, text/plain)
2001-12-14 18:55 EST, Christopher A. Nielsen
no flags Details

  None (edit)
Description Christopher A. Nielsen 2001-12-14 18:54:34 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.2.17-14 i686)

Description of problem:
Unable to install RH7.2. Tried via kickstart, also tried manual install
(boot: linux dd) since I'm using a SMC ISA net card. NFS distribution files
are on RH7.0, and genhdlist was run on RH7.0 system.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Attempt any install via NFS
2.
3.
	

Actual Results:  After format of /boot, error traceback "rpm.error: match
tag missing in new header"

Expected Results:  loading of system

Additional info:

Traceback (innermost last):
  File "/usr/bin/anaconda", line 620, in ?
    intf.run(id, dispatch, configFileData)
  File "/usr/lib/anaconda/text.py", line 408, in run
    dispatch.gotoNext()
  File "/usr/lib/anaconda/dispatch.py", line 143, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 208, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/packages.py", line 434, in doPreInstall
    method.mergeFullHeaders(id.hdList)
  File "/usr/lib/anaconda/image.py", line 26, in mergeFullHeaders
    hdlist.mergeFullHeaders(self.tree + "/RedHat/base/hdlist2")
  File "/usr/lib/anaconda/comps.py", line 161, in mergeFullHeaders
    rpm.mergeHeaderListFromFD(self.hdlist, fd, 1000004)
rpm.error: match tag missing in new header


It would be quite helpful if there were some 'anaconda error dictionary'. I
find these sort of errors quite frustrating, because I have no idea how to
approach it for a workaround (having used python, but not that much). I
don't mind trying different things to try to sort it out, but this leaves
me no clue as to what the problem is.

My anaconda is on a 7.0 machine - since I can't build a 7.2 machine even
manually and I don't have a CD-burner I have no idea what else to try.
Comment 1 Christopher A. Nielsen 2001-12-14 18:55:33 EST
Created attachment 40707 [details]
anaconda dump
Comment 2 Christopher A. Nielsen 2001-12-17 01:10:25 EST
Fixed..

It seems that using prior versoins of genhdlist on RH7.2 is not a good thing.
Trouble is, the obvious thing when setting up a new version like this, is that
the NFS install files (containing RedHat/RPMS, etc) got set up on an existing
(RH7.0) machine. The RH7.0 genhdlist was run with no apparant error - genhdlist
should do a check to make sure it's running against the correct tree - that
would help prevent this sort of mistake with very cryptic results!

-C

Note You need to log in before you can comment on or make changes to this bug.