Bug 575425 - bacula-debuginfo 5.0.1-1 lacks sources
bacula-debuginfo 5.0.1-1 lacks sources
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: bacula (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Andreas Thienemann
Fedora Extras Quality Assurance
: Regression
Depends On:
Blocks: DebugInfo
  Show dependency treegraph
 
Reported: 2010-03-20 13:43 EDT by Ville Skyttä
Modified: 2010-06-24 12:32 EDT (History)
8 users (show)

See Also:
Fixed In Version: bacula-5.0.2-5.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-23 13:44:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Build with $RPM_OPT_FLAGS, show compiler commands in build log (1.23 KB, patch)
2010-06-02 13:13 EDT, Ville Skyttä
no flags Details | Diff

  None (edit)
Description Ville Skyttä 2010-03-20 13:43:58 EDT
bacula-debuginfo 5.0.1-1 lacks sources, this may be because it might not have been built with $RPM_OPT_FLAGS or some other issues, see blocker bug for more possible reasons.

It's hard to tell much at all from the build logs because the build appears to suppress the actual compiler command lines used; I suggest checking if there is some kind of a verbose flag that can be used to prevent that.
Comment 1 Fedora Update System 2010-06-01 16:14:01 EDT
bacula-5.0.2-3.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/bacula-5.0.2-3.fc13
Comment 2 Ville Skyttä 2010-06-02 13:13:39 EDT
Created attachment 419104 [details]
Build with $RPM_OPT_FLAGS, show compiler commands in build log

http://kojipkgs.fedoraproject.org/packages/bacula/5.0.2/4.fc14/data/logs/x86_64/build.log

debuginfo is no longer empty, but the build still does not show all compiler command lines used, and the few that are shown do not include $RPM_OPT_FLAGS.

Fix for both issues is attached.
Comment 3 Jon Ciesla 2010-06-02 13:19:00 EDT
CCIng Jan.

Jan, if you intend to import your fixes in the very near future, could you include this?  If not, I'll get this in sooner rather than later.
Comment 4 Fedora Update System 2010-06-02 14:06:40 EDT
bacula-5.0.2-3.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update bacula'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/bacula-5.0.2-3.fc13
Comment 5 Fedora Update System 2010-06-03 08:42:13 EDT
bacula-5.0.2-5.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/bacula-5.0.2-5.fc13
Comment 6 Fedora Update System 2010-06-04 14:50:43 EDT
bacula-5.0.2-5.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update bacula'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/bacula-5.0.2-5.fc13
Comment 7 Fedora Update System 2010-06-23 13:44:10 EDT
bacula-5.0.2-3.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2010-06-24 12:32:27 EDT
bacula-5.0.2-5.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.