Bug 57543 - Unresolved symbols in modules on a kernel recompilation
Summary: Unresolved symbols in modules on a kernel recompilation
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 7.1
Hardware: alpha Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-12-15 07:00 UTC by Michal Jaegermann
Modified: 2007-04-18 16:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-07 23:39:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to make modules happy if redefined symbols are in use (370 bytes, patch)
2001-12-15 07:02 UTC, Michal Jaegermann
no flags Details | Diff

Description Michal Jaegermann 2001-12-15 07:00:58 UTC
Description of Problem:

After recompilation of a kernel cofigured for Alpha-Nautilus
'make modules_install' complains about unresolved symbols
irongate_ioremap and irongate_iounmap for a number of modules.
This module list includes such "exotics" like tulip and support
for X.  The problem is that ioremap and iounmap symbols are
redefined in include/asm-alpha/core_irongate.h but new symbols
are not exported.

An attached patch ensures that required symbols are exported.
Possibly "|| CONFIG_ALPHA_GENERIC" is not required here but this
was not tested.

Version-Release number of selected component (if applicable):

kernel-source-2.4.9-12

Comment 1 Michal Jaegermann 2001-12-15 07:02:20 UTC
Created attachment 40729 [details]
Patch to make modules happy if redefined symbols are in use

Comment 2 Michal Jaegermann 2001-12-20 07:23:39 UTC
A condition in the attached patch should really be

#ifdef CONFIG_ALPHA_IRONGATE

A patch like that, for 2.4.17rc2, was posted on linux-kernel list.

Comment 3 Alan Cox 2003-06-07 23:39:39 UTC
Alpha is no longer a supported platform



Note You need to log in before you can comment on or make changes to this bug.