Bug 57550 - --bytes-per-inode kickstart option problem
--bytes-per-inode kickstart option problem
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: anaconda (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
Mike McLean
FC4
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-15 09:13 EST by Jarek Polok
Modified: 2007-11-30 17:06 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-14 15:20:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jarek Polok 2001-12-15 09:13:56 EST
Description of Problem:

--bytes-per-inode option in kickstart install mode does not work on 
per partition basis, but globally.
In addition the last value used in per partition option is set for all
partitions having the option. 
Note that it happens ONLY in kickstart mode 


How Reproducible:

Use kickstart install file with options alike:

part /part1 [other opts] --on-disk=sda 
part /part2 [other opts] --on-disk=sdb --bytes-per-inode=266144

[I'm not sure if the same will happen if you have partitions on same disk]

Then install the system using it, check number of bytes per inode 
with dumpe2fs.

Actual Results:

/part1 and /part2 will have 266144 bytes per inode ...


Expected Results:

/part1 - default bytes-per-inode
/part2 266144 bytes-per-inode

Additional Information:

It seems that some values are not cleared in a for loop in
anaconda's sources: kickstart.py file.
Comment 1 Michael Fulbright 2002-01-16 15:40:55 EST
Will be fixed in the next release.
Comment 2 Michael Fulbright 2002-03-26 12:30:11 EST
Deferring to future release.
Comment 3 Brent Fox 2004-12-10 12:56:35 EST
I'm reopening this bug because it was never fixed and I now have a
customer that is hitting this issue.
Comment 4 test 2004-12-14 15:38:10 EST
-

Note You need to log in before you can comment on or make changes to this bug.