Bug 57551 - up2date fails to determine proper system architecture
up2date fails to determine proper system architecture
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-15 10:24 EST by Need Real Name
Modified: 2015-01-07 18:53 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-26 20:11:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-12-15 10:24:13 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.5) Gecko/20011012

Description of problem:
up2date attempts to upgrade glibc for the incorrect system architecture.
Attempting to apply updates to glibc on an i586 machine fails because
up2date attempts to install the i686 glibc package.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.run up2date -p
2.On a i586 machine, it attempts to install glibc for an i686
3.
	

Actual Results:  The command output was:
Test install failed because of package conflicts:
package glibc-2.2.4-19.3 is for a different architecture


Expected Results:  up2date should have downloaded and installed the
packages required.
Since the current package it was trying to upgrade was built for an
i386,perhaps it should have honored the already installed package?

Manually downloading glibc-2.2.4-19.3.i386.rpm and putting it in
/var/spool/up2date didn't help either. I had hoped up2date would 
see the package and use it

Additional info:

# cat /proc/cpuinfo
processor       : 0
vendor_id       : CentaurHauls
cpu family      : 5
model           : 4
model name      : WinChip C6

# rpm -q kernel --qf "%{NAME} %{VERSION} %{ARCH}\n"
kernel 2.4.9 i586
# rpm -q  glibc --qf "%{NAME} %{VERSION} %{ARCH}\n"
glibc 2.2.4 i386

[root@firestorm up2date]# ls
glibc-2.2.4-19.3.i686.hdr         
glibc-common-2.2.4-19.3.i386.hdr  
glibc-devel-2.2.4-19.3.i386.hdr
Comment 1 Need Real Name 2001-12-16 00:41:30 EST
Above:
Steps to Reproduce:
1.run up2date -p

Should of course be:

Steps to Reproduce:
1.run up2date -u
Comment 2 Per Sjoholm 2001-12-17 17:17:24 EST
I have the same problem on one machine running rh7.1, it tries ti install a i686
package
Is there a difference between rh7.2 and rh7.1 because on rh7.2 the glibc i386
package is chosen.
Comment 3 Adrian Likins 2002-01-07 19:01:06 EST
This was partly a server side issue. Are you still seeing this
behaviour?
Comment 4 Need Real Name 2002-01-07 22:33:11 EST
I don't know, to be honest. 
I manually updated the packages, so I'm at a loss as to how to test it.

If you have a suggestion, I'd be happy to try it.

Note You need to log in before you can comment on or make changes to this bug.