Bug 575557 - Fedora keeps restarting - since today's upgrade
Fedora keeps restarting - since today's upgrade
Status: CLOSED DUPLICATE of bug 575417
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
rawhide
All Linux
low Severity urgent
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
Depends On: 575417
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-21 09:27 EDT by damian
Modified: 2010-03-24 18:14 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-24 18:14:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description damian 2010-03-21 09:27:45 EDT
Description of problem:
After today's yum upgrade on rawhide, fedora keeps restarting each time
about ten seconds after login (text or graphical)
I don't think it is because from kernel-package (the older ones have *NOW* the same problem), but I do not know what it could be, so I've marked kernel as the component.


Actual results:
Fedora start up and restarts

Expected results:
Fedora start up

Mar 21 09:13:34 Installed: netpbm-10.47.10-3.fc14.i686
Mar 21 09:13:38 Installed: netpbm-progs-10.47.10-3.fc14.i686
Mar 21 10:02:51 Installed: 7:kdegraphics-devel-4.4.1-1.fc14.i686
Mar 21 10:27:08 Updated: krb5-libs-1.8-4.fc14.i686
Mar 21 10:27:09 Updated: openssh-5.4p1-3.fc14.i686
Mar 21 10:27:10 Updated: libudev-151-5.fc14.i686
Mar 21 10:27:11 Updated: 32:bind-libs-9.7.0-6.P1.fc14.i686
Mar 21 10:27:15 Updated: coreutils-8.4-6.fc14.i686
Mar 21 10:27:15 Updated: coreutils-libs-8.4-6.fc14.i686
Mar 21 10:27:24 Updated: python-2.6.5-1.fc14.i686
Mar 21 10:27:25 Updated: python-libs-2.6.5-1.fc14.i686
Mar 21 10:27:27 Updated: system-config-printer-libs-1.2.0-4.fc14.i686
Mar 21 10:27:28 Updated: authconfig-6.1.1-1.fc14.i686
Mar 21 10:27:31 Updated: udev-151-5.fc14.i686
Mar 21 10:27:32 Updated: openldap-2.4.21-6.fc14.i686
Mar 21 10:27:33 Updated: libcurl-7.20.0-3.fc14.i686
Mar 21 10:27:34 Updated: 12:dhclient-4.1.1-14.fc14.i686
Mar 21 10:27:37 Updated: groff-1.20.1-1.fc14.i686
Mar 21 10:27:38 Updated: ntpdate-4.2.6p1-0.1.rc5.fc14.i686
Mar 21 10:27:39 Updated: ntp-4.2.6p1-0.1.rc5.fc14.i686
Mar 21 10:27:41 Updated: man-1.6f-28.fc14.i686
Mar 21 10:27:43 Updated: curl-7.20.0-3.fc14.i686
Mar 21 10:27:43 Updated: system-config-printer-udev-1.2.0-4.fc14.i686
Mar 21 10:27:44 Updated: krb5-workstation-1.8-4.fc14.i686
Mar 21 10:27:45 Updated: 32:bind-utils-9.7.0-6.P1.fc14.i686
Mar 21 10:27:46 Updated: libgudev1-151-5.fc14.i686
Mar 21 10:27:47 Updated: openssh-clients-5.4p1-3.fc14.i686
Mar 21 10:27:48 Updated: openssh-server-5.4p1-3.fc14.i686
Mar 21 10:27:48 Updated: openssh-askpass-5.4p1-3.fc14.i686
Mar 21 10:27:50 Updated: krb5-devel-1.8-4.fc14.i686
Mar 21 10:27:51 Updated: 2:vim-minimal-7.2.403-1.fc14.i686
Mar 21 10:27:52 Updated: pam_pkcs11-0.6.2-3.fc14.i686
Mar 21 10:27:53 Updated: dracut-005-1.fc14.noarch
Mar 21 10:27:55 Updated: smolt-1.4.2.2-1.fc14.noarch
Mar 21 10:27:55 Updated: smolt-firstboot-1.4.2.2-1.fc14.noarch
Mar 21 10:27:56 Updated: authconfig-gtk-6.1.1-1.fc14.i686
Mar 21 10:28:04 Updated: man-pages-3.24-2.fc14.noarch
Mar 21 10:28:07 Updated: kernel-headers-2.6.34-0.13.rc1.git1.fc14.i686
Mar 21 10:28:08 Updated: perf-2.6.34-0.13.rc1.git1.fc14.noarch
Mar 21 10:28:33 Installed: kernel-devel-2.6.34-0.13.rc1.git1.fc14.i686
Mar 21 10:28:33 Updated: ca-certificates-2010-4.fc14.noarch
Mar 21 10:28:42 Installed: kernel-2.6.34-0.13.rc1.git1.fc14.i686
Comment 1 damian 2010-03-21 09:33:22 EDT
Mar 21 03:33:02 fedora1 rsyslogd: [origin software="rsyslogd" swVersion="4.4.2" x-pid="1485" x-info="http://www.rsyslog.com"] rsyslogd was HUPed, type 'restart'.

is the last line in /var/log/messages-20100321 and looks maybe like the problem to me
Comment 2 John Antony 2010-03-23 07:04:14 EDT
module iTCO_wdt (Watch dog timer) sets the restart in my system. 
Blacklisting module iTCO_wdt prevents restarting. 
kernel kernel-2.6.34-0.13.rc1.git1.fc14.i686
udev udev-151-5.fc14.i686
Comment 3 Stephen 2010-03-23 10:57:15 EDT
Blacklisting iTCO_wdt worked for me also
Comment 4 Benjamín Valero Espinosa 2010-03-23 11:02:15 EDT
Perhaps it is the same bug as #575417
Comment 5 Jordan_ad 2010-03-23 20:59:59 EDT
The same problem keeps happening to me, except that it only waits for about 5 seconds after boot up to restart.  Don't know why, but I would like to know how to black list Watchdog to keep it from rebooting my system everytime!
Comment 6 James Laska 2010-03-24 09:09:25 EDT
According to Harald, this issue should be resolved in the latest udev.  Please retest with the latest udev from rawhide ( >= udev-151-8.fc14) - http://koji.fedoraproject.org/koji/buildinfo?buildID=163039
Comment 7 James Laska 2010-03-24 09:13:02 EDT
Better yet, please retest according to the procedure noted at https://bugzilla.redhat.com/show_bug.cgi?id=575417#c13
Comment 8 Stephen John Smoogen 2010-03-24 09:14:48 EDT
jordan_ad

to get around the problem temporarily so you can update to the latest packages
in either rawhide or updates-testing. Do the following:

At the grub menu type e to edit the kernel boot line and add the following:

 rd_blacklist=iTCO_wdt

this will tell dracut to add this blacklist temporarily. You should then be
able to boot up and update the system. If you are using FC12 the package is in
updates-testing (udev-145-19.fc12)
Comment 9 damian 2010-03-24 18:13:05 EDT
Confirming this is fixed >= udev-151-8.fc14.
Comment 10 damian 2010-03-24 18:14:11 EDT

*** This bug has been marked as a duplicate of bug 575417 ***

Note You need to log in before you can comment on or make changes to this bug.