Bug 57556 - Installer hangs loading Adaptec AIC-7896 SCSI driver/ 440GX motherboad
Installer hangs loading Adaptec AIC-7896 SCSI driver/ 440GX motherboad
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-15 13:27 EST by Fred Lewis
Modified: 2014-01-21 17:48 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-07 16:23:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fred Lewis 2001-12-15 13:27:12 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)

Description of problem:
When installing from CDROM, installer hangs on the "Welcome to Red Hat 
Linux" page with a dialog box titled "Loading SCSI Driver" and 
message "Loading aic7xxx Driver...".

Have tried using the "linux dd" option and inserting driver diskette with 
drvblock.img.  Same results.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Insert Red Hat 7.2 disk 1 in CD drive.
2. Press reset switch to reboot.
3.
	

Actual Results:  Same as in description.  Installation starts and then 
hangs trying to load the SCSI driver.
  

Additional info:
Comment 1 Michael Fulbright 2001-12-17 14:29:00 EST
Can you look on VC3 and VC4 to see if there are any obvious kernel error messages?
Comment 2 Fred Lewis 2001-12-17 16:47:53 EST
On VC4, following 5 lines are repeated over and over again:

<4>SCSI (scsi0:0:0:0) Device reset, Message buffer in use
<4>SCSI host 0 Channel 0 reset (pid 0) timed out -- trying harder
<4>SCSI bus is being reset for host 0 channel 0
<4>SCSI host 0 abort (pid 0) timed out -- resetting
<4>SCSI bus is being reset for host 0 channel 0
Comment 3 srinivasa Rao 2001-12-29 07:48:07 EST
installed redhat 7.2 successfully on my 440gx main board it has aic-7896 scsi 
by using apic kernel parameter . Installation part is success but after the 
reboot systems boots, up to some stage hangs and gives this error 
SCSI:ABORTING COMMAND DUE TO TIME OUT PID0,SCSI0,CHANNEL0,ID0,LUN0,INQUIRY 00 
00 00 FF 00. This message keep on roles by increasing id nuber 0-15
Comment 4 Need Real Name 2001-12-31 21:35:56 EST
Supporting comment:
I also have the same problem as noted above 
(440gx motherboard + adaptec aic-7896 controller SCSI trouble).

I found the "boot: linux apic" option and was successful at getting both RH 7.1 
and RH 7.2 installs to complete.

My system does nothing when trying to boot from the SCSI drive using lilo.
It print GRUB and hangs when using grub as the boot loader.
As bsrao_lalita@yahoo.com notes, I get these continuous SCSI error messages but 
only when trying to boot from the boot floppy.
I even tried installing the system to an attached IDE 20 gig drive so I could 
at least boot up with an OS to work from but no joy.

A google search for one particular phrase 
"device reset message buffer in use" from the SCSI errors 
yields numerous other posts of people having the same SCSI problems 
on numerous linux versions for quite some time and with many linux versions.

This leads me to believe that this has been/is an ongoing problem that requires 
some good documentation. I'd be willing to participate in this venture since 
I'll have lot's of experience with this by the time it gets resolved. 
3 days running now : (

Pete

Comment 5 Need Real Name 2002-01-01 15:47:52 EST
More commentary...
I needed to get one of these two "Penguin Computing" Intel L440GX+ Motherboard 
systems running, therefore, I have fallen back to installing RedHat Linux 6.2 
for the time being.

6.2 installs flawlessly with no special arguments to the install process.
The system also boots up flawlessly.
There are no noticable SCSI error messages (so far).

Hopefully, the tech support folks from Penguin Computing will provide some 
specifics for these systems to load 7.1 (PC certified) and 7.2 (bleeding edge) 
that will shed some more light on this matter.

PS: can someone edit the summary line from:

Installer hangs loading Adaptec AIC-78796 SCSI driver.

to:

Installer hangs loading Adaptec AIC-7896 SCSI driver.

that will properly reflect what we are working on?

We are trying to resolve an AIC-7896 controller not an AIC-78796 controller.

Thanks,

Pete
Comment 6 Fred Lewis 2002-01-02 12:12:23 EST
Attempted to change summary from AIC-78796 to AIC7896.
Comment 7 Fred Lewis 2002-01-02 12:32:03 EST
I have exactly the same symptoms on another Intel dual-processor system (440BX) 
with an onboard Symbios Logic 53c875 SCSI controller.  By disabling the SCSI 
controller and disconnecting the SCSI drives, was able to install to an IDE 
disk.  Would not install to the IDE without disconnecting the drives from the 
controller -- SCSI timeouts.
Comment 8 Need Real Name 2002-01-02 13:04:16 EST
I was finally able to install 7.2 and bring up the system by disconnecting the 
4mm SCSI tape drive on the second system.
I'll try the same on the first system that I loaded with 6.2 and see if this is 
the solution for my two systems.
I got this idea from someone else's problem where they tossed one SCSI tape 
drive (bad-mouthing certain vendor was included here unfortunately : ( for 
another vendor's SCSI tape drive. 
Perhaps it is all related to timings and settings since the APIC arguement is 
changing these in some way.
Unfortunately, I have not had time to digest the specifics on what adding APIC 
as an arguement changes.

Ideas/input/documentation pointer anyone?

Thanks,
Pete

PS: thanks for changing the Summary line FV!
Comment 9 Arjan van de Ven 2002-01-04 08:38:55 EST
Most 440GX motherboards have a serious bios bug (which Intel has admitted over 6
months ago) that prevent interrupts from working properly in 2.4 non-SMP
kernels. "apic" is a very nasty hack that works around the bug for the installer
kernel, but you MUST install the smp kernel and use that as the "apic" hack
breaks lots of "runtime" things for other machines, eg we cannot use it for the
normal kernel.

2.2 kernels work fine as they have a much simpler PCI logic (and as a result
don't work properly on some newer hardware)....
Comment 10 Need Real Name 2002-01-04 09:18:59 EST
Is there specific documentation on what 'apic' does?

Is there documentation on what using 'apic' arguement breaks (fixes : ) ?

Is there detailed documentation on the differences/features/similarities of 
each of the following three kernels?

1) smb
2) enterprise
3) up

All three of these are available within GRUB for my install. 

please enlighten me(us), Yoda : )

Pete
Comment 11 Arjan van de Ven 2002-01-04 09:26:02 EST
"apic" enables the ioapic component that is normally used in SMP mode only, and
also uses the bios tables for SMP use instead of the UP tables. (those tables
describe which PCI device uses which interrupt number; the mechanism is
different on SMP due to the io apic use)

However since this is technically a SMP-only component (although it's present in
just about every normal UP system, just not used normally), BIOSes don't expect
it and things like suspend on laptops (and some soundcards) totally break.

About the kernels:

up - single processor only, limited to 4Gb physical ram
smp - multi-processor, limited to 4Gb physical ram
enterprise - multiprocessor, Pentium III and higher, supports upto 64Gb of ram
Comment 12 Lynn Wheelwright 2002-01-05 19:43:52 EST
I also get a scsi failure on installation (boot from cdrom - version 7.2 or 7.1 -- both fail).  The screen says: "loading SCSI driver" and then hangs.
Mother board: MSI 6347 - SCSI chips on board: adaptec 7892.
2 ide disks
2 scsi disks
1 scsi cd burner (plextor)
1 scsi dvd-ram drive
Comment 13 Need Real Name 2002-01-07 08:06:48 EST
Lynn,

Try disconnecting your scsi cd burner & scsi dvd-ram drive and then @ boot: 

linux  apic

and see if it succeeds.  
Is the MSI 6347 also an Intel Motherboard?

I disconnected my 4mm tape drive and the installation succeeded.

Now my installations work correctly with the tape drive attached.
I am thinking that something in the Adaptec Controller (or motherboard) gets
reset if the tape drive is removed.
I haven't had time to debug this because when I connected the tape drive up to
do the debugging it worked. Sigh!
Good for me but bad for debugging : )

Pete
Comment 14 Lynn Wheelwright 2002-01-12 11:38:40 EST
Response to Pete:
1. The MS6347 is not an Intel Motherboard - it is built for AMD parts (Socket A).
2. I can't disconnect my cdrom since the only cdrom capability I have on this machine is on SCSI.  In an earlier attempt, I did manage to get the installer to get beyond 
this point when I did not have the SCSI hard disks connected (but what use is this when I need them configured into the system).
--Lynn
Comment 15 Arjan van de Ven 2002-01-18 13:49:16 EST
Ok this bug is getting several unrelated "me toos" it seems.
The original bug was the 440GX bios bug for which there's "apic". (please
confirm)

I'm asking the other folks to file a seperate bug just for clarity
Comment 16 Need Real Name 2002-01-18 21:26:31 EST
My contribution was that I used the APIC option but this didn't fully fix my
problem on my 440GX motherboard system.
It did allow me to load 7.2 but I ran into numerous SCSI access errors.

I wanted others to know that it may be useful to remove certain items from the
system in order to succeed which is what I was able to make happen.

For my part in all of this, I searched for and found numerous bug reports for
almost related ADAPTEC SCSI Controller fixes but none suggesting that removing
certain sub-systems from the computer may allow one to succeed in certain areas.

Do you still want me to file a separate bug report for that particular
problem/solution or is this one adequate? Either way is fine for me : )

FWIW, you guys have been a good resource and have provided some very useful
contributions!

Thanks!!!

Pete Sherwood
Comment 17 Arjan van de Ven 2003-06-07 16:23:56 EDT
current errata kernels and RHL9 have some magic to enable 440GX to work right

Note You need to log in before you can comment on or make changes to this bug.