Bug 575616 - [abrt] crash in eclipse-platform-1:3.5.1-22.fc12: Process /usr/lib/eclipse/eclipse was killed by signal 6 (SIGABRT)
[abrt] crash in eclipse-platform-1:3.5.1-22.fc12: Process /usr/lib/eclipse/ec...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
12
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Alexander Kurtakov
Fedora Extras Quality Assurance
abrt_hash:5f15233528f67330daa0e5882f1...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-21 15:46 EDT by bifrost
Modified: 2010-09-10 19:09 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-10 19:09:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (99.38 KB, text/plain)
2010-03-21 15:46 EDT, bifrost
no flags Details

  None (edit)
Description bifrost 2010-03-21 15:46:46 EDT
abrt 1.0.8 detected a crash.

architecture: i686
Attached file: backtrace
cmdline: /usr/lib/eclipse/eclipse
comment: just open eclipse and wait, bzflag was also opened
component: eclipse
executable: /usr/lib/eclipse/eclipse
kernel: 2.6.32.9-70.fc12.i686.PAE
package: eclipse-platform-1:3.5.1-22.fc12
rating: 3
reason: Process /usr/lib/eclipse/eclipse was killed by signal 6 (SIGABRT)
release: Fedora release 12 (Constantine)

How to reproduce
-----
1. open eclipse
2. let's play bzflag for some time
3.
Comment 1 bifrost 2010-03-21 15:46:51 EDT
Created attachment 401591 [details]
File: backtrace
Comment 2 bifrost 2010-03-29 06:03:19 EDT

Comment
-----
eclipse was minimized doing nothing...
Comment 3 Dimi Paun 2010-04-08 12:55:45 EDT

Comment
-----
Clicked on a menu.
Comment 4 Chris Aniszczyk 2010-04-23 10:54:24 EDT
How long did it take? I've been playing for about 5 minutes and can't reproduce :)

What did you have installed in Eclipse? If you go to the About dialog in Eclipse, and hit Installation Details... there's the Configuration tab which has all the specifics there that you can copy to the clipboard and paste into this bug.
Comment 5 Dimi Paun 2010-04-23 11:18:10 EDT
Nah, I keep mine open for days, you can't reproduce in 5 mins :)

In fact, I've seen this crash once or twice only, and I work with Eclipse every day and all day, I wouldn't try to reproduce it. It's futile. Just look at the stack trace, that's the only thing you can go on at this point.

As for what's in my Eclipse, here it goes:

  Android DDMS	0.9.6.v201002051504-24846	com.android.ide.eclipse.ddms.feature.group
  Android Development Tools	0.9.6.v201002051504-24846	com.android.ide.eclipse.adt.feature.group
  Autotools support for CDT (Incubation)	2.0.0.201001052258	org.eclipse.linuxtools.cdt.autotools.feature.group
  BIRT Chart Framework	2.5.0.200908120145	org.eclipse.birt.chart.feature.group
  C/C++ Call Graph Visualization (Incubation)	0.0.1.200911231552	org.eclipse.linuxtools.callgraph.feature.group
  CDT Debugger Services Framework (DSF) Examples	2.0.0.200909110608	org.eclipse.cdt.examples.dsf.feature.group
  CDT GCC Cross Compiler Support	1.0.0.200909110608	org.eclipse.cdt.build.crossgcc.feature.group
  CDT GNU Toolchain Build Support	6.0.0.200909110608	org.eclipse.cdt.gnu.build.feature.group
  CDT GNU Toolchain Build Support Source	6.0.0.200909110608	org.eclipse.cdt.gnu.build.source.feature.group
  CDT GNU Toolchain Debug Support	6.0.0.200909110608	org.eclipse.cdt.gnu.debug.feature.group
  CDT GNU Toolchain Debug Support Source	6.0.0.200909110608	org.eclipse.cdt.gnu.debug.source.feature.group
  CDT Utilities	5.1.0.200909110608	org.eclipse.cdt.util.feature.group
  ChangeLog management tools (Incubation)	2.6.7.200908180856	org.eclipse.linuxtools.changelog.feature.group
  CMake Editor	1.1.4	com.cthing.cmakeed.feature.feature.group
  com.ibm.icu	4.0.1.v20090415	com.ibm.icu.feature.group
  Convert feature.xml/pom.xml to RPM specfiles (Incubation)	0.3.0.201003171651	org.eclipse.linuxtools.rpmstubby.feature.group
  Data Tools Platform Connectivity	1.7.0.v200906151043	org.eclipse.datatools.connectivity.feature.feature.group
  Data Tools Platform Enablement for HSQLDB	1.7.0.v200906151043	org.eclipse.datatools.enablement.hsqldb.feature.feature.group
  Data Tools Platform Enablement for IBM	1.7.0.v200906151043	org.eclipse.datatools.enablement.ibm.feature.feature.group
  Data Tools Platform Enablement for JDBC	1.7.0.v200906151043	org.eclipse.datatools.enablement.jdbc.feature.feature.group
  Data Tools Platform Enablement for Microsoft	1.7.0.v200906151043	org.eclipse.datatools.enablement.msft.feature.feature.group
  Data Tools Platform Enablement for MySQL	1.7.0.v200906151043	org.eclipse.datatools.enablement.mysql.feature.feature.group
  Data Tools Platform Enablement for ODA Runtime	1.7.0.v200906151043	org.eclipse.datatools.enablement.oda.feature.feature.group
  Data Tools Platform Enablement for Oracle	1.7.0.v200906151043	org.eclipse.datatools.enablement.oracle.feature.feature.group
  Data Tools Platform Enablement for PostgreSQL	1.7.0.v200906151043	org.eclipse.datatools.enablement.postgresql.feature.feature.group
  Data Tools Platform JDT Enablement	1.7.0.v200906151043	org.eclipse.datatools.enablement.jdt.feature.feature.group
  Data Tools Platform Model Base	1.7.0.v200906151043	org.eclipse.datatools.modelbase.feature.feature.group
  Data Tools Platform Open Data Access Runtime	1.7.0.v200906151043	org.eclipse.datatools.connectivity.oda.feature.feature.group
  Data Tools Platform SQL Parsers	1.7.0.v200906151043	org.eclipse.datatools.sqldevtools.parsers.feature.feature.group
  Eclipse C/C++ Development Platform	6.0.0.200909110608	org.eclipse.cdt.platform.feature.group
  Eclipse C/C++ Development Tooling Source	6.0.0.200909110608	org.eclipse.cdt.platform.source.feature.group
  Eclipse C/C++ Development Tools	6.0.0.200909110608	org.eclipse.cdt.feature.group
  Eclipse C/C++ Development Tools SDK	6.0.0.200909110608	org.eclipse.cdt.sdk.feature.group
  Eclipse C/C++ DSF gdb Debugger Integration	2.0.0.200909110608	org.eclipse.cdt.gnu.dsf.feature.group
  Eclipse C/C++ DSF gdb Debugger Integration Source	2.0.0.200909110608	org.eclipse.cdt.gnu.dsf.source.feature.group
  Eclipse C/C++ GDB Hardware Debugging	5.1.0.200909110608	org.eclipse.cdt.debug.gdbjtag.feature.group
  Eclipse C/C++ Memory View Enhancements	1.2.0.200909110608	org.eclipse.cdt.debug.ui.memory.feature.group
  Eclipse C/C++ Memory View Enhancements Source	1.2.0.200909110608	org.eclipse.cdt.debug.ui.memory.source.feature.group
  Eclipse C/C++ Remote Launch	6.0.0.200909110608	org.eclipse.cdt.launch.remote.feature.group
  Eclipse CDT p2 Toolchain Installer	1.0.0.200909110608	org.eclipse.cdt.p2.feature.group
  Eclipse Checkstyle Plug-in	4.0.1	com.atlassw.tools.eclipse.checkstyle.feature.group
  Eclipse CVS Client Resources	1.1.101.R35x_v20090811-7E79FEd9KKF5H2UEPDBJ9L01A16	org.eclipse.cvs.source.feature.group
  Eclipse Git Feature (Incubation)	0.6.0.200912140441	org.eclipse.egit.feature.group
  Eclipse Help Developer Resources	1.1.1.R35x_v20090811-7e7eFAxFD3wTVSUkp6Uz0adF	org.eclipse.help.source.feature.group
  Eclipse Java Development Tools	3.5.1.r351_v20090810-0600-7r88FEoFHxXYpY3s0jOJPn58EpLN	org.eclipse.jdt.feature.group
  Eclipse JDT Plug-in Developer Resources	3.5.1.r351_v20090810-0600-7r88FEoFHxXYpY3s0jOJPn58EpLN	org.eclipse.jdt.source.feature.group
  Eclipse JGit Feature (Incubation)	0.6.0.200912081304	org.eclipse.jgit.feature.group
  Eclipse p2 Provisioning Developer Resources	1.1.1.R35x_v20090811-7u6FbEFYXk1qWdbS0gnpRg2932	org.eclipse.equinox.p2.user.ui.source.feature.group
  Eclipse PDE Plug-in Developer Resources	3.5.1.R35x_v20090811-7Z7_F9zFDX-aT6Yswh6QQ73	org.eclipse.pde.source.feature.group
  Eclipse Platform	3.5.1	Eclipse Platform
  Eclipse Platform Plug-in Developer Resources	3.5.1.R35x_v20090910-9pEeGFdFtnSu79iXcyV8_-gIogwPjafr5DGB7	org.eclipse.platform.source.feature.group
  Eclipse Plug-in Development Environment	3.5.1.R35x_v20090811-7Z7_F9zFDX-aT6Yswh6QQ73	org.eclipse.pde.feature.group
  Eclipse Project SDK	3.5.1.R35x_v20090811-7Q7bAIAve_6wiRRDlScZkTz0KWtKj1hfJZMVushH-8HJJ	org.eclipse.sdk.feature.group
  Eclipse RCP Plug-in Developer Resources	3.5.1.R35x_v20090811-9sAiFxdFrfSVki-JAowu4M6e7BA6	org.eclipse.rcp.source.feature.group
  EMF - Eclipse Modeling Framework Core Runtime	2.5.0.v200906151043	org.eclipse.emf.ecore.feature.group
  EMF - Eclipse Modeling Framework Runtime and Tools	2.5.0.v200906151043	org.eclipse.emf.feature.group
  EMF Code Generation	2.5.0.v200906151043	org.eclipse.emf.codegen.feature.group
  EMF Code Generation UI	2.4.0.v200906151043	org.eclipse.emf.codegen.ui.feature.group
  EMF Common	2.5.0.v200906151043	org.eclipse.emf.common.feature.group
  EMF Common UI	2.5.0.v200906151043	org.eclipse.emf.common.ui.feature.group
  EMF Data Binding	1.1.0.v200906151043	org.eclipse.emf.databinding.feature.group
  EMF Ecore Code Generator	2.5.0.v200906151043	org.eclipse.emf.codegen.ecore.feature.group
  EMF Ecore Code Generator UI	2.5.0.v200906151043	org.eclipse.emf.codegen.ecore.ui.feature.group
  EMF Ecore Edit	2.5.0.v200906151043	org.eclipse.emf.ecore.edit.feature.group
  EMF Ecore Mapping	2.5.0.v200906151043	org.eclipse.emf.mapping.ecore.feature.group
  EMF Ecore Mapping Editor	2.5.0.v200906151043	org.eclipse.emf.mapping.ecore.editor.feature.group
  EMF Edit	2.5.0.v200906151043	org.eclipse.emf.edit.feature.group
  EMF Edit Data Binding	1.1.0.v200906151043	org.eclipse.emf.databinding.edit.feature.group
  EMF Edit UI	2.5.0.v200906151043	org.eclipse.emf.edit.ui.feature.group
  EMF Mapping	2.5.0.v200906151043	org.eclipse.emf.mapping.feature.group
  EMF Mapping UI	2.5.0.v200906151043	org.eclipse.emf.mapping.ui.feature.group
  EMF Model Converter	2.5.0.v200906151043	org.eclipse.emf.converter.feature.group
  EMF Sample Ecore Editor	2.5.0.v200906151043	org.eclipse.emf.ecore.editor.feature.group
  Graphical Editing Framework Draw2d	3.5.1.v20090915-1220	org.eclipse.draw2d.feature.group
  Graphical Editing Framework GEF	3.5.1.v20090915-1220	org.eclipse.gef.feature.group
  Graphical Editing Framework Zest Visualization Toolkit	1.1.1.v20090915-1220	org.eclipse.zest.feature.group
  JavaScript Developer Tools	1.1.2.v200908101420-77-FGDCcNBDjBXMoBbFb	org.eclipse.wst.jsdt.feature.feature.group
  JNA Library	3.0.9	com.sun.jna.feature.group
  JST Server Adapters	3.1.1.v20090813-777HFDPCcNBBz0BjJU4BA8	org.eclipse.jst.server_adapters.ext.feature.feature.group
  Libhover Feature (Incubation)	0.2.0.201001052258	org.eclipse.linuxtools.cdt.libhover.feature.group
  Mozilla Rhino Feature	1.7.1.v20090608	org.mozilla.rhino.feature.group
  Mylyn Bridge: C/C++ Development	5.1.0.200909110608	org.eclipse.cdt.mylyn.feature.group
  Mylyn Bridge: Eclipse IDE	3.2.1.v20090722-0200-e3x	org.eclipse.mylyn.ide_feature.feature.group
  Mylyn Bridge: Java Development	3.2.1.v20090722-0200-e3x	org.eclipse.mylyn.java_feature.feature.group
  Mylyn Bridge: Team Support	3.2.1.v20090722-0200-e3x	org.eclipse.mylyn.team_feature.feature.group
  Mylyn Connector: Bugzilla	3.2.1.v20090722-0200-e3x	org.eclipse.mylyn.bugzilla_feature.feature.group
  Mylyn Connector: Web Templates (Advanced)	3.2.1.v20090722-0200-e3x	org.eclipse.mylyn.web.tasks_feature.feature.group
  Mylyn Task List (Required)	3.2.1.v20090722-0200-e3x	org.eclipse.mylyn_feature.feature.group
  Mylyn Task-Focused Interface (Recommended)	3.2.1.v20090722-0200-e3x	org.eclipse.mylyn.context_feature.feature.group
  OProfile Integration (Incubation)	0.3.0.200911191630	org.eclipse.linuxtools.oprofile.feature.group
  Profile Framework (Incubation)	0.3.0.200908180856	org.eclipse.linuxtools.profiling.feature.group
  PyDev for Eclipse	1.5.3.1260390783	org.python.pydev.feature.feature.group
  QuickREx Feature	3.5.0	de.babe.eclipse.plugins.QuickREx.feature.group
  Remote System Explorer End-User Runtime	3.1.1.v200907301400-7L5AE8wqaHPUdsOqKFUpxnbxGiz-	org.eclipse.rse.feature.group
  Remote System Explorer Extender SDK	3.1.1.v200907301400-7U78AFF8Wz-QWxVKUVnCs7-PcuWk	org.eclipse.rse.sdk.feature.group
  RPM Import/Export and Building Tool (Incubation)	0.4.3.201003171651	org.eclipse.linuxtools.rpm.feature.group
  RPM Specfile Editor (Incubation)	0.4.3.201003171651	org.eclipse.linuxtools.rpm.ui.editor.feature.group
  RSE Core	3.1.1.v200907301400-7a7CEwFC7sRTNSwodfv_u	org.eclipse.rse.core.feature.group
  RSE Core Source	3.1.1.v200907301400-7a7CEwFC7sRTNSwodfv_u	org.eclipse.rse.core.source.feature.group
  RSE DStore Services	3.1.1.v200907301400-7L6EsEVVFGMG4TyOVFU	org.eclipse.rse.dstore.feature.group
  RSE DStore Services Source	3.1.1.v200907301400-7L6EsEVVFGMG4TyOVFU	org.eclipse.rse.dstore.source.feature.group
  RSE FTP Service	3.0.101.v200909160005-780A89oB55W5OAP9A9I	org.eclipse.rse.ftp.feature.group
  RSE FTP Service Source	3.0.101.v200909160005-780A89oB55W5OAP9A9I	org.eclipse.rse.ftp.source.feature.group
  RSE Local Services	2.1.101.v200907301400-7B4EqBgJ99r9dJ_GM9E	org.eclipse.rse.local.feature.group
  RSE Local Services Source	2.1.101.v200907301400-7B4EqBgJ99r9dJ_GM9E	org.eclipse.rse.local.source.feature.group
  RSE SSH Services	3.0.1.v200909160005-7A2BhAkF77g7VEYDG7C	org.eclipse.rse.ssh.feature.group
  RSE SSH Services Source	3.0.1.v200909160005-7A2BhAkF77g7VEYDG7C	org.eclipse.rse.ssh.source.feature.group
  RSE Telnet Service	2.2.1.v200908051630-7730AkF77g7UDXELEF	org.eclipse.rse.telnet.feature.group
  RSE Telnet Service Source	2.2.1.v200908051630-7730AkF77g7UDXELEF	org.eclipse.rse.telnet.source.feature.group
  RSE Terminals UI	1.0.1.v200907301400-77-39uC7FSAW8XBVLD3622	org.eclipse.rse.terminals.feature.group
  RSE Terminals UI Source	1.0.1.v200907301400-77-39uC7FSAW8XBVLD3622	org.eclipse.rse.terminals.source.feature.group
  ShellEd	1.0.4	com.something.eclipse.shelled.feature.group
  Subclipse (Required)	1.6.5	org.tigris.subversion.subclipse.feature.group
  Subversion Client Adapter (Required)	1.6.4.1	org.tigris.subversion.clientadapter.feature.feature.group
  Subversion JavaHL Native Library Adapter (Required)	1.6.4.1	org.tigris.subversion.clientadapter.javahl.feature.feature.group
  SVNKit Client Adapter (Not required)	1.6.4	org.tigris.subversion.clientadapter.svnkit.feature.feature.group
  SVNKit Library	1.3.0	org.tmatesoft.svnkit.feature.group
  SystemTap GUI	1.0.0	com.ibm.systemtapgui.systemtap.feature.feature.group
  Target Management Terminal Widget	3.0.1.v200907301400-4-07w311A18412511	org.eclipse.tm.terminal.feature.group
  Valgrind Tools Integration (Incubation)	0.3.0.200911031725	org.eclipse.linuxtools.valgrind.feature.group
  Web Page Editor (Optional)	2.2.1.v20090813-4369oB55W5S7G	org.eclipse.jst.webpageeditor.feature.feature.group
Comment 6 Andrew Overholt 2010-08-23 15:59:05 EDT
This looks like it's a leak somewhere but I'm having a hard time figuring out from the backtrace (maybe the SWT-Mozilla code?).  Is this still happening?
Comment 7 Alexander Kurtakov 2010-09-01 02:11:40 EDT
Yes, it is happening. Xulrunner changes are still crashing Eclipse.
Comment 8 Fedora Update System 2010-09-01 02:15:38 EDT
eclipse-3.5.1-23.fc12 has been submitted as an update for Fedora 12.
https://admin.fedoraproject.org/updates/eclipse-3.5.1-23.fc12
Comment 9 Fedora Update System 2010-09-08 21:20:35 EDT
eclipse-3.5.1-23.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Admin XMLRPC Client 2010-09-10 13:00:55 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 11 Alexander Kurtakov 2010-09-10 19:09:26 EDT
Update to fix this issue has been pushed. Please reopen if the bug still persist.

Note You need to log in before you can comment on or make changes to this bug.