Bug 57562 - tftp-server fails to send file on the form host:file
tftp-server fails to send file on the form host:file
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: tftp (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Elliot Lee
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-15 16:21 EST by Frode Tennebø
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-18 15:28:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Frode Tennebø 2001-12-15 16:21:44 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.79 [en] (X11; U; Linux 2.4.9-13custom i686)

Description of problem:
I believe this is a fault with in.tftp and not with the client. I'm trying
to set up an X-Terminal which receives it's server code from the
tftp-server. Since this does not work I tried the tftp client with various
commands. It appears that I have to either implicit connect on the
command-line (e. #tftp localhost) or explicit (ie. tftp> connect
localhost).

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Make /tftpboot/some-file
2. Start in.tftpd from xinetd
3. tftp
4. get localhost:/some-file 
	

Actual Results:  [ft@leia ft]$ tftp
tftp> verbose
Verbose mode on.
tftp> get localhost:/hds-fx/config/config.fx
getting from localhost:/hds-fx/config/config.fx to config.fx [netascii]
tftp: sendto: Invalid argument
tftp> get "localhost:/hds-fx/config/config.fx"
tftp: "localhost: Unknown host
tftp> get "localhost":/hds-fx/config/config.fx
tftp: "localhost": Unknown host
tftp> get 127.0.0.1:/hds-fx/config/config.fx
getting from 127.0.0.1:/hds-fx/config/config.fx to config.fx [netascii]
tftp: sendto: Invalid argument
tftp> get 10.0.0.10:/hds-fx/config/config.fx
getting from 10.0.0.10:/hds-fx/config/config.fx to config.fx [netascii]
tftp: sendto: Invalid argument



Expected Results:  tftp> connect 10.0.0.10
tftp> get /hds-fx/config/config.fx
getting from 10.0.0.10:/hds-fx/config/config.fx to config.fx [netascii]
Received 1593 bytes in 0.0 seconds [inf bits/sec]


Additional info:

Since my X-Terminal only supports the implicit form, I'm not able to
continue.
Comment 1 Elliot Lee 2001-12-18 15:51:16 EST
I believe this is a bug in the client. Here's the patch I made:
--- ./main.c.sopwith	Tue Dec 18 15:32:16 2001
+++ ./main.c	Tue Dec 18 15:37:13 2001
@@ -162,6 +162,7 @@
 
	fprintf(stderr, "tftp: udp/tftp: unknown service\n");
 
	exit(1);
 	}
+
port = sp->s_port;
 	f = socket(AF_INET, SOCK_DGRAM, 0);
 	if (f < 0) {
 
	perror("tftp: socket");
Comment 2 Frode Tennebø 2001-12-18 17:09:07 EST
Darn. It solves the bug but in the wrong place. :/ It does not explain why my 
X-terminal won't download from the tftp-server......

Perhaps you can tell me why tftpd won't log anything to syslog? I have the 
following line in /etc/syslog:

authpriv.*                                              /var/log/secure

But the only thing that gets logged is:

Dec 18 23:03:51 leia xinetd[7121]: START: tftp pid=25551 from=10.0.0.10
Comment 3 Frode Tennebø 2001-12-25 18:02:22 EST
It turned out that one of the ports on my hub was broken. However, I still 
don't get syslog-ed the precompiled tftpd. It works with my own compiled 
version, but that one won't transfer any files. Mighty strange.....I need to 
investigate some more if you don't have any hints....?

Note You need to log in before you can comment on or make changes to this bug.