Bug 57569 - pump won't stop adding ipchains rules
pump won't stop adding ipchains rules
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: pump (Show other bugs)
7.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Eido Inoue
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-16 01:58 EST by Sharif Nassar
Modified: 2007-04-18 12:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-05 11:03:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sharif Nassar 2001-12-16 01:58:07 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.5) Gecko/20011016

Description of problem:
Every time pump gets a new lease, it insists on adding new ipchains rules
to allow nameservers responses.  ordinarily this would be a good thing, but
my ipchains rulesets are getting very long, and repetitive.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. set up some ipchains rules
2. run pump
3. wait for a lease to renew.
	

Actual Results:  suckage.

Expected Results:  non suckage.

Additional info:

(nameserver IPs changed to protect the innocent)

Dec 15 19:46:19 mrwacky pumpd[3736]: renewed lease for interface eth0
Dec 15 19:46:19 mrwacky logger: punching nameserver 2.4.2.2 through the
firewall
Dec 15 19:46:19 mrwacky logger: punching nameserver 1.1.1.1 through the
firewall
Dec 15 22:19:29 mrwacky pumpd[3736]: renewed lease for interface eth0
Dec 15 22:19:30 mrwacky logger: punching nameserver 2.4.2.2 through the
firewall
Dec 15 22:19:30 mrwacky logger: punching nameserver 1.1.1.1 through the
firewall
Comment 1 Olivier Baudron 2001-12-31 17:22:33 EST
What is the content of your /etc/pump.conf?
If it contains a 'script' directive, can you also give the content of this file?
Comment 2 Need Real Name 2002-06-14 20:31:29 EDT
I've since stopped using pump, so this is no longer an issue for me, but in the
 interest of good science, here are the answers (6 months later == (me == slacker)).

mrwacky[root]/# cat /etc/pump.conf 
nodns
script /root/bin/pumpage
mrwacky[root]/# cat /root/bin/pumpage
#!/bin/bash

if [ $1 = "up" ] ; then 
 mail -s "Lease $1" me@somehost.com << HERE
Here is the info: $1 $2 $3
HERE

fi
Comment 3 Need Real Name 2002-06-14 20:34:47 EDT
I've since stopped using pump, so this is no longer an issue for me, but in the
 interest of good science, here are the answers (6 months later == (me == slacker)).

mrwacky[root]/# cat /etc/pump.conf 
nodns
script /root/bin/pumpage
mrwacky[root]/# cat /root/bin/pumpage
#!/bin/bash

if [ $1 = "up" ] ; then 
 mail -s "Lease $1" me@somehost.com << HERE
Here is the info: $1 $2 $3
HERE

fi
Comment 4 Eido Inoue 2004-01-05 11:03:22 EST
closing as supported products don't use pump anymore

Note You need to log in before you can comment on or make changes to this bug.