Bug 575717 - [abrt] crash in w3m-0.5.2-15.fc12: Process /usr/bin/w3m was killed by signal 11 (SIGSEGV)
[abrt] crash in w3m-0.5.2-15.fc12: Process /usr/bin/w3m was killed by signal ...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: w3m (Show other bugs)
12
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Parag Nemade
Fedora Extras Quality Assurance
abrt_hash:3859b735409709e11bda6612b3b...
: MoveUpstream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-22 04:42 EDT by Alfredo Pons Menargues
Modified: 2010-05-24 05:36 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-24 05:36:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (10.17 KB, text/plain)
2010-03-22 04:43 EDT, Alfredo Pons Menargues
no flags Details

  None (edit)
Description Alfredo Pons Menargues 2010-03-22 04:42:59 EDT
abrt 1.0.8 detected a crash.

architecture: i686
Attached file: backtrace
cmdline: w3m -o indent_incr=0 -o multicol=false -o no_cache=true -o use_cookie=false -o display_charset=utf8 -o system_charset=utf8 -o follow_locale=false -o use_language_tag=true -o ucs_conv=true -T text/html -dump /mnt/compartido/asolis/Skeletor.htm.htm
component: w3m
executable: /usr/bin/w3m
kernel: 2.6.32.9-70.fc12.i686
package: w3m-0.5.2-15.fc12
rating: 4
reason: Process /usr/bin/w3m was killed by signal 11 (SIGSEGV)
release: Fedora release 12 (Constantine)
Comment 1 Alfredo Pons Menargues 2010-03-22 04:43:03 EDT
Created attachment 401671 [details]
File: backtrace
Comment 2 Parag Nemade 2010-03-22 04:50:59 EDT
What is this Skeletor.htm.htm page? Can you also attach it? I think problem should be releated to this page only.
Comment 3 Alfredo Pons Menargues 2010-03-22 05:25:34 EDT
w3m is used and called by the Tracker (indexer program).


[apons@atlantis asolis]$ file Skeletor.htm.htm

Skeletor.htm.htm: Non-ISO extended-ASCII text, with very long lines, with no line terminators

Skeletor.htm.htm  size is 18 Mbytes.

The Skeletor.htm.htm file has private contents and I not allowed to send it.
Comment 4 Jens Petersen 2010-03-22 19:37:59 EDT
I think you need to reduce it to a smaller testcase:
try to work out if it is triggered one of the command-line options,
or what part of your file is causing the crash.

I also recommend reporting the issue to upstream
since they are much more familiar with the code-base.
Comment 5 Jens Petersen 2010-03-22 19:38:57 EDT
Also might be worth testing earlier versions of w3m if you think this is a regression.
Comment 6 Alfredo Pons Menargues 2010-03-23 07:28:17 EDT
I tried to reproduce the error in command line but I did not succeed. Even if I obtained the following warnings:

[root@atlantis apons]# w3m -o indent_incr=0 -o multicol=false -o no_cache=true -o use_cookie=false -o display_charset=utf8 -o system_charset=utf8 -o follow_locale=false -o use_language_tag=true -o ucs_conv=true -T text/html -dump /tmp/Skeletor.htm.htm
GC Warning: Repeated allocation of very large block (appr. size 8716288):
	May lead to memory leak and poor performance.
GC Warning: Repeated allocation of very large block (appr. size 26746880):
	May lead to memory leak and poor performance.
GC Warning: Repeated allocation of very large block (appr. size 26746880):
	May lead to memory leak and poor performance.
GC Warning: Repeated allocation of very large block (appr. size 26746880):
	May lead to memory leak and poor performance.
GC Warning: Repeated allocation of very large block (appr. size 26578944):
	May lead to memory leak and poor performance.
GC Warning: Repeated allocation of very large block (appr. size 26578944):
	May lead to memory leak and poor performance.
GC Warning: Repeated allocation of very large block (appr. size 26578944):
	May lead to memory leak and poor performance.
GC Warning: Repeated allocation of very large block (appr. size 26554368):
	May lead to memory leak and poor performance.
GC Warning: Repeated allocation of very large block (appr. size 26550272):
	May lead to memory leak and poor performance.
GC Warning: Repeated allocation of very large block (appr. size 26550272):
	May lead to memory leak and poor performance.
GC Warning: Repeated allocation of very large block (appr. size 26550272):
	May lead to memory leak and poor performance.
GC Warning: Repeated allocation of very large block (appr. size 26550272):
	May lead to memory leak and poor performance.
GC Warning: Repeated allocation of very large block (appr. size 26546176):
	May lead to memory leak and poor performance.
GC Warning: Repeated allocation of very large block (appr. size 26546176):
	May lead to memory leak and poor performance.
Comment 7 Parag Nemade 2010-05-24 05:21:29 EDT
Are you still able to reproduce this?
Comment 8 Alfredo Pons Menargues 2010-05-24 05:35:24 EDT
No, sorry. I do not happened again.
Comment 9 Parag Nemade 2010-05-24 05:36:47 EDT
I will close this now then. If again crashes report it in bz.
Thanks.

Note You need to log in before you can comment on or make changes to this bug.