This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 57584 - RH 7.1 updates kill booting of Nautilus machines
RH 7.1 updates kill booting of Nautilus machines
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
alpha Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-16 18:33 EST by Michal Jaegermann
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-07 19:46:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2001-12-16 18:33:30 EST
Description of Problem:

I got recently a UP1500 Alpha (Nautilus) board and tried to install
on it Red Hat 7.1 distribution plus updates.  The problem is that
2.4.9-12 current kernel fails to boot.  The machine hangs somewhere
in a startup process, both when attempting to boot multiuser and single,
and normally while accessing disks (turning on swap, attempting to
mount filesystems or in the middle of fsck if filesystem were dirty).
Lockups in fsck are anywhere after 25% to 60% of the whole thing done.

This is what 'cat /proc/cpuinfo' has to say:

cpu			: Alpha
cpu model		: SimulateLCA4
cpu variation		: 7
cpu revision		: 0
cpu serial number	: 
system type		: Nautilus
system variation	: 0
system revision		: 0
system serial number	: 
cycle frequency [Hz]	: 800000000 
timer frequency [Hz]	: 1024.00
page size [bytes]	: 8192
phys. address bits	: 44
max. addr. space #	: 255
BogoMIPS		: 1586.36
kernel unaligned acc	: 12 (pc=fffffc00008163e8,va=fffffc0000ad9e6c)
user unaligned acc	: 24 (pc=120000794,va=120099576)
platform string		: UP1500 800 MHz
cpus detected		: 1

There is 1 GB of a physical memory on board and one SCSI disk
SEAGATE Model ST336737LW attached to sym53c1010 controller.

Here is a list of various kernels which were tried on this machnine
and results:

2.2.20 plus various patches              - boots
2.4.2-010920 patched by a machine maker  - boots
2.4.3-12 from original RH 7.1            - boots
2.4.5-ac13                               - boots
2.4.7-10 (updates to RH 7.1)             - hangs in startup
2.4.9-12 (current updates to RH 7.1)     - hangs in startup
2.4.9-12custom (reconfigured and recompiled
  from kernel-source-2.4.9-12.alpha.rpm) - fails to start to load
2.4.13-ac8                               - boots

Some other kernels with versions higher than 2.4.13-ac8 which I tried,
in particular 2.4.17-rc1, just do not even start to load.  Nothing
past messages from a boot loader shows up on a screen and a machine
can be recovered only with a power switch.

In case you suspect SCSI driver the same version 1.7.3c-20010512 is
used by at least 2.4.5-ac13, which boots, and 2.4.9-12.

Version-Release number of selected component (if applicable):

kernel-2.4.9-12
Comment 1 Michal Jaegermann 2001-12-20 02:19:45 EST
Further developments:  I did recompile using the same tools ("clean" RH 7.1
with all current updates) 2.4.16, 2.4.17rc1 and 2.4.17rc2 on UP1100 and
these binaries boot and so far seem to work fine on that UP1100.  So some
of problems listed above can be caused by hardware faults in UP1500.

But 2.4.9-12 with Red Hat supplied binaries failed to boot UP1500.  I did
manage to boot with it UP1100 but system did not behave; I got in a short
order some "machine checks", which do not happen with other kernels,
and truly weird looking oopses. So there could be two separate problems
there (or an attack of "cosmic rays").
Comment 2 Alan Cox 2003-06-07 19:46:34 EDT
Alpha is no longer a supported platform

Note You need to log in before you can comment on or make changes to this bug.