Bug 575863 - autofs-5.0.5-22.fc12 update :new syntax error reading auto.master
Summary: autofs-5.0.5-22.fc12 update :new syntax error reading auto.master
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: autofs
Version: 12
Hardware: x86_64
OS: Linux
low
high
Target Milestone: ---
Assignee: Ian Kent
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-03-22 15:12 UTC by cgrebeld
Modified: 2010-03-25 22:34 UTC (History)
3 users (show)

Fixed In Version: autofs-5.0.5-23.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-03-25 22:34:16 UTC
Type: ---


Attachments (Terms of Use)
standalone tokenizer extracted from autofs-5.0.5-22.fc12 (6.09 KB, text/plain)
2010-03-22 20:50 UTC, Emmanuel Thomé
no flags Details
Patch - add locality as valid ldap master map attribute fix (1.41 KB, patch)
2010-03-23 03:35 UTC, Ian Kent
no flags Details | Diff

Description cgrebeld 2010-03-22 15:12:29 UTC
Description of problem:
Updating autofs causes auto mounting to fail, which is apparently related to a particular line in /etc/auto.master.  If I comment out that line, the error goes away.  If I revert autofs to the previous revision (autofs-5.0.5-18.fc12.x86_64), the error goes away.  NIS seems to be functioning normally, I can manually mount the directory.

Version-Release number of selected component (if applicable):
autofs-5.0.5-22.fc12

How reproducible:
Every time.

Steps to Reproduce:
1.add line to /etc/auto.master:
/u yp:lnxhomedirs nodev,bg
2.restart autofs
3.
  
Actual results:
In /var/log/messages:
automount[24698]: syntax error in map near [ /u ]

Expected results:
/u will be mounted based on ypbind map

Additional info:

Comment 1 Emmanuel Thomé 2010-03-22 20:48:47 UTC
Same here. I'd raise the severity if I could (although there is a quick workaround).

The problem is that the lexer file recognizes your line as the following sequence:

PATH
DNSERVER
DNNAME
OPTION
COMMA
OPTION

while it should be:

PATH
MAPTYPE
COLON
MAPNAME
OPTION
COMMA
OPTION

(see forthcoming attachment)

Quick fix for you (and me):

replace yp by e.g. yp,sun ; this will prevent the wrong dn match. Alternatively, you may put a space after the column.

Fix for autofs: I don't know / don't wanna know.

Comment 2 Emmanuel Thomé 2010-03-22 20:50:15 UTC
Created attachment 401871 [details]
standalone tokenizer extracted from autofs-5.0.5-22.fc12

This illustrates the problem. It's a trimmed down and bastardized version of master_tok.l and just prints the token list:

/tmp $ flex a.l         
/tmp $ gcc lex.yy.c -lfl
/tmp $ ./a.out /etc/auto.master
(prints the tokens)

Comment 3 Ian Kent 2010-03-23 02:52:59 UTC
(In reply to comment #1)
> Same here. I'd raise the severity if I could (although there is a quick
> workaround).
> 
> The problem is that the lexer file recognizes your line as the following
> sequence:

Yeah, it's the change that allows the LDAP location attribute
("l") that has caused this, sorry. It's not specific enough. I
was afraid I'd get caught with something like this, but I didn't
see any problems when I tested it. I obviously didn't check this.

snip ...

> 
> Quick fix for you (and me):
> 
> replace yp by e.g. yp,sun ; this will prevent the wrong dn match.
> Alternatively, you may put a space after the column.

Yep, that should work, or you can use nsswitch to tell
autofs what map sources you are using and leave out the
"yp:" altogether. Although you can get caught when a map
is present in multiple sources, such as when you have
"automount: files nis" in nsswitch.conf and your map
exists in /etc and in NIS. In this case the file map
would (well should) be used instead of NIS.

> 
> Fix for autofs: I don't know / don't wanna know.    

Hahaha, yeah, working on it.

Comment 4 Ian Kent 2010-03-23 03:35:12 UTC
Created attachment 401915 [details]
Patch - add locality as valid ldap master map attribute fix

I believe this fixes the problem.

While it's unfortunate you have been inconvenienced by this
it looks like the bug has been present for some time and the
locality change just exposed it.

Comment 5 Fedora Update System 2010-03-23 03:38:57 UTC
autofs-5.0.5-23.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/autofs-5.0.5-23.fc12

Comment 6 Ian Kent 2010-03-23 03:43:01 UTC
A build which includes the patch in comment #4 has been done
and I have requested it be pushed to the testing repository.

The build may also be found at:
http://kojipkgs.fedoraproject.org/packages/autofs/5.0.5/23.fc12

Please test this new build and report back.

Comment 7 Emmanuel Thomé 2010-03-23 06:24:11 UTC
(In reply to comment #6)
> A build which includes the patch in comment #4 has been done
> and I have requested it be pushed to the testing repository.
> 
> The build may also be found at:
> http://kojipkgs.fedoraproject.org/packages/autofs/5.0.5/23.fc12
> 
> Please test this new build and report back.    

works here. thanks.

E.

Comment 8 cgrebeld 2010-03-23 18:32:54 UTC
Works for me(In reply to comment #7)
> > The build may also be found at:
> > http://kojipkgs.fedoraproject.org/packages/autofs/5.0.5/23.fc12
> > 
> > Please test this new build and report back.    
> 
> works here. thanks.
> 

Works for me as well

Comment 9 Fedora Update System 2010-03-23 23:30:48 UTC
autofs-5.0.5-23.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update autofs'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/autofs-5.0.5-23.fc12

Comment 10 Fedora Update System 2010-03-25 08:26:25 UTC
autofs-5.0.5-23.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/autofs-5.0.5-23.fc13

Comment 11 Fedora Update System 2010-03-25 22:28:24 UTC
autofs-5.0.5-23.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2010-03-25 22:34:12 UTC
autofs-5.0.5-23.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.