Bug 575885 - freeglut error Unknown X Event type 96
Summary: freeglut error Unknown X Event type 96
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: freeglut
Version: 13
Hardware: x86_64
OS: Linux
low
low
Target Milestone: ---
Assignee: Tomas Smetana
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 574276 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-03-22 16:06 UTC by Tom Horsley
Modified: 2010-06-08 19:36 UTC (History)
2 users (show)

Fixed In Version: freeglut-2.6.0-5.fc13
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-06-08 19:36:44 UTC


Attachments (Terms of Use)

Description Tom Horsley 2010-03-22 16:06:30 UTC
Description of problem:

Running mesa-demos on my fedora 13 alpha boot partition results in demos
which (mostly) seem to work, but which also spew a near unlimited number of
Unknown X Event type 96 error messages to stderr.

I started with this mailing list thread:

http://lists.fedoraproject.org/pipermail/test/2010-March/089327.html

and that eventually led me to decide to submit this bug. Possibly this
is really related to bug 562607, but it seemed like a separate problem.

From that mailing list thread, it seems like the event type 96 is
really one of the SYNC extension events.

Version-Release number of selected component (if applicable):
freeglut-2.6.0-3.fc13.x86_64
mesa-demos-7.8-0.18.fc13.x86_64

How reproducible:
Virtually any of the mesa-demos programs will stream lots of these to
stderr.

Steps to Reproduce:
1.see above
2.
3.
  
Actual results:
error messages

Expected results:
no so many error messages

Additional info:

Comment 1 Tomas Smetana 2010-03-22 17:01:58 UTC
Hello,
  thanks for reporting.

I have this bug already reported but I admit I haven't gotten to examining it yet.  I will close the other bug since this one contains the links to related issues.

Comment 2 Tomas Smetana 2010-03-22 17:03:37 UTC
*** Bug 574276 has been marked as a duplicate of this bug. ***

Comment 3 Alejandro Guizar 2010-05-28 19:18:55 UTC
I have a custom application that uses freeglut and see a flurry of messages printed to stderr as well. It makes any other program output impossible to read. In my particular case the event type is 105.

freeglut (./final): Unknown X event type: 105

The component version is:
freeglut-2.6.0-3.fc13.i686

I wish freeglut simply ignored these unknown events as they do not affect the application. Oddly enough I don't recall the F12 package being this verbose.

Comment 4 Fedora Update System 2010-05-31 09:21:07 UTC
freeglut-2.6.0-5.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/freeglut-2.6.0-5.fc13

Comment 5 Fedora Update System 2010-05-31 18:20:56 UTC
freeglut-2.6.0-5.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update freeglut'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/freeglut-2.6.0-5.fc13

Comment 6 Fedora Update System 2010-06-08 19:36:35 UTC
freeglut-2.6.0-5.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.