This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 57597 - why is mkdirhier in this package
why is mkdirhier in this package
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.2
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-17 06:22 EST by Neil Prockter
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-17 06:23:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Neil Prockter 2001-12-17 06:22:59 EST
Description of Problem:
why is mkdirhier in /usr/bin/X11 and why is it in the Xfree86 package at all ( 
other than historical reasons)
I have many server running quite happily without X and it seems mkdirhier is 
perfectly usable without X and should be in fileutils

sorry if this is the wrong arena for this comment

Version-Release number of selected component (if applicable):


How Reproducible:


Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:
Comment 1 Mike A. Harris 2001-12-17 16:09:08 EST
mkdirhier is a part of XFree86, which is why it comes with XFree86.
It is used by XFree86 during the build procedure since not all systems
that XFree86 is available for, have a mkdir command that can create
multilevel directory structures.  It is included in our binary
distribution of XFree86 so that other external software that also
relies on it, can find it.  It is a miniscule bourne shell script.

It isn't part of fileutils and wont ever be.  mkdir -p serves
the same purpose.

Note You need to log in before you can comment on or make changes to this bug.