Bug 5760 - /etc/sysconfig/network-scripts/ifup-alias prints horrible messages if you compile a kernel without ip aliasing support
/etc/sysconfig/network-scripts/ifup-alias prints horrible messages if you com...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
6.0
All Linux
low Severity low
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-09 03:59 EDT by Hunter, Sean
Modified: 2014-03-16 22:10 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-10-10 00:28:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hunter, Sean 1999-10-09 03:59:13 EDT
As above.  This patch fixes it:

--- /tmp/ifup-aliases	Sat Oct  9 08:52:10 1999
+++ ifup-aliases	Sat Aug 28 18:15:38 1999
@@ -1,5 +1,9 @@
 #!/bin/sh

+if [ ! -f /proc/sys/net/core/net_alias_max ]; then
+    exit 0
+fi

 # adds aliases of device $1

 if [ "$1" = "" ]; then
Comment 1 Bill Nottingham 1999-10-10 00:28:59 EDT
The messages are because linuxconf's alias detection is
fairly broken; it's worked around by commenting out the linuxconf
specific portions. This is what's done in 6.1.

However, the workaround you suggest is probably a good idea - we'll look at that for a future initscripts release.

Note You need to log in before you can comment on or make changes to this bug.