Bug 57601 - ical dumps core on startup
Summary: ical dumps core on startup
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: ical (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-12-17 14:02 UTC by bil kleb
Modified: 2007-04-18 16:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-17 14:14:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description bil kleb 2001-12-17 14:02:35 UTC
Description of Problem: ical experiences segmentation fault during startup

Version-Release number of selected component: 2.2-21

How Reproducible: everytime.

Steps to Reproduce: type 'ical' at command line

Actual Results: Segmentation fault (core dumped)

Expected Results: no error message.

Additional Information:

This started occuring about a week after doing an up2date on my system,
including an update of the kernel from 2.4.2-2 to 2.4.9-12

I removed my .calendar file, removed the ical rpm, reinstalled,
and still experience the same fatal results.

I might try compiling from source...

Ical's home is currently Not Found: 
http://www.research.compaq.com/SRC/personal/Sanjay_Ghemawat/ical/home.html

Comment 1 bil kleb 2001-12-17 14:14:08 UTC
I tried compiling ical-2.2.tar.gz, but configure complains of an incorrectly
installed Tcl/Tk (the --with's were requested by configure):

$ sudo ./configure --prefix=/usr/local/pkgs/ical-2.2 --with-tclsh=/usr/bin/tclsh
--with-tclconfig=/usr/lib
loading cache ./config.cache
checking for a BSD compatible install... /usr/bin/install -c
checking for ranlib... ranlib
checking whether ln -s works... yes
checking for Mail... /usr/bin/Mail
checking for c++... c++
checking whether we are using GNU C++... yes
checking whether c++ accepts -g... yes
checking for POSIXized ISC... no
checking Tcl/Tk installation
checking for tclsh... /usr/bin/tclsh
checking for tclConfig.sh... /usr/lib/tclConfig.sh
checking for tkConfig.sh... /usr/lib/tkConfig.sh
checking for installed Tcl/Tk library files... /usr/lib/libtcl8.3${TCL_DBGX}.so
not found
configure: error: Make sure Tcl/Tk are installed correctly on your
system and then rerun configure.

Comment 2 Ngo Than 2001-12-17 15:50:56 UTC
please try ical-2.2-25 from RHL 7.2. it works for me.

I know the url is not valid, but I don't know a valid one!


Note You need to log in before you can comment on or make changes to this bug.