Bug 57602 - Installer hangs when compiling "FvwmConfig.C" with Intel Proton compiler.
Summary: Installer hangs when compiling "FvwmConfig.C" with Intel Proton compiler.
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: fvwm2 (Show other bugs)
(Show other bugs)
Version: 7.2
Hardware: i586 Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-12-17 14:44 UTC by Need Real Name
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-17 14:44:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
simpl test to describe situation (133 bytes, patch)
2001-12-17 16:11 UTC, Need Real Name
no flags Details | Diff
output file (792 bytes, text/plain)
2001-12-17 16:16 UTC, Need Real Name
no flags Details

Description Need Real Name 2001-12-17 14:44:28 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)

Description of problem:
Compilation aborted for FvwmConfig.C during installation of fvwm2-2.2.5-
4.src.rpm with Intel Proton compiler in place of gcc and c++. There are 
two reasons for it:

1) Information to determinate macro HAVE_MEMCPY  were prepared 
in "configure" but not used due to error in "config.status". There are no 
appropriate strings about HAVE_MEMCPY. New "config.status" without error 
attached.

2) Intel Proton compiler for c++ (icpc) emits errors if abs defined before 
including "iostream.h". The simple test to demonstrate this situation 
attached with the name "test.C". The second attached file "test.out" 
contains diagnostics when "test.C" is compiled with icpc compiler. It is 
not the error of compiler, but user should to define "abs" only after 
including "iostream.h".  User has the analogous situation when he try  to 
include "stdlib.h" after abs-definition. In application  fvwm2 user solve 
this problem with  macro HAVE_STDLIB_H to include "stdlib.h" in good time. 
It is necessary to make anything for "iostream.h", too.  

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
 If you haven't Intel compiler (icc) you will not be able to reproduce 
this error. 
If you have Intel compiler:
1. Make sure, that Intel compiler will be called instead of gcc, g++ and 
so anyway.
2. Install fvwm2-2.2.5-4.src.rpm(-i option for rpm).
3. Try to build fvwm2.spec(-bc option for rpm).	

Actual Results:  Building fvwm2 without errors.

Additional info:

Comment 1 Ngo Than 2001-12-17 15:28:52 UTC
we don't support Intel Proton compiler.

Comment 2 Need Real Name 2001-12-17 16:11:32 UTC
Created attachment 40827 [details]
simpl test to describe situation

Comment 3 Need Real Name 2001-12-17 16:16:18 UTC
Created attachment 40828 [details]
output file

Comment 4 Ngo Than 2001-12-17 16:34:14 UTC
please try 2.4.3-3. It should work.


Note You need to log in before you can comment on or make changes to this bug.