Bug 576105 - [kn_IN] The space between close bracket and the character is very less
Summary: [kn_IN] The space between close bracket and the character is very less
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: lohit-kannada-fonts
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Pravin Satpute
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 577127
TreeView+ depends on / blocked
 
Reported: 2010-03-23 09:27 UTC by Shankar Prasad
Modified: 2015-04-21 04:34 UTC (History)
4 users (show)

Fixed In Version: lohit-kannada-fonts-2.4.5-4.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 577127 (view as bug list)
Environment:
Last Closed: 2010-12-09 21:57:57 UTC
Type: ---


Attachments (Terms of Use)
Shows the actual result (239.86 KB, image/png)
2010-03-23 09:27 UTC, Shankar Prasad
no flags Details
patch for fixing this bug (8.27 KB, patch)
2010-10-18 09:42 UTC, Pravin Satpute
no flags Details | Diff
updated kannada font (194.46 KB, application/octet-stream)
2010-11-22 11:02 UTC, Pravin Satpute
no flags Details

Description Shankar Prasad 2010-03-23 09:27:08 UTC
Created attachment 401977 [details]
Shows the actual result

Description of problem:
In the text containing the Kannada text, space between close bracket and the character is very less. Hence the close bracket appearing as merged with the character. This usually happens in case of complex character.

Version-Release number of selected component (if applicable):
lohit-kannada-fonts-2.4.4-3


How reproducible:
Everytime

Steps to Reproduce:
1. Login Kannada locale
2. Open gedit and copy paste the following text: ನೆರವಿಗಾಗಿ) ಭಾಗದಷ್ಟು) ಫೆಡರಾಟ್ಸಿ)
3. Look at the space between the close bracket and the last character of each word
  
Actual results:
The space between the close bracket and the text is very less

Expected results:
The space should be so that the bracket doesn't actually merge with text.

Additional info:

Comment 1 Pravin Satpute 2010-03-23 09:32:13 UTC
presently lohit kannada doesnt have latin panctuation marks, so using round brackets from default ascii fonts.
i will add these characters in the next release of lohit kannada, so we can handle this better.

Comment 2 Fedora Update System 2010-03-23 10:57:50 UTC
lohit-kannada-fonts-2.4.5-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/lohit-kannada-fonts-2.4.5-1.fc13

Comment 3 Fedora Update System 2010-03-23 23:25:38 UTC
lohit-kannada-fonts-2.4.5-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update lohit-kannada-fonts'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/lohit-kannada-fonts-2.4.5-1.fc13

Comment 4 Fedora Update System 2010-03-25 22:33:40 UTC
lohit-kannada-fonts-2.4.5-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 5 Pravin Satpute 2010-10-11 06:44:41 UTC
still right bracket merging 

see ನೆರವಿಗಾಗಿ) ಭಾಗದಷ್ಟು)  ಫೆಡರಾಟ್ಸಿ)

reopening bug

Comment 6 Pravin Satpute 2010-10-18 09:42:24 UTC
Created attachment 454060 [details]
patch for fixing this bug

this increasea kerning when -ve RBearing character will follow latin character

Comment 7 Fedora Update System 2010-10-18 10:40:43 UTC
lohit-kannada-fonts-2.4.5-3.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/lohit-kannada-fonts-2.4.5-3.fc14

Comment 8 Fedora Update System 2010-10-18 20:53:53 UTC
lohit-kannada-fonts-2.4.5-3.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update lohit-kannada-fonts'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/lohit-kannada-fonts-2.4.5-3.fc14

Comment 9 Shankar Prasad 2010-10-19 07:37:14 UTC
I just tested latest build. Though it looks fixed the above three examples and of similar kind but issue still exists in cases like ಡೆಸ್ಕ್‍) ಟೆಸ್ಟ್‍) where the zwj is used before the bracket.

Comment 10 Fedora Update System 2010-10-28 05:49:24 UTC
lohit-kannada-fonts-2.4.5-3.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Pravin Satpute 2010-10-28 06:05:34 UTC
part of bug fixed string having ZWJ in between i.e. ಡೆಸ್ಕ್‍) ಟೆಸ್ಟ್‍) are still overlapping

Comment 12 Pravin Satpute 2010-11-22 08:28:15 UTC
i have tried lot to write gsub or gpos rules that will move right bracket move when it will followed by ZWJ, but it not working looks like problem from rendering engine.

i will build lohit with this rule then we can report bug against pango for gsub not working

Comment 13 Pravin Satpute 2010-11-22 10:59:35 UTC
added rules in lohit for zwj stuff, now we can report bug against pango, i.e. rules not working

Comment 14 Pravin Satpute 2010-11-22 11:02:50 UTC
Created attachment 461969 [details]
updated kannada font

shankar,

  i have added rules for zwj stuff, those are not working since problem in rendering engine.
  it will be nice if you can test one attached ttf file for if there is any regression, so i can build it tomorrow

Comment 15 Shankar Prasad 2010-11-22 11:48:37 UTC
Works fine with regular combinations where zwj is not used. I didn't notice any regressions.

Comment 16 Pravin Satpute 2010-11-22 16:11:47 UTC
cool, i will build it tomorrow

Comment 17 Fedora Update System 2010-11-23 06:06:28 UTC
lohit-kannada-fonts-2.4.5-4.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/lohit-kannada-fonts-2.4.5-4.fc14

Comment 18 Fedora Update System 2010-11-23 21:55:57 UTC
lohit-kannada-fonts-2.4.5-4.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update lohit-kannada-fonts'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/lohit-kannada-fonts-2.4.5-4.fc14

Comment 19 Pravin Satpute 2010-11-26 05:16:35 UTC
upstream bug is already filed :)
https://bugzilla.gnome.org/show_bug.cgi?id=635391  i have commented there now, feel free if you want to report this in fedora we all. Do give upstream bug reference

Comment 20 Fedora Update System 2010-12-09 21:57:51 UTC
lohit-kannada-fonts-2.4.5-4.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.