Bug 57612 - Keyboard doesn't work in X's Failsafe mode
Keyboard doesn't work in X's Failsafe mode
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-17 12:05 EST by jcmain
Modified: 2007-04-18 12:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-17 12:05:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jcmain 2001-12-17 12:05:41 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.4)
Gecko/20011019 Netscape6/6.2

Description of problem:

It seems that since installing 7.2, my X Windows failsafe mode no longer
works correctly. The failsafe screen comes up with the single xterm, but
the xterm never seems to get focus, so I cannot type anything in the xterm.
Also, there are no menus available from the root window. The strange thing
is that I can cut and paste from and to the xterm.

It worked using 6.2, but has not worked since I installed (I didn't use the
upgrade option) 7.2.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Select failsafe from kdm
2. Enter username and password
3. Click Go!


	

Actual Results:  X actually comes up and there is an xterm with no window
management in the lower right corner of the screen, but the window never
seems to get focus except through cut and paste. No menus appear by left or
right clicking on the root window.

Expected Results:  Should be able to type commands in the xterm.

Failsafe mode worked as expected on 6.2.

Additional info:

Nothing unusual appears in the logs.

Let me know what kind of debugging to turn on, and I'll send the output to you.
Comment 1 Mike A. Harris 2002-01-24 19:56:59 EST
That is correct behaviour.  You're starting X up with no desktop
environment, and no window managers.  All of the things you are
claiming thtat are missing are all features of either a window
manager, or a desktop environment.  If you want to have window
management, and desktop management, then you must run a window
manager, or KDE or GNOME, etc.  The raw Xserver with an xterm
running in it is not very useful.

Note You need to log in before you can comment on or make changes to this bug.